When I generate a slideshow Shotcut just keeps freezing

When trying to make a slideshow, Shotcut always freezes when I get to the generating the slideshow stage. I’ve tried to do it in Proxy but it makes no difference. I have 59 photos in my slideshow. I’ve done much longer ones in the old Photostory windows program I used. That will only do 3:4 aspect ratio. I’m keen to do 16:9 ones now that my camera takes that size. I hope someone can help as I really like the Shotcut interface. I have 4g ram on my laptop. Might that be an issue?

The 4GB of memory is almost certainly the issue. The FAQ states that the minimum requirements regarding memory are:

RAM: At least 4 GB for SD, 8 GB for HD, and 16 GB for 4K.

NOTE: If your computer is at the lower end of CPU and RAM requirements, you should use both the Preview Scaling and Proxy features to help reduce preview lag.

Try rebooting your system and running Shotcut without anything else open. Also you might want to look at the Task Manager->Performance-MEM utility to see if you come close to exceeding your memory limit and start paging.

1 Like

Thank you for your response Elusien. I have tried all your suggestions and it still freezes during the generation part of the slide show. Very disappointing.
I won’t uninstall it yet in case someone else comes up with another solution. I have the latest version I think, 20.09.27. I don’t suppose an older version would be any better.



Stable Version is 21.03.21, try it, it might be more smooth and responsive.

In addition to the upgrade and reboot suggestions above you also need to reduce the project resolution using Settings > Video Mode > Non-Broadcast > 850x480 16:9 NTSC as suggested in this #docs page

Thank you for the suggestion. I’ll try that when I get another couple of hours of time and some more stamina! I’ll let you know if it works.

So a 32bit PC, then it will be slower and give you limited performance, A 32 bit PC only supports ram upto 4GB and give performance lot more bad and slower than a 64 bit one. You should try to buy a new PC or laptop, or you could get a 2nd or 3rd hand laptop/PC, And the cheapest option is to go to the nearest cyber store and and use it for the time you want and then pay them a few bucks.

That may may explain why there is no download available for the 32-bit PC. I’ve been hanging on to this old laptop with Windows 7 since 2011 as I don’t like the newer versions as much. It still goes well, apart from Shotcut. I am going to have to learn how to use Linux OS, which I have dabbled with a bit, if things go bad. Thank you for your reply.

In case others with similar problems come to this discussion, I am adding some advice I got from Graphicious by Cristi Cotovan who has a good tutorial on Youtube on how to use Shotcut to make a slideshow with music:
“Can you try resizing the images externally before adding them to the Shotcut timeline/media bin? Maybe they are too large, make them 1920 x 1080 (or whatever maximum your video is), and see if it works. Maybe you’re hitting a memory limit. Also helps to update to the latest version of Shotcut. Also, if nothing works, try reducing the transitions, instead of Random, if that’s what you’re using, use a simple one, and see if there’s maybe a problem with the transition or one of the transitions being applied.”
“If you only have 4GB ram, that’s probably the reason. I think your computer may be struggling to give Shotcut the memory it needs to process this. Try making shorter slideshows, for example only use half the photos, render the video and then half and render another video, separate project. Then you can stitch together these videos either in Shotcut or in Losslesscut. I have a tutorial on how to do that in a few seconds: [https://youtu.be/USMXFmJfYZo]”

Slideshow tutorial: Create Slideshows from Photos in SECONDS | Quickest, Easiest, FREE Slideshow with Music | Shotcut - YouTube

Show less


Yes, windows 7 is unsafe now, but shotcut still supports windows 7 64 bit. You could use the 64 bit version of windows 7 and be hassle free.

This topic was automatically closed after 90 days. New replies are no longer allowed.