Video isn't displaying at all

I’ve been using Shotcut for a while, but it’s suddenly stopped working properly. Whenever I go to edit a video, the video doesn’t display at all. I can’t move the white triangle on the master timeline (or whatever the one higher up is called), and hitting the play button does nothing. Moving the arrow position in the video tracks at the bottom of the screen does nothing. Then, when I go to close the program, Windows 7 has to force close it.

I’ve tried many things:

  • This issue persists with different videos and file types.
  • I made sure Shotcut was up to date.
  • I uninstalled Shotcut and reinstalled it.

None of this is working. Is there something I’m missing? Thanks in advance for the help.

Does it work if you do not load an existing project?
Just open Shotcut and choose File > Open Other > Noise > OK
Do you see and hear noise? If not, try the different options in Settings > Display Method;

I checked the Noise thing and yes, I did see and hear noise. I actually tried loading an existing project, and that seems to have fixed things. Yay.