Video does not fill screen

I have a Canon SD fs2000 camcorder at which I exported all the scenes I wanted for editing. The editing is done. When I originally viewed the video clips before exportation, the video filled the screen in shotcut but when I exported the clips I wanted to work with…the video on the left and right is short of the entire screen. The top and the bottom fill the screen though.

I exported the resolution at 640x360 with an aspect ratio at 16:9 (as recommended).

I tested exportation when all done without any adjustment of numbers from the camera into shotcut without setting any resolution or aspect ratio in shotcut perimeters at which the camera read 720x480 and an aspect ratio of 16:9 and after exporting, it was full screen. The problem is, I did all the exporting already before I came to that conclusion and I want the video to fill the screen without any re-editing or cropping to be done. I exported the video to hard drive twice…once not adjusting any resolution settings and a second time using the resolution set to 1920X1080 and to my surprise…no difference. There are still two black bars on the side of the screen. What am I not doing right?

John Paul

There are 2 resolutions to consider: first is the project resolution - it is set via Settings → Video Mode and it’s the most important, choosing the correct one will get rid of your black bars. The other resolution is the one in export panel, this one will be what the .mp4 file will use.

You need to change Settings → Video mode to the correct one in your original recording, maybe PAL SD? or something like 720x480 at 16:9 aspect ratio. Actually, first try clicking on Automatic, maybe it’ll set the proper resolution for you.

Btw, your videos don’t use square pixels this is why the numbers are not standard and you have this problem.
And you should make a backup to the curreny project file in case changing resolution will mess your timeline.

The black bars is caused by a mismatch in aspect ratio. To suggest the best parameters, can you please provide:

  1. The Video Mode setting or your project
  2. A screenshot of the properties panel for one of your clips

Hi and thank you for your responses…

The camera would read outrageous numbers when it came to resolution and aspect ratio when first loading it into computer. Not the normal resolution and aspect ratio recommended.
I was able to somehow make a border of black framing around the video and then went into zoom effect and filled the video to fit it in nicely without cropping or distortion of video. . I forget now how I did it as there are many choices. The automatic in itself choice didn’t work, I had to set some other numbers (maybe in custom). Thank you, yes…I should have used the formula of 640 by 480 resolution with an aspect ratio of 16:9 when I first exported video. Someone onetime suggested 640 by 360 resolution which I found out gave the screen the black bars, I didn’t know. Next time I won’t have that problem. The camcorder I have is a Canon FS200.

John Paul

Based on my research, the FS200 records 720x480 4:3 MPEG2.

So your Video Mode should be set to “SD NTSC” to fit the image properly.

This topic was automatically closed after 90 days. New replies are no longer allowed.