Video/Audio Preview Fine, Gone in track

I had been working on editing an mp4 file that, originally, was able to be moved from the preview screen to an video track without issue - the audio and video played fine. However, shotcut and my computer was not running right and my husband had to fix my computer and do a few things (I run a podcast and edit several mp4 files this way - I had just finished one that near the end and during export I noticed both computer and shotcut running poorly/slow, when I moved onto this mp4 file, things stopped functioning correctly completely). That fixed the overall functionality of my computer (I was unable to run any other program on my computer while working within shotcut - not even chrome) and also allowed shotcut to begin working properly. However, that one mp4 I was working on no longer had audio or visual in the track. I closed out that MLT file and began a new one with the same problem - it showed on the preview screen, but when I moved it to the video track it had no audio and no video. I deleted the mp4 file and redownloaded it from the google drive I got it from and tried again with the new download. Same problem. I had the person who saved the mp4 file to my google drive upload a new version of it and I downloaded that with the same problem. I have tried three completely, unrelated mp4 files in shotcut with zero issues; this is the only mp4 I am having issues with. Any suggestions or feedback? I’m not tech savvy but have been using shotcut for over a year on my windows pc and have never had this problem.

Without knowing the specifics of your project, or the mp4 file itself it would be very difficult to give a solution.

Specifics include

  • Video Mode used.
  • Properties view of the Source MP4 in question, including the Audio tab of that file.
  • Filters applied to that file.
  • Export settings used.

If the MP4 file you have has a variable frame rate, it may not be seeking well with Shotcut. Converting the file with Shotcut may solve the immediate issue.

Also ensure you have the latest version of Shotcut, which at this time is 22.04.25.

Is the source MP4 file on one of your computer’s drives? Ensure it’s on an SSD or NVME-type data drive for the fastest speeds. Having that file on HDD (Hard Disk Drive) will make things slower with Shotcut.

Do you get the same result after you restart your computer and leave all other programs closed?

I restarted my computer and the program and it all was the same. Just on that one single video.

However, I just showed this to my husband and he got me the newest version, but we were still having a problem. So, he cleaned out the cache and proxy folders shotcut was using and now the video works. So I guess shotcut couldn’t read the difference between the video that got screwed up and the new video with the same information until we deleted the info from the cache and proxy folders.

Thank you for your help!

This topic was automatically closed after 90 days. New replies are no longer allowed.