Variable Frame-Rate video clips import with choppy video

I’m not exactly sure what is going on, but I have an odd issue with one of my source video clips: Namely, when it is imported, it seems to be playing back at a choppy frame-rate, which persists through editing, and even exists in the exported video file. However, when I playback the footage via VLC, It plays as smoothly as expected. Oddly, this issue only exists when the project’s video resolutions are 720p or higher. Using 640x480 NTSC or similar project formats fixed the problem. The video source is 640x480 at 30 frames per second.

Perhaps it’s best illustrated via some videos. Below, I’ll put links to two short clips. One is the source footage (i.e. this is how it appears when imported/exported by shotcut when set to 640x480 NTSC), and the second is the same clip, as imported/exported by shotcut when set to 720p 30.

Source video clip

Exported video clip

A special note: using 720p or higher project formats at 60 FPS partially fixes the problem; the video plays back smoothly at points, but it is still rather choppy.

My bad: The problem is on my end. Apparently, my “30FPS” videos are being read by both VLC and Shotcut as having a frame rate of 1000FPS, indicating a problem with settings for my encoder. I apologize for wasting your time. Please feel free to close this topic.

1000 fps is often a sign that it is variable frame rate, which is not supported by Sotcut for editing. So, look for an option in your encoder about variable or constant frame rate.

Thanks. I didn’t know about that: I made sure that my encoder was not set to variable Frame Rate, and then I recorded. Sure enough, it appears correctly in Shotcut, and VLC reports the proper frame rate. I’ll keep that in mind the next time I record.

I have the same problem, I don’t know what to do, I can´t understand anything about VLC or 1000 fps or the encorder. Please help

Ok, first, we need to see if your video clip has a variable frame-rate. Import your file into Shotcut and look in the properties tab. If, in the frame-rate section, it says 1000, it has a Variable Frame Rate, and it won’t play properly in Shotcut. If it says anything else (30, 60, i.e: your video’s true Frame-rate), it has a Constant Frame Rate, and it should play normally in Shotcut.

If your video file has a Variable Frame Rate, you have two options:

  1. Re-Record your source material, using Constant Frame Rate. In whatever video recording software you’re using, look for an option that Says Variable Frame Rate, VFR, or something similar. Make sure it is disabled. You could also try other encoders or file container formats (in my case, MKV wasn’t working for some reason, but FLV did).

  2. Re-encode (i.e: convert) your video clip. You can use other software like HandBrake (a Free, Open-Source video converter program) to convert your current VFR video into a constant Frame Rate source. Look for an option mentioning Constant Frame Rate, and enable it. Be sure to set the proper frame-rate before you start converting.

If you need anything else, just let me know.

Oh really thank you… But my Frame rate says 29,97 and when I export the video, looks really normal, no with choppy video… The edition is tricky but the outcome it’s normal. I don’t know what to do

29.97 is actually a standard frame-rate (it’s a NTSC (North American TV) Standard, to be exact). If it exports just fine, you should be ok. If you are referring to choppy video playback while editing, that’s actually a performance issue. It’s no secret that video editing can be resource intensive, so you can’t really do much with that (barring an upgrade to your existing hardware), but there are a few things you can do to mitigate the issue.

  • Use a lower project resolution. The Shotcut FAQ suggests that users with 4GB of RAM stick with Standard Definition (480p) project formats, and users with 8GB can go up to High Definition (1080p). You can change your Project format at anytime by using Settings > Video Mode, but it’s best to do so before starting a new project, as doing this with an existing project will irreversibly mess up video timings, and possibly, how they display.

  • Keep it simple. Try to use a limited amount of video filters and overlays. If you are using multiple video clips and pictures, make sure that each picture/clip is at or below the project’s video resolution.

  • If all else fails, turn on Real-Time mode, and work through it. Real-time mode, available under Settings > Realtime (frame dropping), deliberately drops frames of video during playback (i.e: causing that choppy video during editing, but not in the final export), to make sure that one second of video plays for each second of real time. With Real-time off, the video/project plays back as fast as your computer can process it, meaning that playback will be slowed down if it cannot process the video in time.

Yess!! Oh really thanks, change the resolution worked… But I have another question, why the videos I export have a blake frame? I want just the video without that

I’m not quite sure what you’re talking about, If there are any gaps in between video clips, even if it is one frame, that frame will be black/blank. you can right click on a gap that exists and select remove to clear out any gaps in between videos.

If you still need help, I’m going to ask that you open a new thread, as it’s no longer related to this thread’s original topic. To keep this from growing longer than it needs to be, open up a new topic in the “Help/How To” Section.

White frames are from changing the video settings during a project.
It has something to do with dropping frames for different video formats. Always adjust settings, then bring in files to be used. I recommend saving a “new” project with favorite settings as Untitled.mlt - then every time you start a “new” project it will have those settings already. It’s how we did it in the old days. :smiley: