V19.06 BETA now available


#1

Rules of Participation (Important)

  • Provide all feedback as a reply within this thread or as a GitHub Issue.
  • If using a GitHub issue, make sure you indicate the version.
  • You can reference other threads from this thread, but do not confuse others by opening new posts/threads.
  • Do not report about existing bugs that have not been indicated as fixed by this version.
  • The beta period will last 10 - 14 days.
  • We are only interested in major regressions over recent versions (v19.01 and newer).
  • We are also interested in major bugs in new features and changes specific to this release.
  • There will only be another beta released if there is a critical problem that needs confirmation from testers after the fix.
  • The actual release may add some low risk fixes and additions (e.g. new filter) over the beta.

Download

Get the beta release from this GitHub page that also includes the list of fixes, changes, and additions.

Thank You For Your Help!


Blur not covering sensitive content at bottom of screen
pinned #2

#3

Windows 10.
The Crop:Rectangles position keyframe is broken. When the stopwatch icon is pressed the position and size coordinates are reset to zero. If the playhead is at the beginning of a clip one keyframe node is generated. If the playhead is at any other position, 2 nodes are created. One at the beginning of the clip and one at the playhead.

Screenshots

57%20PM

57%20PM%20001

58%20PM

The corner radius keyframe is working properly.


#4

Mac OS10.11.6
Same observation as @Sauron
The new button for creating keyframes is very convenient.
However, it does not correct the creation of 2 keyframes at a frame interval.
I think that the calculation of the position of the playhead is different according to the section where we are. Maybe a different rounding calculation between 2 files?
See the video below. When I command the playhead from the source drive’s controls, it’s at 2; 16 sec. When I click on the button a keyframe is created at 2; 16 s, but the playhead moves at 2; 17 s

https://streamable.com/42x97

In the next video, I do the same thing, but I position the playhead directly in the Keyframes title bar. The keyframe is well positioned at 3: 13 sec and the playhead remains at this position.

https://streamable.com/ak6u4

When opening a project containing Keyframes, the “chronometer” button in the filter section is no longer selected.

Despite changing the color filter areas, the horizontal scroll bar still does not allow access to the entire area.


That’s why I’m using the workaround I mentioned in another post.

I modified line 175 of the file
Shotcut.app/Contents/Resources/shotcut/qml/views/filter/filterview.qml
like this:

Math.max(150 + filterConfig.minimumWidth, // (rajouté 150 +)

It seems to fit all filters, but probably on the other systems there will be a large margin at right


#5

I tried a project today with the same configuration as the last 8.
To know:
V1: Video 1920x1080 mkv format.
V2: SVG image with transparent template for marks.
V2: Song cover.

Effects in track V1: Video fade (input and output), Gain and volume through keyframes in the beginning and end of the video.
Normalization: two steps (-16 LUFS)
Effects on track V2: None (hidden)
Effects on track V3: Size and position to adjust the cover to its position. Video fade in-out

I exported with YouTube preset (as many other times), however, the video appears reduced. The resolution of the video is finally 1920x1080, but it’s really less because the content is framed.
Here I show an image.

I tested the project in the stable version and was able to export the video correctly.

This is the project in the beta version:
Nik Kershaw.mlt (14.1 KB)
This is the project repaired when I ran it in the last stable version.
Nik Kershaw - Reparado.mlt (13.1 KB)

Edition 2019:06:09
The problem does not seem to be related to any filter as I tried an export of a video without any filter or clipping and the video obtained was within a frame.
I tried disabling hardware encoder but the result was the same.

I created a new project to provide more data:
Data from the source video file: Video source data.txt (2.8 KB)

Rendering record (incorrect) in Shotcut beta version:
Rendering log (video within frame) Shotcut Beta version.txt (1.9 KB)

Rendering log (correct) in the latest stable Shotcut version:
Rendering log (video OK) Shotcut latest stable version.txt (161.0 KB)

Additionally, I imported a wallpaper.png (1920x1080) I added it to the timeline and exported it to YouTube preset. The result was correct. The resulting video was not within a frame.


#6

by clicking on the position size keyframe button of the Crop: Rectangle video filter, changed all the size and position value to Zero.

Crop:Rectangle keyframming issue-Shotcut

Another issue is that the Glitch filter’s preset button is not aligned in one row.


#7

Fixed for next version.

Fixed


#8

Fixed


#9

This is not a new problem and is intermittent. I need to spend more time on this, but fixing may require changing every filter UI, and this might not be done for the next release, which has some much more critical bug fixes to get out.


#10

I do not reproduce this, and there might be something about your OS display or text size that is affecting this. Qt Quick, which is used for the UI is supposed to account for these sort of OS settings to prevent this, but this filter integrates some custom C++ widgets that may be affecting things.

That’s why I’m using the workaround I mentioned in another post.

The problem with this workaround is that it simply adds 150 to every filter UI’s (ui.qml) declared width. That is what we call a “fudge factor” and is not acceptable because then developers unknowingly start to configure the declared width with this constant in place and not remembering about it. Suddenly, you are back in the same place because, for example, something that should have been 450 is now configured as 300.

The problem with simply increasing the width and height of this filter is that it simply makes the custom circular control larger and require more space.

In qml/filters/color/ui.qml , can you please experiment with the lines that set implicitWidth for each ColorWheelItem? Maybe it needs something like -20 appended to each one because the current expression does not factor in scrollbars that might be showing.

--- src/qml/filters/color/ui.qml
+++ src/qml/filters/color/ui.qml
@@ -235,9 +235,9 @@ Item {
         // Row 3
         ColorWheelItem {
             id: liftwheel
             Layout.columnSpan: 3
-            implicitWidth: parent.width / 3 - parent.columnSpacing
+            implicitWidth: parent.width / 3 - parent.columnSpacing - 20
             implicitHeight: implicitWidth / 1.1
             Layout.alignment : Qt.AlignCenter | Qt.AlignTop
             Layout.minimumHeight: 75
             Layout.maximumHeight: 300
@@ -271,9 +271,9 @@ Item {
         }
         ColorWheelItem {
             id: gammawheel
             Layout.columnSpan: 3
-            implicitWidth: parent.width / 3 - parent.columnSpacing
+            implicitWidth: parent.width / 3 - parent.columnSpacing - 20
             implicitHeight: implicitWidth / 1.1
             Layout.alignment : Qt.AlignCenter | Qt.AlignTop
             Layout.minimumHeight: 75
             Layout.maximumHeight: 300
@@ -307,9 +307,9 @@ Item {
         }
         ColorWheelItem {
             id: gainwheel
             Layout.columnSpan: 3
-            implicitWidth: parent.width / 3 - parent.columnSpacing
+            implicitWidth: parent.width / 3 - parent.columnSpacing - 20
             implicitHeight: implicitWidth / 1.1
             Layout.alignment : Qt.AlignCenter | Qt.AlignTop
             Layout.minimumHeight: 75
             Layout.maximumHeight: 300

#11

I do this.
I remove +150 in shotcut/qml/views/filter/filterview.qml
Here is with original files (qml/filters/color/ui.qml)
14

Here is with your modification (add - 20 for each ColorWheelItem)
23

There is no modification for the horizontal scrollbar, but the vertical scrollbar allows lowering down and the wheels are smaller.


#12

This is fixed for the next version.


#13

Have you tried with the French language?
I just did the test with the English language and it’s OK.

07

Since the text in French is longer than the text in English, can this have an impact


#14

Ah hah! Now, I did and reproduce it. Yes, the row of colorwheel labels has a minimum width requirement that is not satisfied. The following fixes it for me:

--- src/qml/filters/color/ui.qml
+++ src/qml/filters/color/ui.qml
@@ -24,10 +24,10 @@ Item {
     property var defaultParameters: ['lift_r', 'lift_g', 'lift_b', 'gamma_r', 'gamma_g', 'gamma_b', 'gain_r', 'gain_g', 'gain_b']
     property double gammaFactor: 2.0
     property double gainFactor: 4.0
     property bool blockUpdate: true
-    width: 520
-    height: 300
+    width: 620
+    height: 350
 
     Component.onCompleted: {
         if (filter.isNew) {
             // Set default parameter values

#15

Here are 2 more things fixed not mentioned here:

  • autosave not working
  • very poor audio quality of Reverse… MP4 and MKV options

#16

This is fixed for the next version.


#17

Does this fix also cover this bug when it happens with the mouse scroll wheel? @Namna had reported it before a couple of times here in this thread and also made a whole thread devoted to it here. I also have had the very same problem of two keyframes being created side by side when trying to create a new keyframe by scrolling the mouse wheel up and down.


#18

No, it does not, and it is not the scroll wheel specifically; it is changing the value when frame-dropping is enabled. I just fixed it for the next version.


#19

For me too
Thank you Dan


#20

It seems the auto save feature is no longer working. The last files saved in the autosave folder are dated June 2, 2019. Since then no files have been added to that folder. I believe auto save was working in 19.04-30.