Two video tracks used, filter in one of them makes the other one invisible

Hello there,

I’m just beginning to work with shotcut and have the following problem:
I have several smart phone videos which are unfortunately made in upright position.
In order to make it look more smoothly I used on additional video track an copied the video into the second track and blurred it over the full size of the screen as explained in this youtube tutorial:

This works perfectly and looks fine for me.

My problem appears as soon as I want to add another filter in the upper video. Suddenly the video in the lower track (the background video) is no longer visible.
This is independent on which filter I use.

Can someone help me and let me know how I can use filters and still see the video in the lower track in the background?

Thanks!
Olivia

S’il vous plait, pouvez-vous nous faire une ou plusieurs copies d’écran sur laquelle nous pouvons voir les clips sur la timeline ainsi que les filtres que vous avez déjà appliqués avant de constater le problème et nous dire le filtre que vous souhaitez appliquer et sur quel clip.

Please, can you make one or more screenshots where we can see the clips on the timeline as well as the filters you have already applied before you have problem and tell us which filter you want to apply and to which clip.

1 Like

I think I have seen this also; I was very busy and simply moved on at that time.

Careful documentation of how this happens would be very useful to me, and probably to others as well.

This sounds like something I experienced a couple of months ago. I pulled in a video shot in a “portrait” orientation (like the typical cellphone video), centered it, and then put a stretched and blurred copy of the same video behind it. I was attempting to produce something like this:

.

My German is way too rusty to see how the tutorial did this, and now I can’t reproduce the problem I had, so I’m not entirely sure what I did at the time, or exactly how the problem manifested itself. As best I recall, though, the issue was that the top video - the “portrait” video - came in with the equivalent of black borders on each side. It seemed to work fine, but then when I added another overlay (? I think? Again, can’t quite remember or reconstruct it), suddenly things went wrong.

I believe I solved it by adding a simple chroma filter and filtering out the black. Alternately, I would guess you could use some sort of mask. But full disclosure: I eventually made the video I needed by building up a couple of .mlt files; the first was just the “portrait” video clip, copied and transitioned so that it created a longer clip of rain. I saved this as a .mlt file. Then I started a new project and pulled that .mlt file into the playlist. I put it on the timeline twice; the top one I put a simple chroma filter on as described above, and the bottom one I used a size-and-position (distort) filter to stretch it and a gaussian blur. Then I saved this .mlt file, created the final project, and pulled the latter .mlt file into the playlist. I say all this to report that now, even if I turn off or remove the simple chroma filter in the second stage, I can’t seem to reproduce the problem, so either something changed in a ShotCut update, or else something about doing it in “layers” like this is solving the problem.

That was probably all as clear as mud, but hope it gave at least some ideas to try …

Thank you for your intention to help!
Please find here some screenshots (unfortunately I had to remove all but one, because only one is allowed for new members):

  1. The video on the first track is in potrait orientation.

  2. I don’t like the black bars on either side. So I added a second track and put the stretched and blurred copy below.

  3. No more filters used, the result is the following (and exactly what I want):

  4. As soon as I use ANY filter on the first video (the one in the front), the black bars are back.
    Here I used a text. But it’s the same with any filter.

Thank you all for helping to solve this problem!
Olivia

Thanks a lot for your ideas!
Indeed the chroma filter works and I can remove the black bars and indeed the video underneath comes into vision again.
But this is not useful for me because it also removes all the black in the picture and so changes it too much.

The following should work:

V1: The clip with the SPR & Blur filters applied
V2: The original “Portrait” clip

Then apply the filter Mask:Simple Shape to V2 with a rectangle (zero softness) covering the original.

Then you can apply other filters, like Text:Simple to V2 without getting the black bars. It seems to work for me, let me know if it OK for you.

+1 for Elusian’s answer - a mask would be a much better way to do this, to avoid keying out parts of the image that you actually want to keep. A rectangular mask with softness set to 0 would let you achieve the exact effect above. But it might be interesting to play with a little softness on the mask, to blend the primary image into the background. Hmm … something to experiment with …

Pour ajouter du texte sur votre montage, ajoutez une piste au dessus sur laquelle vous mettez un clip transparent et un filtre Text: Simple ou Text: Riche

To add text to your edit, add a track above which you put a transparent clip and a Text: Simple or Text: Rich filter

1 Like

That works for text, but if he wants to manipulate the original video on V1, e.g. use the Brightness filter, he is back in the same position as before, with the black sidebars appearing.

Il suffit de mettre un filtre SPR avant la luminosité

Just put an SPR filter before the brightness

Ah, I seem to remember that being mentioned in another post a week or so ago.

Thank you very much, this solves the problem for the text!

I have no idea why, but the additional SPR filter before the brightness works!
THANK YOU SO MUCH!

Needing to add the CPU-intensive SPR filter to make another filter work correctly, when neither Size, nor Position, nor Rotation are being modified, seems to me to go beyond the usual definition of “Work Around” and put it in the realm of “Bug”.

Vous pouvez aussi mettre un filtre Crop: rectangle ou Mask: Simple shape ça marche aussi.
Le filtre SPR a l’avantage de se régler tout seul aux dimensions de l’image alors que les filtres Crop: rectangle ou Mask: Simple shape doivent être ajustés manuellement.
Par contre pour la consommation de CPU, je ne sais pas.

You can also use a Crop: rectangle or Mask: Simple shape filter.
The SPR filter has the advantage of adjusting itself to the dimensions of the image while the Crop: rectangle or Mask: Simple shape filters must be adjusted manually.
But for the CPU consumption, I don’t know.

This topic was automatically closed after 90 days. New replies are no longer allowed.