Track render order follows creation, not timeline order


#1

I understand that there’s no (supported) way to re-order tracks; but it is my understanding that tracks are meant to be rendered in Z-order in the same order as they appear in the timeline. However, it appears (in 19.02.28) that tracks are rendered in order of their addition to the timeline, irrespective of where they are inserted.

Can someone confirm this behavior, and whether it is expected? Is there a way to insert a video layer below the existing layers?


Why is lower track showing on top?
#2

Select the lowest video tracks header. Right click->insert. This will add a track above the selected track. You cannot add a track below V1.

Tracks are rendered from 00:00:00:00: to the end of the timeline, unless you copy timeline to source. In that case you can specify a start and end point for rendering.


#3

When I say “rendered in order” I mean their z-order; that is, when using size-and-position to place them on the canvas, I’m concerned with which tracks render on top of which other tracks.

Right click->insert.

I’m doing that; and I’m able to place the track in the list where I want it to be; but my experience is:

I create this timeline with two video tracks:

V2: content
V1: background

I then try to insert a new track to create a drop shadow effect, like this:

V2: content
V3: shadow
V1: background

But V3 always renders on top, blocking V1, no matter where I place it in the order of tracks.


#4

My bad. Some NLE’s use render to mean export.

This is the way it works. Upper track will always block lower track. V3 will block V2, V2 will block V1. It doesn’t matter how may tracks you have.

You need to use the size and position filter or the rotate and scale filter to create your composition. You could use opacity to allow a lower tack to show through an upper track.

Here’s an example. Using 3 tracks. BGD on V1. Shadow on V2. Content on V3. Using the rotate and scale filter.

Attached the project file so you can see how it works.

3 Tracks.mlt (9.3 KB)


#5

What you have described is what I expect, but not what I have observed. See here in this screenshot that the shadow track is rendering over the gameplay track, even though it is placed under it in the timeline.


#6

I should also point out that I am able to recreate this behavior reliably; I’m not just in some corner case.

I’ll try to capture footage of me doing it.


#7

You have filters applied to the video tracks. Although it shouldn’t, that might be causing this anomaly. Try applying the filters to the clips.

image

Look at the track blend modes. Default for tracks to behave properly is over.

image


#8

I just re-created with a new project and no filters at all. Notice that this should have green (V3) on top; but black (V2) is the one that’s displaying.


#9

Or, since black can sometimes be ambiguous, here’s one with blue.


#10

That is most unusual. I put filters on the tracks and everything worked fine. Here’s a screenshot with all filters disabled. Yellow on the V3 is showing in the source viewer.
What version of SC are you using?

image


#11

19.02.28.


#12

This thread describes a situation where the top track does not render.

I just reproduced what the OP described. Removed track V2 then Undid it and now V3 is no longer rendering.

The way to fix it to remove the upper track and then add it back and put the clip on the track.


#13

There is no undo in my use case. Here is a video of my problem.


#14

Your video does not play.


#15

It was just still processing on the youtube side. Try again.


#16

Working fine for me.
Windows 10 Home 64-bit


#17

Here’s another that repositions the clips just to be clear that all tracks are rendering, just in the wrong order.


#18

I just duplicated the entire procedure in your video, step by step, and the upper track does not render. It’s probably because you insert the middle track. In my original project I created all 3 tracks before putting the color clips on them.

This might be a bug. I will upload my project.

Middle track bug.mlt (5.7 KB)

I removed the upper track then added it back and now the tracks render properly.


#19

Thanks. I’m glad I’ve finally managed to convey what I’m experiencing.

I know I can do it by creating the tracks ahead of time. But it appears that render z-order reflects the order of addition, not the order of the clips in the timeline. So it’s impossible to insert a track underneath an existing track.

Assuming this is a bug, what’s the next step? Is there a way to report this? (I’ll try to find out myself; but I was thinking that bringing it up here in the first place would do that.)


#20

It is a bug. One of the developers will eventually look at this thread and try and fix it. You can re-categorize this thread from Help/How to to Bug.