Text won't show on transparent overlay

Hi everyone!

I’m quite new to Shotcut but did managed a few things already. I am now struggling with what looks so easy on tutorials, I’m so glad the community is here :smiley:

So, I would like for a text to slide in only half way of a track. I could make a cut and add a text filter. But I have seen the trick with the transparent overlay and tried to apply it, in order to be able to move it around and be more flexible. I managed to add the overlay on the second timeline but it won’t show the text, when I click on the overlay it shows only the frame even though in the overlay setting I do see the text. I am absolutely clueless.

Another option would be to add a filter to the full track and delay the moment when the text slides in the video but I didn’t find that either.

Hope it’s not that big an issue and it’s just about ticking a little option somewhere ^^ Thanks for your time :smiley:

Ok well I have put the video track on V1 and the overlay on V2 and it seems to work, no idea why ^^

From my understanding, stacking of the tracks is done top down so your transparent layer with text would need to be at the top. Likewise if you were adding a Picture In Picture (PIP) effect, the smaller PIP would be at the top of the background layer.

Thanks for your answer :slight_smile: I also understand V2 overlays V1, so if I put an overlay on V1 it’s being hidden by the video on V2, it does actually make sense now. At least I hadn’t change the names of the tracks so I could find out where the problem comes from, lucky!

By default, all video tracks are blended with V1 (bottom-most video track).
With your original scenario, you could change Blend mode of V2 to Add in the Properties window. The default blend mode of all tracks above V1 is “Over”.

1 Like

Never looked at that. New one to me. Thanks @Hudson555x

1 Like

@Hudson555x Thanks for the confirmation, I won’t forget that :slight_smile: