Text: Rich filter not showing in preview or export (Background height too small)

What is your operating system?
Windows 10 Home 64 Bit

What is your Shotcut version (see Help > About Shotcut)? Is it 32-bit?
20.09.13 64 bit

Can you repeat the problem? If so, what are the steps?
(Please be specific and use the names as seen in Shotcut, preferably English. Include a screenshot or screen recording if you can. Also, you can attach logs from either View > Application Log or right-click a job and choose View Log.)

  1. Open Other, color : black
  2. Drag to V1
  3. Apply Text: Rich filter to clip on V1
  4. Resize current text to 250

Clicking on another filter, or Output will show a black screen. Exporting the video will show a black screen.

Adding a 2nd track, this time I used a transparent color above it, and the filter works fine.
Shotcut rich text 2009.mlt (7.5 KB)

The only way to see the text is to have the specific clip on V1 selected


Selecting any other part of Shotcut, output, or another track, another clip will not display text from V1.

Exported frame from exported video via Shotcut.

Side note: When saving the HTML from the Text Rich filter’s menu it always saves to this same location despite having saved the MLT.
shotcut_2020-09-16_04-36-13

Bonjour,

Je ne veux pas ouvrir un autre fil sur “text: Rich” car je ne sais pas si il s’agit d’un bogue ou pas.
La fonction copier/coller ne fonctionne pas.
Si je sélectionne du texte dans le VUI, copier fonctionne, mais pas coller.

Hello,

I don’t want to open another thread on “text: Rich” because I don’t know if it’s a bug or not.
The copy/paste function doesn’t work.
If I select text in the VUI, copy works, but not paste.

I’ve been trying to duplicate the issue but can’t.
Are you copy/pasting in the same filter or another filter, on V1 or V2 same or separate clips?
I’ve pasted to the same filter, and separate filters on various clips on both V1 and V2.

Je suis désolé, je me suis mal exprimé, je parlais de la fonction copier coller directement dans le texte. Après avoir copié le texte “Shotcut” et déplacé le curseur, la fonction coller n’est pas accessible (grisée) dans le menu Edition du Finder.
DĂ©mo

I’m sorry, I misspoke, I was talking about the copy and paste function directly into the text. After copying the text “Shotcut” and moving the cursor, the paste function is not accessible (grayed out) in the Finder’s Edit menu.
Demo

I think that is by design.

There is a copy/paste function in the VUI itself.
2020-09-16_12-41-02

OK, je suis confus, j’ai tellement l’habitude d’utiliser les commandes de la barre des menus du Finder que je n’ai même pas pensé à utiliser celle de SC :roll_eyes:
Désolé de vous avoir fait perdre du temps

OK, I’m confused, I’m so used to using the Finder menu bar commands that I didn’t even think of using the SC menu bar. :roll_eyes:
Sorry for wasting your time

I try to do this, it works for me

That is correct. The Edit menu in the main menu is for clips on the Timeline.

I have not reproduced this on Linux or Windows.

Also, the project you shared is for your successful case, but it does show that you are not using an opaque black color clip but rather a transparent one. The color dialogs do not change the alpha to 255 when you click a color block, and we do not make the color dialogs. Also, upon clicking OK Shotcut only sets the alpha to 255 when it detects the color has actually changed, which in this case it has not.

This is fixed for the next version.

I am able to reproduce this again in Windows.
Shotcut 3.mlt (4.4 KB)
shotcut-log3.txt (54.6 KB)

Playing the exported MP4

I think I figured out the issue. The VUI box around the text has to be larger than the font size.
Shotcut 3 v2.mlt (4.4 KB)
This mlt works as it should, or at least how I perceive it should work by design. I had to increase the box around the text, and it now clearly shows when clicking on another track or output.
2020-09-16_17-23-29

For a font size of 250, the background size height has to be 413 or larger.

I have a fix for this, but I had also wanted to support multiple lines that exceed the height of the rectangle for scrolling long text vertically. However, (and per the current VUI) the rectangle crops.

I will add the capability for it to not crop to support the use case of vertically scrolling many lines, but I am still thinking about whether to make that an explicit option or automatic. For automatic, I was thinking that it only crops when the rectangle (Background size) height is less than the video mode height. Thoughts?

I am not really sure. I don’t see myself using this filter to any great extent. Perhaps the people that will be using the filter heavily will be able to chime in and give their thoughts.

Personnellement je pense que faire défiler le texte dans le rectangle plutôt que faire défiler le rectangle dans l’écran peut avoir un intérêt. Cela permettrait de supprimer l’utilisation du filtre “masque simple” lorsque l’on veut faire défiler le texte sur une portion seulement de l’écran.

Personally I think that scrolling the text in the rectangle rather than scrolling the rectangle on the screen can be interesting. This would eliminate the use of the “single mask” filter when you want to scroll the text on only a portion of the screen.

Hey, @jonray, have you tried out Text: Rich? :slightly_smiling_face: I’m wondering with your experience with text in Shotcut what you think about Dan’s question:

I will add the capability for it to not crop to support the use case of vertically scrolling many lines, but I am still thinking about whether to make that an explicit option or automatic. For automatic, I was thinking that it only crops when the rectangle (Background size) height is less than the video mode height. Thoughts?

Personally, I can’t decide either way. I would have to try out both ways to see.

Hi @drm, thanks for asking! However I haven’t really had time to experiment with the Text:Rich filter.

My initial thought though is that there is going to be a lot of confusion with users if the output result is different from what happens in the preview screen, so I would think that the non-cropping behaviour should be made automatic, if that makes sense …

Boys. The problem is the font color. It looks white to you but it’s actually set to black. Try changing color to white and it will work.

This bug is fixed for the next version 20.10. I added an Overflow parameter that be set as: Automatic, Visible, or Hidden. I also fixed the bug exporting with parallel processing that was reported elsewhere.

1 Like

The one that I brought up here, right?

Update:
Yes, the bug I reported in the link above was fixed.
Thanks, Dan!

1 Like