Text font is different when exported

What is your operating system?
Windows 7

What is your Shotcut version (see Help > About Shotcut)? Is it 32-bit?
64-bit 20.11.28

Can you repeat the problem? If so, what are the steps?
I was making a video, I added text on the video i’m working on, but when I try exporting the video, it’s turned back default. Can you fix this problem? :frowning:
-Sincerely, Pimimyun

Hi @Pimimyun
If you open your project again in Shotcut, what font is set in the Text filter ? The default or the one you wanted to use ?

1 Like

If you position the playhead on the clip thenselect it, open the filters menu and highlight your text filter then take a screenshot of the whole window, e.g. using the Windows Snippit tool, then post that screenshot, it would make it a lot easier to help as we can then see what you are doing - e.g. are you using Text:Simple ot Text:Rich, which font are you using etc.

1 Like

Burbank Small Bold

It would still be better if we saw a screenshot. Is your text for example in EXTRA BOLD? If so, it is possible that the font-family you are using does not have this style and will revert to the default in the export.
See here:

1 Like

Windows 10
Shotcut version 21.01.29

No issue at all with Text:Simple

Complications with Text: Rich

  1. Select Text:Rich
  2. Click on the font selector icon in the text window, change font, font size
  3. Click the text box to regain focus
  4. Type a few characters, only Verdana, font size 72 appears

Workaround: Type out all text, CTRL+A, then change font & font size.
2021-02-11_07-31-08

Can’t duplicate issue once exported with either Text:Simple or Text:Rich.

1 Like

Is the solution the same for Win10 and Win7?

I think that’s where the problem lies, he wants to restore the old font. To be honest, I do not know how this can be done. You can do it even easier and not look for a solution in these complex codes. Just try to find a similar font or even better and just download it. I value my time and would not waste it looking for some codes when the problem can be solved in a simpler way. You can see it here https://upfonts.com/magnolia-sky-font fonts and find a suitable one for yourself. I hope I was able to help you.

What complex codes?
Are you referring to Text:Simple?
That is the name of the filter.
shotcut_2021-06-14_17-17-36

At the time OP posted, it wasn’t an issue with the current version of Shotcut.
OP was using an outdated version, and never responded back in the post to let us know if anything was solved for them.

At this time, the current stable version 21.03.21 and it’s still a non-issue with Text:Simple.

Also a non-issue with Text:Rich

Another example: