Some MOV Files rotate 90

What is your operating system?
Windows 10

What is your Shotcut version (see Help > About Shotcut)? Is it 32-bit?
21.10.31 - 64-bit

Can you repeat the problem? If so, what are the steps?
When loading a selection of .MOV files into the playlist of a new project, some (but not all) appear in both thumbnails and preview rotated by 90 degrees from the original orientation.
All are from the same camera (Fuji XP140), all in landscape HD1080p format.
The affected clips display correctly in Windows Media Player, but are rotated when shown in VLC.
The clips appear in a “block” in the playlist, with unaffected clips both above and below.
Clips loaded from an SJCAM M10 in the same format and in the same project are never affected.

It sounds like these particular clips have the “orientation/rotation flag” set to 90°.

Run the file(s) through mediainfo using the menu option View->JSON and check the “Rotation” setting.

You are spot on - many thanks for that. I wonder why WMP ignores that flag? Even more, I wonder how it can even get set to anything but zero when we only use the camera in one orientation!
Can you recommend a metadata editor to adress this?

How do you feel about using the command line? If you are comfortable with that, ffmpeg can do the job:

ffmpeg -i -codec copy -map_metadata 0 -metadata:s:v:0 rotate=0

(Of course, change the filenames to suit what you have / need, and you can also use other rotation settings as needed.)

1 Like

This is not a bug. The tool reads what it can from a media file, but if it is missing orientation or rotation, it cannot understand the correct orientation by judging the image using AI. The next version has a Rotation field in Properties to set or override what is in the file. In the current version, you need to use the Size, Position & Rotate filter.

Well, it IS a bug…with the Fuji XP140 camera!
I have been using the “Size, Position & Rotate filter” but was a little concerned that it seemed to need a Size setting of 178% and it worried me that this could be affecting resolution.
No matter - if a suitable tool is in the pipeline, that’s all good, and I’ll filter in the meantime.

1 Like

It’s a thought, but when there are 26 clips in a sequence, all needing adjustment - a bit of a faff. Anyway, it does seem like an answer is forthcoming in a software update.

As a stopgap measure until the feature is available, I just built that lline into a file ROT.BAT so I can type the command and the filename to be edited, put the filename as a variable and output filename the same but with prefix R.

“C:\Program Files\Shotcut\ffmpeg” -i %1 -codec copy -
map_metadata 0 -metadata:s:v:0 rotate=0 R%1

Thanks for the guidance, sir!

1 Like

It sounds like you are on Windows - I haven’t used Windows in a long time, so I don’t remember the exact way to do it, but I know there is a way to have your .BAT file process not just one, but a whole series of files. (I can help you do in in Linux, if you’d like … :))

You are correct, and I wondered about making it a multi-file routine, but so far the instances of rotation are quite random and sporadic, so it seemed a bit more than I needed. One folder only had a single example out of 32 clips.
It’s probably 25 years since I needed to put a script together, so I was actually pretty shocked that I even remembered how to use variable substitution!

1 Like

This topic was automatically closed after 89 days. New replies are no longer allowed.