Slower Response than old version

What is your operating system?
Windows 10 Home Single Language

What is your Shotcut version (see Help > About Shotcut)? Is it 32-bit?
shotcut-win64-20.11.25

Slower response problem.txt (34.7 KB)

Shotcut version 20.11.25 still has the Slower Response problem for me.
Even simple task (such as selecting another clip) is much slower than version 20.09.27

And then I reinstall SC version 20.09.27. It has no Slower Response problem.

No Slower response problem 20.09.27.txt (35.8 KB)

Thank you very much.

Weird. I do not experience this and have no explanation. Perhaps it depends on Settings > Display Method and depends on your hardware system, drivers, or something else in the operating system. It is difficult to say what is the cause. Did you try the different options in Display Method?

1 Like

Yes. Since this year’s October versions of SC have “Slow Responses” in every activity with my ASUS Notebook . It could happen from anything such as CPU, Display Driver, RAM , etc. Bad luck for me, I guess :sweat_smile:.
I will continue with SC 20.09.27

I had some experiences in C programming. I think I love Shotcut. I just hope some version in the future not have this problem for me.
Thank you very much again from Thailand. :smiley::pray::heart:

Kop khun kup. :pray: Do not bother to download and test the new version 20.11.28 I just made. It will not help this. I suspect this is some drawback to the big update to our GUI library, maybe based on your GPU. But if that is true, the software display method should be OK. We will see if some others report this problem, and maybe that will provide some more points to make a comparison. However, be careful, because a lot of people will say something is slower without making a proper comparison. I trust the screen recordings you made; it is clear. There is another thing I request that you test with version 20.10 or 20.11: turn off the timeline audio waveforms. Also, please ensure there is only 1 shotcut.exe running in Windows Task Manager Details view.

P.S. My girlfriend is Thai and started the Thai translation, but I am afraid she might not be using the expected Thai computer and video terminology. Please use our Transifex project if you would like to help or can convince someone else to help. :slight_smile:

1 Like

Thank you ครับ (Khrạb)

Shotcut version 20.11.28.
This recording is still not turn off the timeline audio waveforms.
SC 20.11.28 used memory around 1,9xx - 2,0xx MB

Shotcut version 20.11.28. Turn off Show Audio Waveforms.
This time, SC 20.11.28 used memory around 1,8xx - 1,9xx MB

Lag Problem 20.11.28 turn off show audio waveforms

Shotcut version 20.09.27. Turn on Show Audio Waveforms.

SC 20.09.27 used memory about 1,2xx - 1,3xx MB with the same activities after open same project. Is that O.K. ?

Anyway, I feel lucky that when I get back to ver. 20.09.27, it is still good for me. :innocent:

My younger brother, CJ, live in L.A. USA. He has much more English skill than me :laughing:

Thank you for the update. I am still thinking about this. Unfortunately one of the ideas about the cause requires changes that I estimate will require about 200 hours of work. :sweat: I do have another idea about a change that I can make configurable and then give you a nightly build to test. Are you comfortable to edit a shotcut setting in the registry? Also, what is the exact model of your notebook?

1 Like

That’s sound boring to me :expressionless:

Yep.

Thank you very much. :pray::heart:

as a new user i say hello :slight_smile: … but from the start i have the same problem with shotcut version 21.03.21

windows 10
intel i7-4790K, 16 GB RAM, NVIDIA GeForce GTX 1070, SSD

i work with relatively simple material: full HD mp4, 1 video track, 1 audio track, video clip lenght 3 - 10 min, total video project length ca. 30 min

in the first minutes of the project everything works fine. the more clips i add over time and work on them, the slower the response time becomes. from a project length of approx. 15 minutes, it is no longer possible to work efficiently. when i click on an item in the timeline, it takes longer than 10 seconds to react. click on a item wait 10 sec until it is selected, cut item wait 10 sec until it is cut, click again on the item wait 10 sec until it is selected, move it and wait 10 sec until it moves, etc. …later in the project it will be 15 seconds, etc. …no chance to work without going crazy.

what i tried:

  • have tested all display methods
  • lowest preview scaling
  • with or without proxy
  • latest GPU drivers
  • complete reinstallation of win 10

…none of it did anything. the problem remains the same. in other software like davinci resolve i can work completely fluently and very quickly also on large projects.

1 Like

Please try Shotcut ver. 20.09.27 for now if you want to use this app.

1 Like

thanks! i tested 20.09.27 and was able to cut my videos almost smoothly. the reaction time when clicking on an item in the timeline was approx. 0.5 to 1 second. i can live with that.
i hope so much this problem will be fixed in future releases because i really fell in love with shotcut.
when the problem is resolved, i like to donate a few dollars, because then i will be working with shotcut more often.

1 Like