Size of playback image

I’m a newbie. I’ve spent many hours trying to find an answer to my question. I created 2 projects, each containing multiple mp4 files downloaded from my phone. I exported the 1st project and it played as a small rectangle (3 3/4 x 3 inches). Research showed changing the aspect ratio from 4:3 to 9:16 or vice-versa makes a difference. When I created the the 2nd project, I did something to get it to play in full screen mode (10 x 6 1/2 inches) on my PC, and fills out the entire TV screen when I play it with a DVD player, but I don’t recall what I did or how I did it. I went back and changed my first project’s aspect ratio ( I think ), and now it still plays at the original width, but with full height (3 3/4 by 6 inches). How do I get my exported file to “fill the TV screen” ?

Find out the resolution of your tv screen, and the aspect ratio. Go to export>advanced and set the same resolution and aspect ratio.

For example if tv’s resolution is 1920x1440 and aspect ratio is 4:3, than export would be also same to fill the tv.

Ar_D, thank you for your reply. I tried Settings on my TV, but it did not show the desired info. However your tip did give me an idea, so you did help me in the end.
It turns out that Shotcut establishes the attributes based on the 1st clip ADDED to the project, NOT based on the 1st clip IN the project. Lets call these clips A, B and C. Clip A was from another project that did display in “wide mode”, while clips B and C displayed in “narrow mode”. I started a new project and loaded clips A, B and C, and then deleted clip A. What remained now displays in “wide mode” as opposed to “narrow mode”. The attributes of clip B now reads
Codec H264 / AVC / MPEG-4 AVC / MPEG-4 part 10
Resolution 1080 x 1920
Aspect ration 9 x 16
The cause of my original problem was that clip B was created by holding my phone vertically when I started recording and after 10 seconds rotated the phone to a horizontal position. Despite deleting the first 10 seconds of clip B so that what remained was “in landscape layout”, Shotcut kept using it as though it was in “portrait layout”, whereas clip A was recorded right from the beginning with the phone being held horizontally. By loading clip A first and then deleting it, I was able to “transfer” A’s attributes to clip B. And since those attributes override all subsequent clips, my movie now plays on the TV in full screen mode.
Thank you again for your help.
Bob

1 Like

This is the behavior when Shotcut is in “Automatic” Video Mode. If you ever want to be sure what the output will be, you can choose a specific Video Mode setting in the menu and then it will not change regardless of the clips you add.

1 Like

Hi @BoboShot1, you can actually just search for the resolution with your model number on google. For eg:- Here is a screenshot of my tv’s resolution…

That could be solved if you choose a preset or create a custom one rather than choosing automatic.

Thanks to both of you. I saw the dropdown list, but being a novice…talk about intimidating. When I’m unfamiliar with software, I figure “the software usually knows best”. If I ever decide to make a profession out of home movies, I’ll learn all the techno-jargon. Meanwhile you’ve helped me get what I need. I will take this opportunity to mention something that puzzles me. I set a keyframe with a magnification level. Move further along in the clip, change the image’s position and magnification; and the first keyframe changes to match the new settings. Took me awhile to realize what was happening, but WHY it was happening still eludes me.

Then you should watch some tutorials, @UbitronicsUK has one of the greatest ones you can watch.

Thanks Ar_D! Thats means a lot :slight_smile:

1 Like

Strange, the first or any keyframe should be at the value it was manually set to. I don’t really know the reason, but maybe you are talking about the place between two keyframes, that is gradual changes that happens.
Otherwise, I also am not sure what is happening, abd it will also elude me like you. Maybe a screen recording of that problem might help us.

Long time no see :smile:, great you are back to the forum after half a year.
Welcome, you just have very nice tutorials to watch. And your voiceover is soothing too.