Shotcut's videos cannot be uploaded to twitter


#1

Please help!

I have a raw footage from a video game, captured with Windows 10 Game Bar. I made a few tweaks to it in Shotcut and exported MP4 file and I want to use it on twitter. The file follows the guidelines for twitter videos (size, etc.), but twitter refuses to upload the Shotcut’s exported file.

I click the “Add photos or video” button on twitter, I select the file, and it just closes without any error message or other prompt and the video is completely ignored. Meanwhile when I try to upload that unaltered Game Bar footage, it works.

I tried default settings from MPEG-4 profile for the export and it failed. Because the default settings produce very bad quality of video for some reason, I tried custom settings shown below and it failed as well. Properties of the raw Game Bar recording is added in the picture for comparison:

My system is Windows 10, 64 bit. Shotcut version is 17.12.03.

I’m total noob to video editing and do not understand why the original video works, but the Shotcut’s exports do not. I tried several other codecs but to no avail. If anyone is able to use Shotcut’s exported videos on twitter, please tell me what are the exporting specs of the video. Any other advice would be greatly appreciated!

Thanks!


#2

I just used Shotcut's default export profile to encode a video and uploaded it to Twatter. Worked fine.
I don't think you need to use the MPEG-4 preset. It did not work when I tried it.


#3

With the 100% quality settings, the size is huge, no?
Maybe there is a size per sec limit in twitter?


#4

Or forget Twitter’s ridiculous conditions and use streamable.com then just paste the video link. This plays directly in Twitter posts.


#5

You are right! The key difference seems to be the video codec which is libx264 for the default setting instead of mpeg4. I should not have fiddled with it.

I also found out that the quality set too high (probably over 90) breaks it, but this time twitter returns error message about incompatible video instead of nothing.

The size definitely wasn’t the problem. I’ll check streamable.com, thanks for the tip and thanks to all for the responses!