Shotcut version 21.09.20 is laggy

I have recently noticed that if I open a project in shotcut it runs perfectly fine but if I save the project and open it after a reboot or restart the project becomes so laggy that it becomes unusable and importing files and editing becomes a pain. It just repeatedly shows not responding. I tried reinstalling the shotcut after a clean install to windows 11 but still the issue persisted so I installed an older version 21.09.13. This version seems to work fine and I had to complete the rest of the editing in this version. This version i.e 21.09.13 works fine.

**Everything I write below is just what I think, I don’t know if shotcut supports win 11, so if it supports, than I might be wrong.

The clear reason is you are using win 11, shotcut and many big programs too are not ready for it yet.

But I wonder how it ran on windows 11, my
secondary desktop meets the requirements of win 11, so I will upgrade to win 11 when the update comes, and then I will definitely try to install shotcut.

While this may not fix the issue with Shotcut, perhaps list specifications since this is with a very buggy new OS that really hasn’t been fully bench tested.

Listing specifications may help others with Windows 11 using Shotcut.

  • Computer specifications: CPU, Ram, Data Drive type(s)
    • Anti-virus programs?
  • Video Mode settings in Shotcut
  • Source video(s) specifications
  • Filters used

I seriously doubt this bug is legitimate. I do not see it, I doubt Windows 11 makes the difference, no one else is reporting it, and there is very little different between these versions - just a CPU instruction compatibility problem that appeared in the 360 video filters. I suspect when you were first working on the project it was busy building audio waveforms and video thumbnails, and a later time those were retrieved from the cache.

it was not working with windows 10 as well

is this problem specific to my processor

It is not the problem with windows 11 as the 21.09.20 version was not working on windows 10 as well.

My Laptop specs are:
CPU - i3 6006U
RAM - 12GB ddr4
Storage - 240GB SSD for OS + 1TB HDD for Storage

I have only the built-in windows security on.

Video Mode settings : 1080p @29.97 fps

Source video specification : MTS files from a old sony handycam

Filters used
Text Simple

Your processor is not fast enough. Not saying it won’t work, but it will be slow processing.
SD = 640x480
HD = 1920x1080

If you do have your videos on the HDD, consider moving them to the SSD for faster processing. HDD’s are not fast enough for video editing.

Preview Scaling and Proxy editing will greatly speed up the entire process.
Here is a great tutorial on how to get started with Proxy editing.

You also need to consider heat limitations. There is built in heat protection if your CPU get’s too hot, it will throttle down speeds until it’s cool enough to run.

I have several times got the same on my old laptop with i3, I didn’t know what was the reason but after sometime, the same version became stable.

Anyway, 12GB is still not very good for HD, The project might be taking too much resources of your PC.

And your processor is also not good enough.

That is why I am using proxy files everytime

I am using proxy and my video files are also on a SSD.

My CPU reaches 60 degrees when on max load

Thanks for the help, and I am already using proxy files.

I don’t see this much temperature as high, because my CPU always stays at 55-60°C, and performs very well.

Try to use check for any problems happening physically to your CPU, because that may cause some problems, also try to interchange the ram, I do it sometimes when I get a problem, which couldn’t be solved in the software.

Can you give every exact step to recreate it…

I have a laptop so swapping ram requires me open disc bay, keyboard, battery and nearly 20 screws so it is difficult to swap the ram sticks.

Maybe I should using 21.09.13 and wait for the next update.

Than you should try to reinstall shotcut by checking “Remove registry settings” And then download. (A pure guess*)

Create a new project, open one of these files, click on Properties.
Can you show a screenshot of this panel?

Yes, they might have variable frame rate, and then he needs to convert it. That maybe the actual problem.

I tried that as well, it does not work.