Shotcut v23 won't open

@Ertan concerning the white interface:
As per release notes, Shotcut - New Version 23.05

Drawbacks and Limitations

  • Settings > Theme is gone due to a bug or limitation in Qt 6 Quick Controls. The Shotcut dark or light theme now strictly follows the system settings. On Linux, that is hit-or-miss depending on the desktop environment and its version (and, sadly, not the AppImage). For many people this will not make a difference. For many others, it might make you want to switch your system to dark mode. I do not expect this situation to change in the near future (2023). Yeah, I am not real happy about it either, but it is what it is - which means all comments, forum posts, and bug reports about this will be ignored, hidden, or closed.

Yes. I have read this part.

Same on my system. After installing shotcut shows the Loading Screen and then terminates. (Windows 10) (just info)
I go back to previous Version (thot works fine)

I uploaded a debug build of Shotcut 23.05.07 for Windows:

You can extract this zip file to a separate folder in Desktop or Downloads without affecting your typical install. Then, go into the folder with Explorer and find and double-click shotcut.exe to run it. When this crashes, it sometimes creates a file in the same folder, next to the .exe, named shotcut.RPT. If you get it, please upload it here as an attachment. image (or drag it into the reply editor).

Otherwise, another thing to do to help is to grab the shotcut-log.txt file after the crash. Run a working version of Shotcut and choose Settings > App Data Directory > Show… Leave the folder open and close Shotcut. Next, run either this debug build or the release version of v23.05. After it crashes, upload the log from the opened folder window to here as an attachment in a reply.

1 Like

shotcut.RPT (8.5 KB)

shotcut-log.txt (36.6 KB)

Thanks for the crash report and log! The report shows a crash inside the Qt GUI library, and the log reports:

[Warning] <> D3D11 smoke test failed (failed to create vertex shader)
[Warning] <> Failed to create QRhi for QBackingStoreRhiSupport

Basically, this means the DirectX 11 driver for your GPU is not compatible. What is your GPU? Please try to upgrade your driver.

There is a good probability that I will not be fixing this, and if your system is incompatible you need to run an older version or something else - similar to what was said before about OpenGL. I expected switching from OpenGL to Direct3D on Windows to improve compatibility. After all, DirectX 11 was launched in 2009.

Ran the debug build of Shotcut 23.05.07. Here is the file for the crash.
shotcut.RPT (8.2 KB)

@Albert your report shows the exact same problem as the previous.

To others, the .RPT file is simply a text file, and these incompatible DirectX driver problem crashes look like this:




I will try to install old version driver. Thanks.

That is not going to work. Basically, your system is too old and fallen out of support for Shotcut going forward. That GPU was kind of low end (“entry level”) when it was launched in 2009. Your screenshot and wikipedia shows DirectX 10, and we require 11. This is not something I can fix and not willing to go back. The goal was to improve compatibility with recent systems by going native on Windows and macOS, not to improve compatibility with ancient systems. Old systems can use old versions.

1 Like

I have 3 Macs (2 Intel, 1 M1) (macOS 10.14 - 13.3) on which it works fine, but maybe yours is too old to support Apple’s GPU technology Metal.
I just tested a friend’s MacBook Air from 2013 with macOS 10.14 and even that worked including GPU Effects and hardware encoding.

Yes, you are right. my system is low. An update is required. especially my video card.

As a result, we understood where it originated. @shotcut.

  • I read the article you mentioned about the dark theme. My personal opinion is that it is optional.

Kind regards.

I changed the Graphics Card. SC v23.05.14 is now running on PC (large screen ie…).

1 Like

shotcut.RPT (24.0 KB)

I got the RPT
I can’t run a working version if it won’t even open. I apologise if I sound smarmy, but it worked just fine, until I clicked “update”. 23.06.20 (?)
I love Shotcut.
Other’s editors suck and upsell you. I can’t see what or where I’m cutting, or they slam all your stuff together and call it done… with Watermarks.

Oh by the way, Windows blocked you on start up. It gave me a pop up that it didn’t recognise your software, harmful yada yada. Billy just wants us to pay him to use Windows editor. Can’t save without paying him, can’t Export without Bill’s $$$ incentive to let you create. Jealous Jeff makes more money?
I clicked run anyway and still nothing, unfortunately. But, Windows blocks you, not the first time I had to give permission.

This topic has been marked solved (so you won’t get many replies) and the solution is to run an older version. That would involve uninstalling 23.06.20, then downloading an older build from the downloads page and reinstalling that (making sure to check the box to clean the registry during the reinstall process). As a fellow Shotcut lover, that seems like an extremely simple fix (at least to me).

I think that is a confusing or inconvenient place for most people because that link is the project GitHub Releases page (lots to look through and understand including betas and release notes). Rather, the web site Download page has a clear and simple section:
Windows 7 (or old computer without Direct3D 11+).