Shotcut v21.05.18 crashing frequently

Since the last update v21.05.18, I am facing frequent crashes while using Shotcut.

  1. It crashes while adding files to the playlist.
  2. It crashes while opening a mlt file.
  3. It crashes while not doing anything.
  4. It shows a prompt asking to recover the auto-saved project, even if I click “yes” it just opens the project where I last saved it and all recent changes are lost.

Could someone please help with fixing this issues as I have to make video projects frequently. Do I need to revert to the older version?

1 Like

Possibly… what filters are you using?
I just posted a bug report for Size, Position & Rotate.
Does it look the same?

It crashes for me without using any filters

In case you do not use the Time Remap filter (implemented since version 21.05.01) you have the option to use older versions (e.g. 21.03.21).
Release v21.03.21 · mltframework/shotcut · GitHub
It is advisable to make a copy of the projects and test those copies.
Just as a general precaution, I manually save an additional copy of my projects as a backup (naming as “project name”_backup.mlt).
You do not need to install Shotcut as there are portable versions.

Thank you for your suggestion @ejmillan

1 Like

Sorry but I do not experience this, no one else reports it, and unable to do anything about it. I suspected you made a faulty upgrade. You should reboot, uninstall Shotcut, and reinstall.

I’ve just been trying Shotcut after problems with Kdenlive and I get exactly the same problem. I’m not doing anything complicated, but even something like adding a key frame causes a crash.

I also tried the flatpak version of Shotcut and got the same result.

What is suspicious is that very similar things happen in Kdenlive, though it seems to be using an older version of MLT & Qt. I hadn’t used Kdenlive in months, but last time I did it was fine.

I tried the 21.03.21 AppImage suggested above. When I open the project Shotcut offers to repair it and fails. If I recreate the project, Shotcut seems to work without crashing.

In case it’s relevant this is what I was doing. I’ve taken (wav) audio from a radio program to highlight some points for language learners. I’ve added an abstract video background and one text filter. The crashes seemed to mostly happen when trying to configure the text filter, e.g. adding start/stop points.

Manjaro Cinnamon
Shotcut 21.05.01 (mlt 7, Qt 5.15.3)
Kdenlive 21.04.0 (mlt6, Qt 5.15.2)
Nvidia driver 460.80

You should probably start a new thread for your issue.

Are you using the build available here?

If not, please try the official build and report back.

Spoke too soon. Adding a second text filter also caused a crash in 21.03.21.

Are the github releases not official?

The only official packages are the ones from the Shotcut download site. If you are using packages made by someone else, then you should work with that packager to resolve your problem. The Shotcut packages are portable and easy to try without committing to an installation.

Yes I am using the build available there from GitHub

The Shotcut download site has links to the files at Github, so the 21.03.21 AppImage that I tried was ‘official’.

The download page also advertises the Flatpak and Snap packages. Are they ‘official’?

As I said in my original post, I tried the latest Flatpak as well (21.05.01). It’s not as though I just tried the Arch package before posting.

The 21.05.18 AppImage seems to be stable so far, so maybe the issue was just with the package not being up-to-date.

The 21.05.18 AppImage also crashes for me when editing Text Filters. If I change a text filter then choose another in the list, there is an immediate crash.

Yes. Since the problem is not widespread (I can not reproduce it on my Ubuntu machine), it might be a good test to try the Portable Package on your system.

Other things to consider to help debug:

  • Try a different Settings->Display Method
  • Which text filter exactly are you using? Do you apply Text: Simple twice
  • If you can provide a screenshot or video of the steps leading up to the crash maybe someone will notice an important detail

What operating system are you using?
What are your system specifications (CPU, RAM, etc)?

I have a Windows 10 laptop with the following specifications:
CPU - Intel i3-6006u
RAM - 12GB DDR4 2133mhz

I’ve had to move back to 21.03.21 myself on Windows 10. The last two releases just randomly lock up doing normal things such as dragging in videos, etc. Not sure what has changed.

I am also experiencing this, with 21.05.18
(I did almost nothing with 21.05.01, so I don’t know about that one.)

Not reproducible; every attempt after a crash to “do exactly the same steps” has resulted in no crash.

But it happens quite often, on very simple projects.

Had to do the same myself. It seems to particularly dislike imported MLTs. Just splitting a track from an MLT in 21.05.18 causes everything to hang for about 5 seconds. 21.03.21 seems to behave fine.

Edit: in 21.05.18, projects with imported MLTs also take forever to load and if you make the mistake of hitting ‘undo’, it’s easier to just kill the program and manually set things back to what you wanted.

Edit2: in the application log for 21.05.18, I see a lot of lines with “missing hwaccel parameters” that I do not see with the exact same video files as 21.03.21 (video in MLT, then MLT into master MLT). @shotcut does this provide a hint for what might be the cause of some users experience such a difference between 21.03.21 and 21.05.18?