Shotcut theming gone wrong


I am not sure where Shotcut gets its buttons and sizing info from, but it looks just wrong. Here is the interface that I get:
Happens with all the 3 selectable themes.
Tried changing the system theme, icon theme, window manager theme, but nothing seems to affect the appearance of Shotcut.

Looks fine when I install it in a virtualbox though which leads me to believe that it grabs the button size and theme from somewhere in the system, but I just don’t know where.

Tried completely removing Shotcut and having a clean install - result is the same.
Running on Archlinux.

Any help is appreciated.
Thank you!

Ok, looks like the issue is not with Shotcut at all, more likely it’s the nvidia drivers and how they scale with DPI.
When I move the window to another monitor, everything becomes tiny with Shotcut. Same scaling happened initially when I installed nvidia drivers in the first place. The workaround was to add the following DPI option to xorg.conf:
Section "Monitor" Identifier "Monitor0" VendorName "Unknown" ModelName "Unknown" HorizSync 28.0 - 33.0 VertRefresh 43.0 - 72.0 Option "DPMS" Option "DPI" "96 x 96" EndSection
Now the question is, how do I get the scaling corrected? This might be a very wrong forum to ask from, but maybe someone has encountered similar things before and knows the answer? :slight_smile:
If I find the solution beforehand, I shall note it.

Ok, I’m onto something here.
Launching Shotcut like this resolves the issue:
QT_AUTO_SCREEN_SCALE_FACTOR=0 /usr/bin/shotcut

Looks like it tries to do some magical scaling but for whatever reason is not working properly with nvidia driver settings.
Unfortunately looks like when exporting the env variable, it doesn’t work, so I need to change the launch command directly to:
"QT_AUTO_SCREEN_SCALE_FACTOR=0 /usr/bin/shotcut"
Then it works.

Final entry.
Got it resolved.
Just wrote:
Into bootup script in /etc/profile.d/

Works fine now. Thanks. :slight_smile: