Shotcut Resolution Ubuntu


#1

I’ve recently converted my OS to Ubuntu from Windows 10 to try resolving some Shotcut issues, but resolution in Ubuntu has been a challenge. Looks like the padding is a little strong - I’m unable to get to certain filter properties unless I let the filter window float. But even then, it’s a struggle to resize the floating window in order to display all properties.

Drivers are updated and correct, and resolution for the desktop and all other apps displays as it should. Is there a way to change the app resolution for only Shotcut?

Edit: See the third attachment. In this example, I cannot access the Y offset without floating the filter (scroll does not go all the way down). It is also difficult to see whether the Audio Track(s) have been locked/unlocked or muted/unmuted.

ANOTHER EDIT: Since evidently the information above is not clear, I’ve attached another screenshot for those with eyes. The panels are pulled to their maximum size, yet some properties still cannot be seen. As I mentioned above, I can float the panel and see all properties (or hide other panels), but that’s obviously a pain in the ass. The workaround of adding the line QT_AUTO_SCREEN_SCALE_FACTOR=0 does not work. From what I gathered from being given a link instead of an explanation, it looks like an HiDPI issue was potentially fixed with the June release. Unfortunately that release is useless because of the significant audio problems that occur when scrubbing. Is there no real fix for this aside from waiting until the July release when (hopefully) the audio scrubbing will be addressed?

Screenshots:

https://drive.google.com/open?id=1lOqGgJ8rADagusuzNTMOteFZQAhPvnbA
https://drive.google.com/open?id=1-fXoKQVCDsJ_hLIVmHbEEz6xJRP_HjQI
https://drive.google.com/open?id=1PYcKYHksCb_UoNtEzg-COg1Q1NmvYMW1
https://drive.google.com/open?id=19sjosC51Znpn2Y3Hf17pxim_OwwD4zt5


#2

Do you know how to resize the panels in Shotcut? There is a little horizontal line that separates the Timeline from the Video Player window. Hover your mouse over that line and your cursor will become an up/down arrow. When that occurs click and drag to resize the panels and get more room to see your controls.

-=Ken=-


#3

See Program dont fit on tv screen


#4

This didn’t work


#5

Yes, but if you look at the screenshots you can see the horizontal line does not exist underneath the Audio Track. In regard to the filters window, even if the panel is fully expanded it is not enough to see some properties. The text filter, for example, has many properties that cannot be seen even if the window is fully extended.


#6

What is your screen resolution & dpi set at?
What are the computer’s specifications?


#7

1920 x 1080 (60hz refresh rate, 110 dpi). The dpi is set manually for Shotcut, because editing is the single most important function of my machine. I’m running Ubuntu 16.04.4 LTS Studio distro, which I switched to because Shotcut constantly failed on Windows.


#8

I guess I don’t understand what the problem is. Since I don’t do screen shots well, and since you have provided three of them already, let me try to describe the issue as I understand it. In your screenshots just above the Plus sign indicator for zooming into the Timeline there is horizontal row of what looks like about six tiny dots. If you will hover your mouse over that row of dots your cursor will change into an up/down arrow. When it does then click and drag either upward or downward, resizing the panels. There is another “gadget” just like that except it is vertically oriented. You can click and drag that right or left to resize the panels. This works well to facilitate the operation of the Filters panel since you don’t need to see all the Timeline tracks while you are doing it. When through adjusting the filters then you can drag the interface panels again to see the Timeline tracks. HTH,

-=Ken=-


#9

Lol thanks for the tutorial on resizing panels, but I’m not an idiot. If you cannot understand the issue as its cearly described and shown in the screenshots, then perhaps this isn’t the topic for you.


#10

Sorry you have to slam someone for trying to help out. I am a retired IT professional. A problem cannot be resolved unless it is properly defined. I am not having the problem you described. I hope you figure it out.

Best. Really! Best to you.

-=Ken=-


#11

It has been fixed for the next version, but calling it useless and significant is hyperbole IMO.

Did you export it? As you can see, Shotcut uses Qt, which is responsible for drawing the GUI. Shotcut does not override the paddings usually. I run 1920x1200 at 96 dpi, but I do not have the problem. Not many people have a reported a problem that was not solved by the QT_AUTO_SCREEN_SCALE_FACTOR workaround. I can provide a test build using Qt 5.9.5, or I can try to expose the equivalent of QT_AUTO_SCREEN_SCALE_FACTOR in Shotcut’s Settings.
See also this page from Qt. Maybe there are other environment variables needed for your case:
http://doc.qt.io/qt-5/highdpi.html

FYI, Shotcut does call QCoreApplication::setAttribute(Qt::AA_EnableHighDpiScaling); which export QT_AUTO_SCREEN_SCALE_FACTOR=0 is supposed to override and disable.


#12

I tried to use xrandr --dpi 110 (and other values) and gsettings set org.gnome.desktop.interface text-scaling-factor 1.1458 to reproduce but could not. Only when I set text-scaling-factor very high did I reproduce similar issue, which I can address by using font metrics, but I do not think that will fix your case.


#13

It may sound hyperbolic from a developer’s perspective, but not to someone actually trying to use the software to edit video. As an editor, you have to hear what you are working on, so while losing audio scrubbing at a micro-level might seem like a “minor regression” to you, it is indeed required for 99% of editing use-cases. Have you ever had to edit video for something other than a simple youtube tutorial?

Yes, I exported it. It looks different, but the same problems persist, so I’ll simply wait for the next release and hope this addresses the problems.

The reason for my frustration is that I’ve overhauled my system due to Shotcut and don’t understand is why editors like myself and others on this forum should even be expected to perform workarounds on their machines in first place. Seems it would make much more rational sense to provide routine updates that fix regressions, no matter how “minor” or “hyperbolic” they might seem. Is Shotcut still in beta?


#14

You might want to know what you’re talking about before making statements like this.
https://github.com/mltframework/shotcut/commits/master
https://shotcut.org/blog/

I don’t know of any software that get’s this many updates other than PubG.


#15

COOL so I can update my version of Shotcut right now and these committed updates will be applied, right?


#16

I get the impression this software is not suited for your particular, immediate needs.

No need to be insulting to me, other users, nor devs for what you can’t accomplish with the software provided to you to use for free.


#17

The software worked well for years with only minor issues here and there up to the June release. Which means I’ve been as patient as everyone else for that period of time, in spite of Shotcut’s shortcomings that includes constant crashes in Windows. The issues I’ve brought up here are not minor and linking to other complaints about the same issue or rolling back to previous versions does not provide an adequate fix.

You might want to know what you’re talking about before making statements like this.


#18

If you or anyone else reading needs an older version, they can be found here.


#19

There are so much changes done by dan this weeks (& tiny regressions at the same time), that a half-month build could be usefull.
But instead of complaining, I think it’s better to consider donating or contributing or helping…