Shotcut renders with Proxies instead of original files (FIX & question)

I know I’m not the first to post about this, but I’ve never seen a satisfying answer as to why this happens or how to prevent it … but here is how to FIX it.

I am using version 21.12.24 on an old CPU (w Win 10) - so Proxies are a godsend. My projects occasionally crash (usually when I move clips between tracks).

After a week worth of editing with several crashes - leading to several auto recover & “repaired” versions of my mlt, I create a render to check something … and while it renders in 1080p as set, the quality is - for the most part - 360p.

Obviously I suspect proxies, but I am confused as to why this happened. I turn off proxies and render again - same difference.

So I look at the xml (mlt file) and sure enough, a majority - not all mind you - of the files were pointing to the respective proxy: Where at some previous point it said
“video/MVI_2022.MP4”, it now says
(my proxy folder is in the project folder)

Because I don’t work of a single mtl, but “save as” after every scene, I had a previous version to fall back on to now manually edit the mlt (of course I made a copy first).

Here is what I did:

  • Opened both mtl files in notepad side by side
  • Went down the entire file by searching for “resource”
  • Then copy and paste good to bad

Shotcut save information in blocks, so a bad one would look like this:

  <chain id="chain62" out="00:01:16.583">
    <property name="length">00:01:16.617</property>
    <property name="eof">pause</property>
    <property name="resource">proxies/9d60075cac512f3dc288e6e420d5e5bf.mp4</property>
    <property name="mlt_service">avformat</property>
    <property name="seekable">1</property>
    <property name="audio_index">1</property>
    <property name="video_index">0</property>
    <property name="mute_on_pause">1</property>
    <property name="video_delay">0</property>
    <property name="shotcut:hash">9d60075cac512f3dc288e6e420d5e5bf</property>
    <property name="shotcut:caption">MVI_7610.MP4</property>
    <property name="xml">was here</property>

The only thing “corrupted" is the “resource" line (3rd property line) … so I replace that one with (in my case)
<property name="resource">video/MVI_7610.MP4</property>.

If I don’t have a know good entry (because the good file I am using is several edits back), I can still figure out what the good source is because of the caption (2nd lot last) line. (and if that is not there, I can open the proxy file and match it against to original - tedious, but is rarely necessary)

Not all the blocks look like this (there a time-warps, etc. - but all will have the “resource” as the key element that needs fixing. In the end, it shouldn’t refer to a proxy destination anywhere in the mtl, so if it does, it needs correcting.

So my final step is to search for “prox” in the mlt I am repairing - it the search comes up empty, I’m done.

It took me about 2 hrs for a file w 5600 lines … mind you I was going slow and careful (as you always should when doing “brain surgery”)

This works perfectly. Everything is found, renders in full quality and after turning Proxy back on, everything is as it should be … and yes, 2 hrs wasted is no fun - but better than having to re-edit about a weeks worth of content.

The thing I don’t get though is: How does this happen, and how can I prevent it in the future? (or is it a bug?)

Either way - hope this helps someone else out there … cheers everyone.

Honestly i didn’t go through this in detail - way too long and complicated.
As far as i understood your problem: your project several times crashed and you restarted from some auto-save files. Then you manually tried to edit the .mlt-file.
When exporting you ended up with (in some parts???) getting the smaller proxy-results??

  1. Question: only in parts or the complete export was in proxy-size?
  2. Question: how big was your project .mlt-file finally?

I did some bigger projects up to 1++h video in HD and more with mlt-file bigger 1 MB and SC became quite laggy and i worked a lot with proxies. SC also crashed a few times (mostly when i was too impatient). But i never tried to edit the .mlt.
So i would guess the problem could be some fault when editing - not sure tough.
For me this problem never happened.

This has happened to a few other people, and I’m not sure anyone ever figured out what triggered it.

Thanks for posting a detailed explanation of how to fix it! We can refer other people to your steps to help them out.

1 Like

Sorry if I made this too complicated … it’s meant as a How To guide, not a cry for help … the question is only at the end. But let me try to simplify:

Problem: Video renders in low qual (360p) even though set to 1080p.
addtl info: Using proxy editing (and had several crashes & recovers over the course of editing.)

investigation: mlt file (mostly) points to the proxies (not the actual files as it should)
Solution: manually edit the mlt to replace resource reference to proxies w location of original files

This works, but takes time & diligence (still better than having to redo all the work).
Details describe in original post for other as a guide.

Question: Why did it happen in the first place … and how can it be prevented?

Does this problem occur only with the newest version of SC?
I still use an older one and never had these problems.
But honestly i didn’t use SC to its very last detail and ability and never tried to edit the mlt-file.
But i did use proxies quite a lot.

Can’t say for sure Rilo … it’s happened for me a few times over the last year (serval versions) and I know the same is true for other (just search the forum).

Then again, there are other factors to consider (e.g. age of system, type of files, etc.) … and editing is a fairly heavy workload on any system, so crashes happen - regardless of program used.

It would be nice to figure out what exactly triggers the changes in the mtl, so recovery after a crash is more clean more often.

(this of course assumes that the crash is in fact the cause of the problem to begin with … :wink: …)

Did you ever had this problem before SC crashed?

For me it only crashed a few times when working on bigger projects with mlt-files above 1 MB,
but never had this problem. On some projects i had maybe 8 - 10 crashes but i do save project versions often and mostly started to work on these backups. When the crash is ‘hard’ it maybe not possible for SC to fully restore the mlt-file.

This topic was automatically closed after 90 days. New replies are no longer allowed.