Shotcut peak meter reads incorrectly - lowers volume while rendering


#1

I’m making a simple video. It’s just a series of still images. The main purpose of the video is to showcase some music I’ve composed. I know the audio, as I have made it, is not clipping (when examined out of shotcut). I created it in Cubase. That meansthe audio in the FINAL stage of production in Cubase is hitting a BRICKWALL LIMITER after compression.

After I rendered my video in Shotcut the audio was noticeably more quiet. Upon checking the volume controls in Shotcut, they are set to 0db yet peaks go over that (ie clip). Of course I haven’t or wouldn’t alter the audio in Shotcut. I used 1000’s of dollars of gear to make this music. I am assuming what is happening is Shotcut is detecting the clip incorrectly and therefor “doing it’s job” and fixing the “problem” by lowering the volume X amount of DB to compensate for the (incorrectly) perceived clipping.

And no, I can’t settle for it being quieter. It’s orchestral music that already has a high dynamic range and is really difficult to master without killing the tonal qualities. (ie to make “louder” is very difficult from a music production stand point, therefor I need the audio to be set to 0.0db in Shotcut - I cannot, nor will not add some random compressor or limiter in Shotcut or lower the volume.)

Even within Shotcut the peak meter is showing occasional peaks of +1 to +3db which is absurd. Obviously in the digital realm ANY amount of clipping past 0.0db is bad news…

Are the audio render options playing a role in this issue?


Audio level not calibrated?
#2

Do you have a before and after sample?
I ask because I have never noticed such a problem, I don’t think Shotcut makes any audio adjustments automatically.


#3

Upon some more googling it seems people had these issues in Vegas, and it was due to import options.

I’m currently playing with audio export options to see if that has some effect.

Are there even import options in Shotcut? I can’t see any.

As far as samples go, I’d have to upload the video and have you compare it to say a soundcloud upload.


#4

Settings>Video mode But none for the audio stream.

Which audio codec is use for the source video’s audio track?


#5

2ch 44.1 KHz PCM 32-bit floating point little-endian

I do notice that all the export settings default unless I was to save a preset.


#6

If you are using the Audio Peak Meter Scope in Shotcut, it bases its reading on oversampled values. So, if your source has hard limits as 0dBFS, it is very possible that the Peak Meter falsely reads >0dBFS.

You might consider looking at the Audio Waveform Scope. That will show the actual waveform for each frame.

Shotcut won’t alter your audio unless you add a filter. It doesn’t automatically analyze and limit the audio.

Also, it isn’t clear from your description: When you analyze a file exported from Shotcut, are the levels actually lower than the source? Did you use your ears, or a tool to verify that?


#7

Thanks for the intel Brian. According to the waveform it doesn’t appear to be going over 0.0db. (if visually shotcuts waveform lets it draw past 0.0db on the scope)

I heard the difference. To me it was dramatic (probably over a DB) but to a normal person they might not even notice.

I’ve probably done a dozen renders and magically the level “seems” to be proper and unchanged now. I’ll check in a bit after dinner and confirm.


#8

Ok the render from shotcut retains the loudness that I oringally produced.

It’s clear now that youtube normalizes audio… my god. Accepting the compression of data via YT is one thing…but audio normalization. ugh. Hopefully I can persuade people to go to SoundCloud.


Audio level not calibrated?
#9

I experienced similar problems: (1) once the video clip in the timeline, the audio level drops significantly (6 to 14dB depending on the audio track). (2) the peak meter goes above 0dB. (1): this was a problem in the Shotcut version I was using (17.06.22). With the latest 19.02.28 there is no more such a problem. (2): I recorded a video with 0dB audio input and when played in Shotcut 19.02.28 the peak meter shows apprx. +2dB. I understood from brian’s post above that this is probably due to oversampling. Would it be possible to have a more detailed explanation of this oversampling effect?