Shotcut installed but wont execute


#1

Hi, I’ve installed Shotcut 17.10 on ubuntu studio (16.0.3) but when I execute it nothing happens. I’ve tried installing it via the snap method, zip and manually. Nothing is working. Please help.


#2

What happens if you try to run it via terminal?


#3

It says this…

[Debug  ] <static ShotcutSettings& ShotcutSettings::singleton()> language "en_GB" 
[Debug  ] <static ShotcutSettings& ShotcutSettings::singleton()> deinterlacer "onefield" 
[Debug  ] <static ShotcutSettings& ShotcutSettings::singleton()> external monitor "" 
[Debug  ] <static ShotcutSettings& ShotcutSettings::singleton()> GPU processing false 
[Debug  ] <static ShotcutSettings& ShotcutSettings::singleton()> interpolation "nearest" 
[Debug  ] <static ShotcutSettings& ShotcutSettings::singleton()> video mode "" 
[Debug  ] <static ShotcutSettings& ShotcutSettings::singleton()> realtime true 
[Info   ] <Application::Application(int&, char**)> Starting Shotcut version 17.10.02 
[Info   ] <Application::Application(int&, char**)> Linux version 
[Info   ] <Application::Application(int&, char**)> number of logical cores = 2 
[Info   ] <Application::Application(int&, char**)> locale = QLocale(English, Latin, UnitedKingdom) 
[Info   ] <Application::Application(int&, char**)> install dir = "/snap/shotcut/12/Shotcut.app/bin" 
[Info   ] <Application::Application(int&, char**)> device pixel ratio = 1 
[Debug  ] <MainWindow::changeTheme> begin 
[Debug  ] <MainWindow::changeTheme> end 
[Debug  ] <MainWindow::MainWindow()> begin 
[Info   ] <GLTestWidget::GLTestWidget(QWidget*)> OpenGL context version 2 1 
[Debug  ] <Mlt::Controller::Controller()> begin 
[Info   ] <MLT> plugin_mgr_get_object_file_plugins: error finding ladspa_descriptor symbol in object file '/usr/lib/ladspa/blop_files/sawtooth_1641_data.so': /usr/lib/ladspa/blop_files/sawtooth_1641_data.so: undefined symbol: ladspa_descriptor
[Info   ] <MLT> plugin_mgr_get_object_file_plugins: error finding ladspa_descriptor symbol in object file '/usr/lib/ladspa/blop_files/parabola_1649_data.so': /usr/lib/ladspa/blop_files/parabola_1649_data.so: undefined symbol: ladspa_descriptor
[Info   ] <MLT> plugin_mgr_get_object_file_plugins: error finding ladspa_descriptor symbol in object file '/usr/lib/ladspa/blop_files/square_1643_data.so': /usr/lib/ladspa/blop_files/square_1643_data.so: undefined symbol: ladspa_descriptor
no more csLADSPA plugins
[Info   ] <MLT> plugin_mgr_get_object_file_plugins: error opening shared object file '/usr/lib/ladspa/ladspa-rubberband.cat': /usr/lib/ladspa/ladspa-rubberband.cat: invalid ELF header
[Info   ] <MLT> Plugin 1952 exists in both '/usr/lib/ladspa/vco_sawpulse.so' and '/usr/lib/ladspa/blvco.so'; using version in '/usr/lib/ladspa/vco_sawpulse.so'
[Info   ] <MLT> Plugin 1953 exists in both '/usr/lib/ladspa/vco_sawpulse.so' and '/usr/lib/ladspa/blvco.so'; using version in '/usr/lib/ladspa/vco_sawpulse.so'
[Info   ] <MLT> Plugin 1954 exists in both '/usr/lib/ladspa/vco_sawpulse.so' and '/usr/lib/ladspa/blvco.so'; using version in '/usr/lib/ladspa/vco_sawpulse.so'
[Info   ] <MLT> Plugin 2670 exists in both '/usr/lib/ladspa/waveguide_mesh_2670.so' and '/usr/lib/ladspa/signal_abs_2669.so'; using version in '/usr/lib/ladspa/waveguide_mesh_2670.so'
[Debug  ] <Mlt::Controller::Controller()> end 
[Debug  ] <Mlt::GLWidget::GLWidget(QObject*)> begin 
[Debug  ] <Mlt::GLWidget::GLWidget(QObject*)> end 
[Debug  ] <MainWindow::setupSettingsMenu> begin 
libDeckLinkAPI.so: cannot open shared object file: No such file or directory
[Warning] <MLT> [ 0x20352b0] The DeckLink drivers not installed.
[Debug  ] <MainWindow::setupSettingsMenu> end 
[Debug  ] <MainWindow::readPlayerSettings> begin 
[Debug  ] <MainWindow::readPlayerSettings> end 
[Debug  ] <MainWindow::configureVideoWidget> begin 
[Debug  ] <MainWindow::setProfile> "" 
[Debug  ] <Mlt::Controller::setProfile> setting to profile "Automatic" 
[Debug  ] <MainWindow::configureVideoWidget> end 
[Debug  ] <ScopeController::ScopeController(QMainWindow*, QMenu*)> begin 
[Debug  ] <ScopeWidget::ScopeWidget(const QString&)> begin true 
[Debug  ] <ScopeWidget::ScopeWidget(const QString&)> end 
[Debug  ] <AudioLoudnessScopeWidget::AudioLoudnessScopeWidget()> begin 
[Debug  ] <AudioLoudnessScopeWidget::AudioLoudnessScopeWidget()> end 
[Debug  ] <ScopeDock::ScopeDock(ScopeController*, ScopeWidget*)> begin 
[Debug  ] <ScopeDock::ScopeDock(ScopeController*, ScopeWidget*)> end 
[Debug  ] <ScopeWidget::ScopeWidget(const QString&)> begin true 
[Debug  ] <ScopeWidget::ScopeWidget(const QString&)> end 
[Debug  ] <AudioPeakMeterScopeWidget::AudioPeakMeterScopeWidget()> begin 
[Debug  ] <AudioPeakMeterScopeWidget::AudioPeakMeterScopeWidget()> end 
[Debug  ] <ScopeDock::ScopeDock(ScopeController*, ScopeWidget*)> begin 
[Debug  ] <ScopeDock::ScopeDock(ScopeController*, ScopeWidget*)> end 
[Debug  ] <ScopeWidget::ScopeWidget(const QString&)> begin true 
[Debug  ] <ScopeWidget::ScopeWidget(const QString&)> end 
[Debug  ] <AudioSpectrumScopeWidget::AudioSpectrumScopeWidget()> begin 
[Debug  ] <AudioSpectrumScopeWidget::AudioSpectrumScopeWidget()> end 
[Debug  ] <ScopeDock::ScopeDock(ScopeController*, ScopeWidget*)> begin 
[Debug  ] <ScopeDock::ScopeDock(ScopeController*, ScopeWidget*)> end 
[Debug  ] <ScopeWidget::ScopeWidget(const QString&)> begin true 
[Debug  ] <ScopeWidget::ScopeWidget(const QString&)> end 
[Debug  ] <AudioWaveformScopeWidget::AudioWaveformScopeWidget()> begin 
[Debug  ] <AudioWaveformScopeWidget::AudioWaveformScopeWidget()> end 
[Debug  ] <ScopeDock::ScopeDock(ScopeController*, ScopeWidget*)> begin 
[Debug  ] <ScopeDock::ScopeDock(ScopeController*, ScopeWidget*)> end 
[Debug  ] <ScopeController::ScopeController(QMainWindow*, QMenu*)> end 
[Debug  ] <RecentDock::RecentDock(QWidget*)> begin 
[Debug  ] <RecentDock::RecentDock(QWidget*)> end 
[Debug  ] <PlaylistDock::PlaylistDock(QWidget*)> begin 
[Debug  ] <PlaylistDock::PlaylistDock(QWidget*)> end 
[Debug  ] <TimelineDock::TimelineDock(QWidget*)> begin 
[Debug  ] <TimelineDock::TimelineDock(QWidget*)> end 
[Debug  ] <FiltersDock::FiltersDock(MetadataModel*, AttachedFiltersModel*, QWidget*)> begin 
[Debug  ] <FiltersDock::FiltersDock(MetadataModel*, AttachedFiltersModel*, QWidget*)> end 
[Debug  ] <EncodeDock::EncodeDock(QWidget*)> begin 
---
formats:
  - a64
  - ac3
  - adts
  - adx
  - aiff
  - amr
  - apng
  - asf
  - ass
  - ast
  - asf_stream
  - au
  - avi
  - avm2
  - bit
  - caf
  - cavsvideo
  - crc
  - dash
  - data
  - daud
  - dirac
  - dnxhd
  - dts
  - dv
  - eac3
  - f4v
  - ffm
  - ffmetadata
  - fifo
  - filmstrip
  - flac
  - flv
  - framecrc
  - framehash
  - framemd5
  - g722
  - g723_1
  - gif
  - gsm
  - gxf
  - h261
  - h263
  - h264
  - hash
  - hds
  - hevc
  - hls
  - ico
  - ilbc
  - image2
  - image2pipe
  - ipod
  - ircam
  - ismv
  - ivf
  - jacosub
  - latm
  - lrc
  - m4v
  - md5
  - matroska
  - matroska
  - microdvd
  - mjpeg
  - mlp
  - mmf
  - mov
  - mp2
  - mp3
  - mp4
  - mpeg
  - vcd
  - mpeg1video
  - dvd
  - svcd
  - mpeg2video
  - vob
  - mpegts
  - mpjpeg
  - mxf
  - mxf_d10
  - mxf_opatom
  - null
  - nut
  - oga
  - ogg
  - ogv
  - oma
  - opus
  - alaw
  - mulaw
  - f64be
  - f64le
  - f32be
  - f32le
  - s32be
  - s32le
  - s24be
  - s24le
  - s16be
  - s16le
  - s8
  - u32be
  - u32le
  - u24be
  - u24le
  - u16be
  - u16le
  - u8
  - psp
  - rawvideo
  - rm
  - roq
  - rso
  - rtp
  - rtp_mpegts
  - rtsp
  - sap
  - segment
  - stream_segment,ssegment
  - singlejpeg
  - smjpeg
  - smoothstreaming
  - sox
  - spx
  - spdif
  - srt
  - swf
  - tee
  - 3g2
  - 3gp
  - mkvtimestamp_v2
  - truehd
  - tta
  - uncodedframecrc
  - vc1
  - vc1test
  - voc
  - w64
  - wav
  - webm
  - webm_dash_manifest
  - webm_chunk
  - webp
  - webvtt
  - wtv
  - wv
  - yuv4mpegpipe
  - alsa
  - fbdev
  - oss
  - pulse
  - sdl,sdl2
  - v4l2
  - xv
...
---
audio_codecs:
  - comfortnoise
  - s302m
  - aac
  - ac3
  - ac3_fixed
  - alac
  - dca
  - eac3
  - flac
  - g723_1
  - mlp
  - mp2
  - mp2fixed
  - nellymoser
  - real_144
  - sonic
  - sonicls
  - truehd
  - tta
  - vorbis
  - wavpack
  - wmav1
  - wmav2
  - pcm_alaw
  - pcm_f32be
  - pcm_f32le
  - pcm_f64be
  - pcm_f64le
  - pcm_mulaw
  - pcm_s8
  - pcm_s8_planar
  - pcm_s16be
  - pcm_s16be_planar
  - pcm_s16le
  - pcm_s16le_planar
  - pcm_s24be
  - pcm_s24daud
  - pcm_s24le
  - pcm_s24le_planar
  - pcm_s32be
  - pcm_s32le
  - pcm_s32le_planar
  - pcm_s64be
  - pcm_s64le
  - pcm_u8
  - pcm_u16be
  - pcm_u16le
  - pcm_u24be
  - pcm_u24le
  - pcm_u32be
  - pcm_u32le
  - roq_dpcm
  - adpcm_adx
  - g722
  - g726
  - adpcm_ima_qt
  - adpcm_ima_wav
  - adpcm_ms
  - adpcm_swf
  - adpcm_yamaha
  - libmp3lame
  - libopus
  - libvorbis
...
---
video_codecs:
  - a64multi
  - a64multi5
  - alias_pix
  - amv
  - apng
  - asv1
  - asv2
  - avrp
  - avui
  - ayuv
  - bmp
  - cinepak
  - cljr
  - dnxhd
  - dpx
  - dvvideo
  - ffv1
  - ffvhuff
  - flashsv
  - flashsv2
  - flv
  - gif
  - h261
  - h263
  - h263p
  - huffyuv
  - jpeg2000
  - jpegls
  - ljpeg
  - mjpeg
  - mpeg1video
  - mpeg2video
  - mpeg4
  - msmpeg4v2
  - msmpeg4
  - msvideo1
  - pam
  - pbm
  - pcx
  - pgm
  - pgmyuv
  - png
  - ppm
  - prores
  - prores_aw
  - prores_ks
  - qtrle
  - r10k
  - r210
  - rawvideo
  - roqvideo
  - rv10
  - rv20
  - sgi
  - snow
  - sunrast
  - svq1
  - targa
  - tiff
  - utvideo
  - v210
  - v308
  - v408
  - v410
  - vc2
  - wrapped_avframe
  - wmv1
  - wmv2
  - xbm
  - xface
  - xwd
  - y41p
  - yuv4
  - zlib
  - zmbv
  - libtheora
  - libvpx
  - libvpx-vp9
  - libx264
  - libx264rgb
  - libx265
  - h264_nvenc
  - nvenc
  - nvenc_h264
  - nvenc_hevc
  - hevc_nvenc
...
[Debug  ] <EncodeDock::EncodeDock(QWidget*)> end 
[Debug  ] <JobsDock::JobsDock(QWidget*)> begin 
[Debug  ] <JobsDock::JobsDock(QWidget*)> end 
[Debug  ] <MainWindow::readWindowSettings> begin 
[Debug  ] <MainWindow::readWindowSettings> end 
[Debug  ] <LeapNetworkListener::start> begin 
[Debug  ] <MainWindow::MainWindow()> end 
[Warning] <> QSqlQuery::value: not positioned on a valid record
[Error  ] <Database::upgradeVersion1> Failed to create thumbnails table. 
[Debug  ] <Database::run> Database version is 0 
[Debug  ] <Mlt::GLWidget::initializeGL> begin 
[Info   ] <Mlt::GLWidget::initializeGL> OpenGL vendor "nouveau" 
[Info   ] <Mlt::GLWidget::initializeGL> OpenGL renderer "Gallium 0.4 on NV63" 
[Info   ] <Mlt::GLWidget::initializeGL> OpenGL threaded? false 
[Info   ] <Mlt::GLWidget::initializeGL> OpenGL ES? false 
[Debug  ] <Mlt::GLWidget::initializeGL> end 
Segmentation fault (core dumped)

#4

Just reinstall and erase config.

And then try to launch as admin

Where did you put the package?


#5

Thanks Keno40, that’s a good question. I seem to have two installations under the snap folder. Now I can’t even uninstall it. it shows up under synaptic package manager but I can’t do anything with it. Can I just delete the shotcut folders under the snap folder?


#6

Ok so I’ve managed to uninstall and reinstall via snap. Same thing - no execution. How do I erase config? And launch as admin? Sorry I’m a linux newby


#7

I use Linux Mint 17.3. I can’t use SNAP packages because they are only supported in Mint 18+ so I use the ‘Linux Portable zip’ packages. I just designate a Shotcut folder, which the unzipper makes for me, under the Downloads folder. For convenience I add a ‘Launcher’ on my Home screen. I did have to install the SWH LADSPA plugins package as described in the Download page, HTH -=Ken=-


#8

Thanks kenj69. That may be the case. I’ve tried the portable zip method, it still doesn’t execute. I have two of the required packages already installed (libsox2 libsdl2-2.0-0) but when I try to install libjack0 it says I have to remove a huge list of other packages including libjack-jackd2-0. I can only speculate what kind of problems this move would give the system. I’m going to last resort i think and installing it on the Windows dual boot.


#9

Here is my installation location:

/home/buddy/Downloads/Shotcut/Shotcut/Shotcut/Shotcut.app

Kind of convoluted, huh? In the Shotcut.app folder is a shell script named … Shotcut! Double-click that and it comes up. I wouldn’t worry too much about Jack audio app. Once you get it to come up go to File/Open other… and select the audio under Device. I had to select ALSA the first time I ran Shotcut and the audio has worked properly ever since, through several newer releases. HTH -=Ken=-

-=Ken=-


#10

Thanks again. So I moved the zip shotcut folder from a separate drive to the home folder on the system drive like your install but when I double click the shotcut file under shotcut.app it opens it in mousepad as text. I’ve run that text in the terminal for kicks and giggles but didn’t find it very funny when nothing happened. Am I missing something??


#11

Oops, my description was wrong. You should navigate to the Shotcut folder which contains the Shotcut.app folder and “Shotcut” which a shell script. If double-clicking on Shotcut doesn’t give you an option to run or edit then right-click on the file, select Properties, and change the Permissions to Execute: Allow executing file as a program.

-=Ken=-


#12

Same as kenj69 said.

Except that, on Ubuntu, I used to do that :

  • from the desktop : right click ,add new launch icon (or something like that…)
  • you can try to search by name of the program “Shotcut”
  • Then you can edit the shortcut with right click and point to “XXXXX/…//Shotcut.app
  • to try to launch as admin, just add Sudo at the start of the command line

Try to launch this way then & report


#13

Ok so under the permissions of Shotcut shell script there is a box (already ticked) saying “Allow this file to run as a program” but its still not executing. I only have the options to run it under another application. Run in Terminal using sudo it gives me this…

$ sudo shotcut
[sudo] password for watiz: 
[Debug  ] <static ShotcutSettings& ShotcutSettings::singleton()> language "en_GB" 
[Debug  ] <static ShotcutSettings& ShotcutSettings::singleton()> deinterlacer "onefield" 
[Debug  ] <static ShotcutSettings& ShotcutSettings::singleton()> external monitor "" 
[Debug  ] <static ShotcutSettings& ShotcutSettings::singleton()> GPU processing false 
[Debug  ] <static ShotcutSettings& ShotcutSettings::singleton()> interpolation "nearest" 
[Debug  ] <static ShotcutSettings& ShotcutSettings::singleton()> video mode "" 
[Debug  ] <static ShotcutSettings& ShotcutSettings::singleton()> realtime true 
[Info   ] <Application::Application(int&, char**)> Starting Shotcut version 17.10.02 
[Info   ] <Application::Application(int&, char**)> Linux version 
[Info   ] <Application::Application(int&, char**)> number of logical cores = 2 
[Info   ] <Application::Application(int&, char**)> locale = QLocale(English, Latin, UnitedKingdom) 
[Info   ] <Application::Application(int&, char**)> install dir = "/snap/shotcut/12/Shotcut.app/bin" 
[Info   ] <Application::Application(int&, char**)> device pixel ratio = 1 
[Debug  ] <MainWindow::changeTheme> begin 
[Debug  ] <MainWindow::changeTheme> end 
[Debug  ] <MainWindow::MainWindow()> begin 
[Info   ] <GLTestWidget::GLTestWidget(QWidget*)> OpenGL context version 2 1 
[Debug  ] <Mlt::Controller::Controller()> begin 
[Info   ] <MLT> plugin_mgr_get_object_file_plugins: error finding ladspa_descriptor symbol in object file '/usr/lib/ladspa/blop_files/sawtooth_1641_data.so': /usr/lib/ladspa/blop_files/sawtooth_1641_data.so: undefined symbol: ladspa_descriptor
[Info   ] <MLT> plugin_mgr_get_object_file_plugins: error finding ladspa_descriptor symbol in object file '/usr/lib/ladspa/blop_files/parabola_1649_data.so': /usr/lib/ladspa/blop_files/parabola_1649_data.so: undefined symbol: ladspa_descriptor
[Info   ] <MLT> plugin_mgr_get_object_file_plugins: error finding ladspa_descriptor symbol in object file '/usr/lib/ladspa/blop_files/square_1643_data.so': /usr/lib/ladspa/blop_files/square_1643_data.so: undefined symbol: ladspa_descriptor
no more csLADSPA plugins
[Info   ] <MLT> plugin_mgr_get_object_file_plugins: error opening shared object file '/usr/lib/ladspa/ladspa-rubberband.cat': /usr/lib/ladspa/ladspa-rubberband.cat: invalid ELF header
[Info   ] <MLT> Plugin 1952 exists in both '/usr/lib/ladspa/vco_sawpulse.so' and '/usr/lib/ladspa/blvco.so'; using version in '/usr/lib/ladspa/vco_sawpulse.so'
[Info   ] <MLT> Plugin 1953 exists in both '/usr/lib/ladspa/vco_sawpulse.so' and '/usr/lib/ladspa/blvco.so'; using version in '/usr/lib/ladspa/vco_sawpulse.so'
[Info   ] <MLT> Plugin 1954 exists in both '/usr/lib/ladspa/vco_sawpulse.so' and '/usr/lib/ladspa/blvco.so'; using version in '/usr/lib/ladspa/vco_sawpulse.so'
[Info   ] <MLT> Plugin 2670 exists in both '/usr/lib/ladspa/waveguide_mesh_2670.so' and '/usr/lib/ladspa/signal_abs_2669.so'; using version in '/usr/lib/ladspa/waveguide_mesh_2670.so'
[Debug  ] <Mlt::Controller::Controller()> end 
[Debug  ] <Mlt::GLWidget::GLWidget(QObject*)> begin 
[Debug  ] <Mlt::GLWidget::GLWidget(QObject*)> end 
[Debug  ] <MainWindow::setupSettingsMenu> begin 
libDeckLinkAPI.so: cannot open shared object file: No such file or directory
[Warning] <MLT> [ 0x253bca0] The DeckLink drivers not installed.
[Debug  ] <MainWindow::setupSettingsMenu> end 
[Debug  ] <MainWindow::readPlayerSettings> begin 
[Debug  ] <MainWindow::readPlayerSettings> end 
[Debug  ] <MainWindow::configureVideoWidget> begin 
[Debug  ] <MainWindow::setProfile> "" 
[Debug  ] <Mlt::Controller::setProfile> setting to profile "Automatic" 
[Debug  ] <MainWindow::configureVideoWidget> end 
[Debug  ] <ScopeController::ScopeController(QMainWindow*, QMenu*)> begin 
[Debug  ] <ScopeWidget::ScopeWidget(const QString&)> begin true 
[Debug  ] <ScopeWidget::ScopeWidget(const QString&)> end 
[Debug  ] <AudioLoudnessScopeWidget::AudioLoudnessScopeWidget()> begin 
[Debug  ] <AudioLoudnessScopeWidget::AudioLoudnessScopeWidget()> end 
[Debug  ] <ScopeDock::ScopeDock(ScopeController*, ScopeWidget*)> begin 
[Debug  ] <ScopeDock::ScopeDock(ScopeController*, ScopeWidget*)> end 
[Debug  ] <ScopeWidget::ScopeWidget(const QString&)> begin true 
[Debug  ] <ScopeWidget::ScopeWidget(const QString&)> end 
[Debug  ] <AudioPeakMeterScopeWidget::AudioPeakMeterScopeWidget()> begin 
[Debug  ] <AudioPeakMeterScopeWidget::AudioPeakMeterScopeWidget()> end 
[Debug  ] <ScopeDock::ScopeDock(ScopeController*, ScopeWidget*)> begin 
[Debug  ] <ScopeDock::ScopeDock(ScopeController*, ScopeWidget*)> end 
[Debug  ] <ScopeWidget::ScopeWidget(const QString&)> begin true 
[Debug  ] <ScopeWidget::ScopeWidget(const QString&)> end 
[Debug  ] <AudioSpectrumScopeWidget::AudioSpectrumScopeWidget()> begin 
[Debug  ] <AudioSpectrumScopeWidget::AudioSpectrumScopeWidget()> end 
[Debug  ] <ScopeDock::ScopeDock(ScopeController*, ScopeWidget*)> begin 
[Debug  ] <ScopeDock::ScopeDock(ScopeController*, ScopeWidget*)> end 
[Debug  ] <ScopeWidget::ScopeWidget(const QString&)> begin true 
[Debug  ] <ScopeWidget::ScopeWidget(const QString&)> end 
[Debug  ] <AudioWaveformScopeWidget::AudioWaveformScopeWidget()> begin 
[Debug  ] <AudioWaveformScopeWidget::AudioWaveformScopeWidget()> end 
[Debug  ] <ScopeDock::ScopeDock(ScopeController*, ScopeWidget*)> begin 
[Debug  ] <ScopeDock::ScopeDock(ScopeController*, ScopeWidget*)> end 
[Debug  ] <ScopeController::ScopeController(QMainWindow*, QMenu*)> end 
[Debug  ] <RecentDock::RecentDock(QWidget*)> begin 
[Debug  ] <RecentDock::RecentDock(QWidget*)> end 
[Debug  ] <PlaylistDock::PlaylistDock(QWidget*)> begin 
[Debug  ] <PlaylistDock::PlaylistDock(QWidget*)> end 
[Debug  ] <TimelineDock::TimelineDock(QWidget*)> begin 
[Debug  ] <TimelineDock::TimelineDock(QWidget*)> end 
[Debug  ] <FiltersDock::FiltersDock(MetadataModel*, AttachedFiltersModel*, QWidget*)> begin 
[Debug  ] <FiltersDock::FiltersDock(MetadataModel*, AttachedFiltersModel*, QWidget*)> end 
[Debug  ] <EncodeDock::EncodeDock(QWidget*)> begin 
---
formats:
 bla bla bla
...
---
audio_codecs:
  bla bla bla bla
...
---
video_codecs:
  bla bla bla bla bla bla
...
[Debug  ] <EncodeDock::EncodeDock(QWidget*)> end 
[Debug  ] <JobsDock::JobsDock(QWidget*)> begin 
[Debug  ] <JobsDock::JobsDock(QWidget*)> end 
[Debug  ] <MainWindow::readWindowSettings> begin 
[Debug  ] <MainWindow::readWindowSettings> end 
[Debug  ] <LeapNetworkListener::start> begin 
[Debug  ] <MainWindow::MainWindow()> end 
[Debug  ] <Mlt::GLWidget::initializeGL> begin 
[Info   ] <Mlt::GLWidget::initializeGL> OpenGL vendor "nouveau" 
[Info   ] <Mlt::GLWidget::initializeGL> OpenGL renderer "Gallium 0.4 on NV63" 
[Info   ] <Mlt::GLWidget::initializeGL> OpenGL threaded? false 
[Info   ] <Mlt::GLWidget::initializeGL> OpenGL ES? false 
[Debug  ] <Mlt::GLWidget::initializeGL> end 
Segmentation fault (core dumped)

It looks like there are necessary drivers missing.

Interestingly there is an Openshot icon (launcher) in the top right hand corner of the desktop today. It wants to work it seems but can’t


#14

As I mentioned earlier I did have to install the SWH LADSPA plugins package as described in the Download page. Also, my desktop “launcher” (shortcut) has Read/Write permissions on the file.

Interestingly, for me, I can’t run the Shotcut shell script from the Terminal! Many moons ago I was a unix System V administrator - but things in the unix, and now the Linux world seem to have changed (and perhaps I am rusty!). Using Linux Mint, when I open Nemo, Files and PCManFM in the folder where the Shotcut shell script is located I see “Shotcut” and that’s all. Using Dolphin, Krusader and Terminal I see Shotcut.desktop! Double-clicking on all of these file managers except PCManFM will open Shotcut. Very strangely, Terminal refuses to recognize Shotcut or Shotcut.desktop, even when pre-pending with sudo which I find very odd!

BTW, historically, didn’t a shell script have to have a .sh on the end of the filename??

-=Ken=-


#15

Sigh, swh plugins are already installed. I’ve reinstalled them to no effect. Yep the launcher is read/write. I’m wondering what the metaphysical meaning of this hurdle is. Shotcut wont execute on ubuntu. It will on Windows. I guess that’s why I’ve got Windows. I dream of a day without the need for Windows and murder in general but let’s face it the darkside is a better executioner


#16

Well, this is a head scratcher. Shotcut should certainly be able to run on ubuntu. I set up Mint and Win 7 to dual-boot on this machine and I am loath to run Billy’s OS. I even have Sony Vegas MS 10 which is a very fine editor. It has taken 3 years to find a reliable editor on Linux and now that I have found Shotcut I am quite happy. Still waiting for keyframes though.

BTW, I did try Kdenlive. It was the only other editor on Linux that would display HDV video properly. But it wouldn’t even stay running long enough to add a clip! Shotcut has been ultra stable for me.

-=Ken=-


#17

Hi,

I have the same exact problem with normal Ubuntu 17.10. I can’t find a solution for it. I hope this will be fixed soon.


#18

This part caught my attention. “nouveau” is an open source Nvidia driver.

If, in fact, you have an Nvidia card, try this

1. sudo apt-get purge nvidia*
2. sudo add-apt-repository ppa:graphics-drivers
3. sudo apt-get update
4. sudo apt-get install nvidia-NNN
5. <REBOOT>
6. lsmod | grep nvidia
  • This removes any traces of old Nvidia drivers,
  • adds the repository for graphics-drivers,
  • does an update to take advantage of the new repository,
  • This is where the magic happens…

NNN refers to the current rev. number for Nvidia’s drivers
You can go to the graphics-drivers web site, or
the Nvidia web site to get the current rev. number.
As of this posting, the current rev. is 384.90
In this case
sudo apt-get install nvidia-384
Do not enter 384.90!!!

  • reboot activates the new drivers (otherwise the nouveau drivers will still be in charge)
  • and the lsmod | (called “pipe”, it’s a vertical bar, not an I or l) grep nvidia shows if the nvidia drivers are installed. If you see lots of nvidias in the output, you’re done. If you see lots of nouveaus, you didn’t reboot, or you did something wrong. If nothing comes back from the lsmod, you really got something very wrong. Do the process again. Cut & paste is your friend.

Using SUDO comes with the risk that, if something is typed incorrectly, the results will vary from nothing to rendering your OS unusable. Spelling counts! You have been warned.
Have a nice day.


#19

Ok wow thankyou RBEmerson :slight_smile:

Interesting events transpired, magic you could say but as the naive apprentice, it didn’t go as expected when i waved my wand.

so i followed instructions 1-4 to the copy and paste degree with the exception of adding the 384 and an extra l on “instal”. I salute your test of awareness. All seemed to be going to plan.

I reboot the computer. i’m guessing that’s what no.5 meant as copy and paste failed me.

Some kind of alice in wonderland trickery took place as the desktop font doubled in size. Very discombobulating. the screen resolution was now 640x480 instead of 1280x1024 and unchangeable. I kept cool however as the world around me was spinning into madness. I C&Pd number 6. There was one lonely nvidia driver.

Most relevantly Shotcut did not execute.

So I went through stages 1-3 again which removed nvidia-384. I figured i’d try a reboot here which to my delight restored the correct resolution along with my sanity.

Thanks for your idea my friend. It may not have resolved the shotcut problem but i had a wild adventure and i REEAAALLLLLYYY appreciate my screen resolution now! Its true what they say, we don’t appreciate what we’ve got till its gone.


#20

Thanks for the heads up on the install typo.

The initial BIOS and Ubuntu splash screens may look odd, but, after the full boot process wraps up, everything should be normal.

First which Linux distribution are your using? Second, check on the Nvidia site to verify that your particular GPU is covered by 384.90. I suspect the problem centers on the wrong driver for the card.