Shotcut fails to load any video file

What is your operating system?

NAME=“openSUSE Tumbleweed”

What is your Shotcut version (see Help > About Shotcut)?

Can you repeat the problem? If so, what are the steps?
(Please be specific and use the names as seen in Shotcut, preferably English. Include a screenshot or screen recording if you can. Also, you can attach logs from either View > Application Log or right-click a job and choose View Log.)

[Debug ] MainWindow::open “/photos/movies/S22/2023-09/20230924_104908.mp4”
[Info ] MainWindow::showStatusMessage “Failed to open /photos/movies/S22/2023-09/20230924_104908.mp4”

I am unable to open any video or audio file into shotcut. See error message above. This happens since my last OS upgrade. So I am pretty sure it is an OS issue. However I cannot see any logs which points me in the right direction. Is there a way to produce a more detailed log output?

1 Like

You mention an upgrade, so I’m assuming that is an “in-place” upgrade and not a complete install of the new OS?

Any mount points, file locations, or drive storage that has changed? I see it references the path “/photos/movies/S22/2023-09/20230924_104908.mp4”. Where is this photos folder located and has it been mounted?

What happens if you try dragging or importing a video that is located under your current home folder?

Yes, this was an in-place update.

The mount points and file locations are still the same. I forgot to mention that I am able to open and view the video with vlc for example. So the video itself is there and loadable.

I copied the file to my home directory, but this didn’t help either.

And I also want to point out that this happened to all video and audio files I tried to load.

I can confirm this, shotcut doesnt work on OpenSUSE Tumbleweed anymore. I have tested the Linux AppImage-version and the Linux portable tar of the download page.

I see the following systemd messages:

systemd[1686]       Started /home/gerhard/bin/shotcut-linux-x86_64-230929.AppImage.
shotcut[2910] cannot open shared object file: No such file or directory
plasmashell[1859]   QString::arg: Argument missing: *.png, shotcut
plasmashell[1859]   QString::arg: Argument missing: *.svg, shotcut
systemd[1]          tmp-.mount_shotcu41iDxI.mount: Deactivated successfully.

I don’t have any idea.

I use AppImages on Linux primarily to keep multiple versions at the same time, so that is weird, but not completely unusual.

Have you both tried a reinstall after removing the config/data folders? They are usually located here:

Uninstall the current version if it was a local install and not a portable tar or AppImage. Then rename both those folders to Meltytech.old before reinstalling the latest version, and see how you go.

What are the file permissions on the video/audio that won’t load but will play in VLC? I can’t see that being an issue but it’s worth looking at quickly and will only take a few moments to establish (they could be read only, although I highly doubt it). Can you edit (not just play) these files in another program like Kdenlive on the same OS?

Sorry for all the questions but they might help narrow down the issue.

Thanks for looking into this!

I removed both directories

and started shotcut as appImage again. Unfortunately without success.

The permissions on the video files are 775, so they should be read/writable.

I installed kdenlive on the same system and it was able to load the video files right way without any issue.

I also installed a new computer with openSUSE Tumbleweed at version “20231001” and I still have the same issues.

On another computer with Tumbleweed version “20230922” shotcut is working fine.

I suggest to use the flatpak. Otherwise you need to do some debugging using gdb and ldd

I did a rollback to previous btrfs snapshots of my system and found that shotcut has stopped working since 9/28/2023 18:02 - since I installed the updates from 9/26.
So the problem is caused by one of the following updates:

New Tumbleweed snapshot 20230926 released!

This Update changed 1146 files on “/”, e.g. in “/usr/lib64/qt5/plugins/” or “/usr/libexec/kf5”.

The Shotcut flatpak version is working as expected.
But I guess it will eventually fail as well, at the time when the flatpak kde or lib version will be updated to the version which causes this issue.

The shotcut binary is not a dynamic executable, so I guess ldd would not help.
I tried to strace the process, but it looks like shotcut does not even try to open the file at all.

It’d be great if there is a way to get a more detailed log output to point me to the library which causes this issue. I would be able to open a bug against this library.

1 Like

I can confirm this with several AppImage versions under Manjaro.

Im experience the same issue, but i open a new Topic because of your unprecise titel.

Because the Shotcut version from my official Manjaro Reposition is working.

Better rename the folder instead remove it or you don’t use individual settings for your filters and don’t care to lose your settings.

Another appimage that broke on recent Manjaro updates is Audacity 3.3.3
/tmp/.mount_audaciABfngW/bin/audacity: symbol lookup error: /usr/lib/ undefined symbol: pixman_image_set_dither

Cairo is 1.18.0-1

The same 3.3.3 from arch repositories only launches when started from terminal. It won’t start from menu or desktop shortcut. It also won’t open associated files (i.e. wav) from file explorer (Dolphin).

Both Shotcut and Audacity appimages were working fine before recent rolling updates.

I just installed Shotcut portable in a Ubuntu 23.10 virtual machine, and I get this error in the job log when I use Open Other > Count (that part works) and try to Export it as MP4.

I removed from the portable and now it works on Ubuntu 23.10. I need to exclude this lib from the app bundle. Can you try it please?

1 Like

I unpacked the appimage and deleted Shotcut/squashfs-root/usr/bin/lib/
launched via AppRun

Can confirm dragging a .wav from Dolphin now works on Manjaro. Placing the file back breaks it again (a new video track is created on an empty project, but the media does not go onto the track)

Please repack a new appimage without that

I also can confirm that it works under openSUSE Tumbleweed when the library has been removed. :+1:

The AppImage and portable downloads are now fixed as well as the build script for next release. Snap stable channel will be updated to next nightly build as that cannot be modified and only moves forward.


I have tested the latest AppImage from the download-page. It works now fine under openSUSE Tumbleweed.
Thank you!

1 Like

Yeah its working on Manjaro also, thanks alot for your support here :slight_smile:

After all that hassle that i had with that newer versions from shotcut (wobbly/unprecise audio playback from newer versions and now this broken blur filters, almost let me regret to support this project, but atleast i can still use the older but perfect and flawless 22.12.21 (AppImage) version again and im fine with that. i just hope im not running in a dead end anytime but you make it running today again, so many thanks :hugs:

I dont used the packed appimage, but instead the tzar archive that i had unpacket. I don’t know if there is a big difference, but after deleting the recommended file.

Under Manjaro i opene shotcut>new empty project and placed the video file per drag+drop and drag+drop in the application and then the visible video (project) also per drag+drop to the output (tracks) at the bottom… i don’t see a issue or any difference to the function before this adjustments. :man_shrugging: