Shotcut doesnt display more than one video track at a time

I was editing a video, after updating it, and i finished the project. When i go back to test it, only the upper most video track at the moment. I though it was weird, but with my pc being slow, i thought it was similar to how shotcut sometimes didnt display filters properly but once exported they worked.
I hit export, and once its done i check it, and its the same problem. Only one track displays, and the rest is black, no background or anything else.
I downloaded an older version of shutcut, and the same problem. Even opened an older version of that same project and it worked perfectly. And it isnt that I pressed hide track, because all of them are showing, so what is the problem?

Heres a reddit post with a video showing the issue, so any help is appreciated

It would help if you provided a screenshot of the problem. You don’t even show all of the tracks, or what filters are being used. So please do the following:

  1. Make the player height a lot smaller, until you see all the tracks in the Shotcut window.
  2. Position your playhead on a spot where the problem happens.
  3. Select the clip at this point on the top track.
  4. Open the “Filters” panel.
  5. Take a screenshot of the whole Shotcut window.
  6. Post it here.

The thing is, i dont know what the problem is. If you saw the video, you probably saw that it doesnt display all tracks at a time in the video, it only shows the upper most track, and i dont know what happened. It cant be filters, because its with the entire project, and i removed the filters. and not every image/video uses the same filter. But heres a screenshot of all the tracks
This one is all the tracks showing

And this one has the upper most track hidden

Parts of the tracks don’t show when they take more space than the height of the timeline.
Either resize the height of the player in the layout, or resize the height of the tracks.

To resize the height of the tracks, go to the Timeline menu

Or place your mouse cursor in the timeline and use SHIFT + Mouse Wheel to adjust the height of the tracks.

There is a possibility that the blend mode of the tracks has been altered. It should normally be set to “Over”, but it is possible yours have been set to “None”.

  • Click on the track, not the clip but the track - where “V4” is etc.
  • Click on “Properties”.
  • Check the blend mode is set to “Over”.
  • Do this for each video track. (not V1 though)

I select properties but nothing appears, and there isnt a filter. Is it the blend/unblend option in track operations? because that one didnt do anything either. Heres a screenshot

I don’t understand, you should see something like the following:

I’ve never seen this situation before, which makes me think if we can sort this problem out, it will solve your problem. Hopefuly someone like @shotcut or @brian has an idea of why your “Properties” do not show the Blend mode.

The following post highlights a bug that could cause your problem. Do all the tracks have the blend mode missin or just one or two? Also, did you at any time move the tracks up/down?

I created new video tracks, and it seemed to do the trick. Since its half an hour and i used 5 tracks, its gonna take a while to fix it, but at least its fixable. Thank you so much and have a nice day

I’m glad that you managed to rescue your project.

1 Like

I can duplicate the issue.
Clicking on V2 or V3 (the actual track name) then clicking another track header away from the track name causes this action.


The workaround is just simply clicking once more away from the track name. This loads the blend mode option.

This topic was automatically closed after 90 days. New replies are no longer allowed.