ShotCut Crashing while trying to change the Text Font

Hello there!
Hope you all are doing good!

I am Hrishikesh Kelkar.

I am using ShotCut for the previous 8 months and I love it!

But, today there is a bug occurring continuously.
I am currently using Manjaro GNOME Edition.
I used ShotCut on only Ubuntu and PoP!_OS before and it worked like a charm!
Just a few days ago, I switched to Manjaro GNOME.
After the installation of the OS, I installed ShotCut and also tried editing a video and at that time it was all good!
But now, I just opened it for editing a YouTube Video and was working well, but,
When I click on that button which says the current font name which is present in the ‘Text: Simple’ Filter or when I click on that A in the ‘Text: Advanced’ Filter,
ShotCut hangs for 3-5 seconds and just crashes!!!

After trying it 2-3 times, I just went on the web and searched for the issue.
Then I found this topic in this forum itself!: Crash when change the font

It doesn’t have anything. The problem faced by the Author of that Topic is the same one I am facing. But there is no solution!

Please help me solve it or I have to switch my editor.

I am attaching a screenshot with the mouse pointer which indicates the button:

Check where is the mouse pointer to understand it.

Thanks in advance!

Edit: Forgot to mention the version. It is 22.04.25-1. It’s installed using the Official Repository of Manjaro. [Pamac / Pacman]. Also, all the time I used ShotCut before, I used the FlatPak / FlatHub Package. Should I try using the FlatPak one to see if the bug is solved?

From reading many posts here, other Linux repositories have their own versions of Shotcut, which is not supported here.

Have you tried installing Shotcut from here?

1 Like

Can’t reproduce this issue using the flatpak version on Fedora Linux 36.

When using a font dialog or file dialog in a flatpak it using portals to open native dialog in the DE you are running, so you get a Gtk dialog on a gnome system and a KDE one if running KDE etc.

I looks like there is an problem with the portal implementation in your OS, so you should make a bug against Manjaro.

You can try the official appimage version of shotcut to see if it work better on your disttro.

1 Like

It produces the one with the system gtk theme.

I tried using the flatpak and there it worked but the theme was light whereas in my system it’s dark.

And about app image, it crashed one time and then opened the native windows of shotcut.

This topic was automatically closed after 89 days. New replies are no longer allowed.