Crash when change the font

I had use Shotcut for few weeks and it work totally fine before. But today when I trying to change the font, the program just suddenly shut down.
I’m not sure if it’s related, but I found this problem after I installed HitFilm Express today. I had tried delete HitFilm but can’t fix the problem…

There is not enough information here. There are multiple things with fonts. Can you repeat the steps to make it crash? List the steps and be specific.
Also, you must state your operating system and Shotcut version.

My operating system is Window 10 and the Shotcut version is 20.04.12
I was using the Text: simple filter and trying to change the font type, when I click the button the program crash

Thank you for the additional info. Does it crash at the moment you click the button or after you click OK in the font dialog that is supposed to appear?

Also, please try this: choose Open Other > Text > OK. Then, immediately go to Properties and click the font button.

It crash about 3 seconds after I click the button, the font dialog have not appeared.

And “Open Other > Text > OK” is the same result.

Weird, but I am sorry that I am unable to reproduce it and will be unable to fix it. When you click the button, the code immediately requests the library and OS to show the font dialog. The only thing I can suggest is to reinstall and enable the checkbox option to remove all your Shotcut settings from the registry. If all that fails, you can use Text: HTML or make text in a paint program saved as PNG or drawing program saved as SVG.

Thank you for helping.
I had tried to reinstall Shotcut but nothing change. I found something in the log.txt but I don’t know is these related to the problem.

[Debug ] <LeapNetworkListener::onDisconnected > Disconnected from Leap Motion
[Debug ] <LeapNetworkListener::onError > Leap Motion WebSocket error: “Connection refused”
[Debug ] <VideoVectorScopeWidget::profileChanged > 709
[Info ] Failed to open audio device: XAudio2: XAudio2Create() failed at open.
[Info ] [sdl2] Try alternative driver: xaudio2
[Warning] <> file:///C:/Program Files/Shotcut/lib/qml/QtQuick/Controls/ScrollView.qml:359:13: QML Item: Possible anchor loop detected on fill.

It solved, though I have done nothing :joy:
I just turn my computer off and have my dinner, then when I come back and turn it on again, the problem solved with no reason…