Shotcut crashes when I move a video track back and forth

So everytime I try to sync the camera video with the mic audio/voiceover, I pull the video tracks back and forth and Shotcut just crashes!!! For absolute no reason!!! How can this happen??? It’s not even a heavy task to simply drag a track!!! You really need to fix this!!!

Wich SHOTCUT Version do you use???

I have never had a problem like this. You should try the different options under Settings > Display Method:

I am experiencing the same problem. I am using a fresh installation on Windows 7. My video was shot in 1080p 30fps so that is the video mode I chose for the project. I am trying to sync audio that I recorded thru an external mic completely separate from my camera.

I’m afraid I’m not a software developer. While I appreciate the above response from Shotcut tech support, it doesn’t make any sense to me. I don’t see any place in Shotcut’s settings menu that allows me to choose between Mesa 3D and DirectX. The application log does look like I’m using OpenGL. How should I do this stuff?

image

Thanks! I changed the setting to software (Mesa); now the program won’t run at all. When I try to open it, I just get a series of error messages:

First message:
"Failed to create OpenGL context for format QSurfaceFormat(version 2.0, options QFlagsQSurfaceFormat::FormatOption(), depthBufferSize 24, redBufferSize -1, greenBufferSize -1, blueBufferSize -1, alphaBufferSize -1, stencilBufferSize 8, samples -1, swapBehavior QSurfaceFormat::SwapBehavior(DoubleBuffer), swapInterval 1, profile QSurfaceFormat::OpenGLContextProfile(NoProfile)) .
This is most likely caused by not having the necessary graphics drivers installed.

Install a driver providing OpenGL 2.0 or higher, or, if this is not possible, make sure the ANGLE Open GL ES 2.0 emulation libraries (libEGL.dll, libGLESv2.dll and d3dcompiler_*.dll) are available in the application executable’s directory or in a location listed in PATH."
Error1
Click “OK” and it goes to a C++ error.
Click “OK” again and the program crashes.
I can only post 1 image at a time right now; I’ll make another post for the C++ error.
What would you suggest at this point?

Here is the C++ error:
Error2
The other two errors are standard Windows program crash stuff. I can send you a screenshot if it’s helpful.

Thank you for your help, by the way!

Try re-installing the application.
image
Check the remove reg settings. That might help.
If not then Shotcut might not work with your system.

Run the Shotcut installer again and choose the checkbox option to remove all registry settings.

Same problem here moving audio or video with zoom more than 50%.
I’ve tried changing to mesa, and I get a slightly better behavior, but then of few movements I got the same crash.

My version is 20.07.11 in Windows 10 64 bits, Nvidia MX 150.shotcut hangs

I have the same problem, with version 20.07.11 on Ubuntu 20.04 64-bit, with the built-in graphics of an Intel i7-6820HQ, crashes using Mesa just the same as with OpenGL, in particular when doing very small adjustments.

Also reported on Github

I believe I fixed this for the next version 20.09