Shotcut-190816 exporting any sized source to 1920x1080

Hi! I don’t know if this is a bug, a feature or an error by me. I have been using Shotcut to edit many videos and greatly appreciate the program!

Shotcut would always export videos in the resolution of the first video added to a new project.
It’s the first time I’ve been using the latest Shotcut-190816. I am using the Shotcut-190816.glibc2.14-x86_64.AppImage on Linux Mint 18.3 XFCE-64.

After working several hours on a few videos shot with a phone at 720x1280 and finally exporting them it turned out all videos were exported at 1920x1080.

I have been doing a few tests about this. It turned out that every input video file on every new project regardless of the original resolution was exported at 1920x1080 with Shotcut-190816.
Doing the same with Shotcut-190715 produced an output at the same resolution as the input.

What happened? As said it was the first time I used this particular version. I keep versions also as appimage and they worked just as they should be. The preset column of Shotcut-190816 shows nothing indicated as being selected.

I have managed to save my day and my many hours of hard work by editing the saved .mlt files and changing

<profile description="HD 1080p 25 fps" width="1920" height="1080" progressive="1" sample_aspect_num="1" sample_aspect_den="1" display_aspect_num="16" display_aspect_den="9" frame_rate_num="25" frame_rate_den="1" colorspace="709"/>

for

<profile description="automatic" width="720" height="1280" progressive="1" sample_aspect_num="1" sample_aspect_den="1" display_aspect_num="720" display_aspect_den="1280" frame_rate_num="19875600" frame_rate_den="661993" colorspace="709"/>

from a .mlt generated by Shotcut-190715 with the same input.

Hi and welcome!
What is your setting in “Video Mode”?
Every time you begin a new project you have to set the Video Mode in Settings.
If you want a special screen you can add a custom size. In your case 720x1280 and aspect ratio 720:1280.

There is an issue with 19.08.16 that was brought up in this thread.

It’s been fixed for 19.09.

Thanks for the replies. The framerate indeed was also set at 25. I’ll skip 190816 from now on and wait for 19.09