Shotcut 17.01.02 Missing File in transition when reloading mht - /ShotCut/<tractor>

I get an error message when reopening an mht file for a partially edited video: “There are files missing in your project…” with the missing file being identified as "F:/Applications/Video/ShotCut/. This is with the latest version of Shotcut 17.01.02.

The project was created with ShotCut yesterday, and reopened with this error today. Restarting the computer doesn’t help.

Error message

This is what the transitions now look like - just a static image instead of a blending of videos:
[I would show you what it looked like but I can’t upload more than one image… ]

I can upload the mht if you like.


You say that your transitions are messed up after this bug happens? Sounds related to an old bug report here I remember. However in that report we could only reproduce the issue when the missing file was named. Someone had mentioned that the same thing had happened to them when the missing file was not named, but we could not reproduce that. There might be a lingering issue that was not resolved back then, which is still in the newest version.

But to my knowledge I cannot reproduce. Could you look on that page I told you about and see if there is any related information, and then tell what you find here?

Edit: There were also recently people talking about errors when you load from a drive other than C, but that was supposed to have been fixed for 17.01.02. There might be something unresolved there as well, but just in case, did you download an official version of Shotcut from the homepage? Somewhere else which is unofficial might not have been updated or it could be a bad version.

Actually that was my report, but you are mistaken, it’s 17.01.02 where the bug first appeared.

I downloaded the previous version from the ShotCut homepage, and it updated itself to the current 17.01.02 version.

Thanks for the link. I’d seen that post when I searched the forum, but since that issue appeared to be closed I thought I’d start a new post. Additionally, my situation is slightly different in that pressing ‘OK’ on the missing file dialogue box, while opening the project, does show an error on the transitions.

Here’s what it looks like in the ShotCut preview as well as in the video when exported:

I don’t know enough about the MHT files to know just what I’m looking at, but the one that gives this error does have differences to one’s that don’t show the error (I haven’t tried saving over them, as they are fine for now).

If someone was able to have a look at the MHT I’m having the problem with it may be possible, as a fix for my situation, to manually make changes to the file’s xml? I don’t know that, of course, but the thought crossed my mind.

I install my programs on a separate drive, F:, as my C: drive is a smallish SSD with just enough room for Windows and whatever other programs don’t give an option to choose the installation drive & directory.

Yes, it was supposed to be fixed but maybe there were some loose ends when the newer versions came out. :confused:
I don’t think it’s something that could be resolved with just some xml edits, but may I see the .mlt file anyways? It would help to create steps for reproducing the error on my end.

Thanks. Here’s the mht file. I hope you can see something that’ll help.

FYI, I was cutting down a gaming video to just highlights - I split the clip into several pieces, deleted some pieces and used a drag & drop fade of 1 second overlap between clips. The fades at the beginning and end are 2 seconds overlap.

Let me know if there’s anything else I can do to help pin it down.


2 - Battlefield 4 - All Kills and All Deaths Operation Firestorm, 2014.mlt (65.1 KB)

ps. just realised ive been referring to an ‘mht’ file. I don’t know where I got that. sorry for the error!

Hi again. Just in case it might help, here’s an MLT file that works fine when I open it, no errors and working transitions created in the same way as the one that gives the error.

new year’s eve war pigeons.mlt (14.0 KB)

Ah, sorry the media needs to be included as like a .zip or something in order to open… I’m sorry I should have mentioned that…

Hi. sorry, I won’t be able to do that - it was a whole evening’s worth of gaming, and the video file is more than 2GB. On my internet speeds I can’t manage to upload that.

Let me know if there’s anything else I can do, short of sending you the media…


I hate to be a “me, too”, but I noticed this right after upgrading to 17.01.02 from 16.12.03. It happened to a few of my transitions, but not all of them. Fixing them by hand seems to work, but I haven’t finished fixing them all. I still get the missing “tractor” file even though I’ve saved it in 17.01.02. I assume that’s because I still have broken transitions left.

I see the multiple rectangles during those transitions also. Sorry, I don’t have anymore details. I’m a developer, too. So, I know how frustrating that is. The source files are all MP4’s if that helps. Thanks!

This is a known bug in v17.01 that is already fixed for the next release - similar to a lot of other problem reports in the forum this month all related to broken file paths on Windows.

Thanks for the update. I’ll look out for the next release.

Great! Thanks, Dan! I’ll keep an eye out for the new release.

Just a quick update. Once I fixed the transitions, the error went away. It’s working fine now.

Hi Phragmites. It is doing the same thing to me! Could you tell me how did you sort the issue?

Hi Elena. In the end I had to abandon my project and start again. I’ve not had the problem again since updating shotcut, but I also no longer save projects - I just finish them in one go so that the problem, if it does still exist, won’t affect me.


Hey, how were you able to fix transitions? I can’t even open my file…