Settings of crop filter (partially) disappear


#1

So the settings of the crop filter are reset or disappear while editing.

The bug I’m experiencing is quite similar to this one:

Except that it doesn’t always happen and that not all the crop settings are always reset. I’ve tried to identify patterns as to when this does and doesn’t occur and it seems that:

  • settings generally do not disappear when I play the clip with the filter applied before selecting another
  • splitting the clip sometimes causes loss of crop settings
  • changing the speed of a clip sometimes causes loss of crop settings
  • dragging and dropping clips from one position on the timeline to another sometimes causes the problem
  • After saving as mlt, closing Shotcut and opening the file again, selecting any clip seems to reset (part of) the crop settings. It happens this way: I click on some time on the timeline, play a bit and crop works perfectly. I then select the clip beneath that time and crop settings are reset.
  • Generally all crop settings are lost at the moments above, but on some occasions only some of the crop settings are lost. In most cases, I still have a right and left crop, but above and below have disappeared. Still having the crop settings for top and bottom and not for right and left has also happened, but seems less often the case.

I’m editing .mts-files @ 1920x1080, but I’ve reproduced the problem with mp4-files in a new project as well.

I’m currently using version 16.10.01, x64 on Windows 8.1, but I’ve noticed this bug in earlier versions (few months old, can’t exactly remember version).

I cannot reproduce this bug on my Windows 10 tablet (version 16.08.12 x64).


#2

I’m happy to see I’m not the only one encountering this issue! It’s been driving me crazy, LOL.

So I can confirm all of the above observations. I can also add a bit more…

I thought I could work around this issue by saving my crop settings, since shotcut lets you do that. So I clicked on the + button, typed in a name for my preset, but… as soon as I hit OK, bam! all my settings were gone again.

Furthermore, when I click on the preset I just saved, it comes up with the one setting that did remain, everything else is blank.

So I figured OK, that’s annoying, but maybe I can go manually edit my presets if it’s stored in a text file. So I did some digging and found the text file, yay!

So I open my crop preset file and… surprise! All the settings are in there???

How baffling is that?

So it seems like the settings get saved OK but are just not read properly by shotcut for whatever reason. Or rather, specific actions (like selecting the clip or hitting the OK button to save the presets) will make it stop reading the settings properly.

Also, I should point out that I run shotcut on a linux box (Fedora/KDE), so it’s not just the Windows version that is misbehaving. Though I can confirm that the issue also exists under Windows 7 (as I also tested this on my laptop).

And BTW, I’m running version 18.01.02 on both machines.