Segmentation fault bin/shotcut "$@"


#1

Trying to install on Puppy xenial 64 getting this error on running
[Debug ] ShotcutSettings::log audio channels 2
/initrd/mnt/tmpfs/tmp/.mount_ShotcuI1a6mq/usr/bin//shotcut: line 17: 26563 Segmentation fault bin/shotcut “$@”
root#

Can anyone tell me what it needs please?


#2

This is probably the same problem as

Please try the nightly build, which includes the fix mentioned. It is portable tar format instead of AppImage, but it’s basically the same. You extract it and launch either the shotcut.desktop file or Shotcut.app/shotcut (not Shotcut.app/bin/shotcut).


#3

The link you provided goes here…
56%20PM


#4

image

You need to Log in as guest to get the nightly build.


#5

Aha, thank you.


#6

New beta has AppImage:
https://forum.shotcut.org/t/v19-01-beta-now-available/9240/2


#7

root# ./shotcut
[Info ] Application::Application Starting Shotcut version 19.01.27
[Info ] Application::Application Linux version
[Info ] Application::Application number of logical cores = 2
[Info ] Application::Application locale = QLocale(English, Latin, UnitedStates)
[Info ] Application::Application install dir = “/initrd/mnt/dev_save/TempSave/Software/Shotcut/Shotcut.app/bin”
[Info ] Application::Application device pixel ratio = 1
[Debug ] ShotcutSettings::log language “en_US”
[Debug ] ShotcutSettings::log deinterlacer “onefield”
[Debug ] ShotcutSettings::log external monitor “”
[Debug ] ShotcutSettings::log GPU processing false
[Debug ] ShotcutSettings::log interpolation “nearest”
[Debug ] ShotcutSettings::log video mode “”
[Debug ] ShotcutSettings::log realtime true
[Debug ] ShotcutSettings::log audio channels 2
./shotcut: line 20: 14212 Segmentation fault bin/shotcut “$@”
root# ./shotcut
[Info ] Application::Application Starting Shotcut version 19.01.27
[Info ] Application::Application Linux version
[Info ] Application::Application number of logical cores = 2
[Info ] Application::Application locale = QLocale(English, Latin, UnitedStates)
[Info ] Application::Application install dir = “/initrd/mnt/dev_save/TempSave/Software/Shotcut/Shotcut.app/bin”
[Info ] Application::Application device pixel ratio = 1
[Debug ] ShotcutSettings::log language “en_US”
[Debug ] ShotcutSettings::log deinterlacer “onefield”
[Debug ] ShotcutSettings::log external monitor “”
[Debug ] ShotcutSettings::log GPU processing false
[Debug ] ShotcutSettings::log interpolation “nearest”
[Debug ] ShotcutSettings::log video mode “”
[Debug ] ShotcutSettings::log realtime true
[Debug ] ShotcutSettings::log audio channels 2
./shotcut: line 20: 21952 Segmentation fault bin/shotcut “$@”
root#


#8

Shotcut is incompatible with your system. It could be an OpenGL problem or simply incompatible with Puppy (even though “xenial” makes it sound based on Ubuntu Xenial, which should work as that is what Shotcut binary is built on). Paste the output of glxinfo | grep OpenGL please.


#9

Thanks for the reply . I would really like to get this running.

root# glxinfo | grep OpenGL
OpenGL vendor string: Intel Open Source Technology Center
OpenGL renderer string: Mesa DRI Intel® 965Q
OpenGL version string: 2.1 Mesa 17.0.7
OpenGL shading language version string: 1.20
OpenGL extensions:
OpenGL ES profile version string: OpenGL ES 2.0 Mesa 17.0.7
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 1.0.16
OpenGL ES profile extensions:
root#