Running jobs sequentially


#1

How can I run jobs in a sequential order?

I may spend an hour editing several videos, but it would take more than a few hours rendering all of them. At least it would be great to stack the jobs and have them one right after another while I’m away from the computer.

Thanks.
obs jobs


#2

This is one way to do what you want.

Go to File Open MLT XML as Clip.
image

Once the mlt is loaded it will be in the source player. Add it to the playlist. Do this for each video you want to export. You can save the mlt as Jobs. That way it can be used again.

Export all the videos in the playlist using the export From Each Playlist item function. All the videos in the playlist will export and be numbered sequentially. The export format will be the same for all the videos.

image

If you export from playlist all the videos in the playlist will be concatenated.


#3

I will definitely be using this. Thank you.


#4

I guess I need to figure out how to add items to the playlist. I’ve tried this numerous times. I must be missing something really simple. I get this error each time I try.

Shotcut Can't add to playlist


#5

Start with a blank playlist and use File open MLT XML as Clip.

Drag and dropping an mlt on the playlist won’t work. It will open the mlt for editing. The mlt you are using might be corrupted. Try to open it as you normally would and Save As to a different file to see if that is the issue.


#6

I may be having issues with Shotcut, or the Qt program. I’ll try plugging away at throughout the week. I just tried exactly the way you have it. It even does other saved mlt files the same way, always crashes the program. I do appreciate the help. I did re-save the mlt file to another name, still crashes.

It’s not a big deal, just would be a time saver.


#7

I can load an MP4 into the playlist, but it will not load an MLT file. I’ve tried and tried. Maybe it will work with a newer version. This version just crashes the program immediately after I push the plus button to add the MLT file from the source. I do selected MTL XML as Clip.


#8

It works fine with Version 18.01.02. The entire procedure I described for loading MLT’s to do sequential exports works perfectly.

I tried it before I posted.


#9

@sauron, I do believe you. I’m just scratching my head as to why I can’t get it to work on my end. The only thing I can think is something like one of the Microsoft Visual C++ distros might be corrupted or need updating.

I made a video showing you what happens (latest version): https://youtu.be/JUUYZu3d9GM


#10

Just watched the video. That is strange. Maybe one of the developers might step in and shed light on what’s happening.


#11

@sauron, Thank you so much for your help. I wonder if I should start another thread instead of continuing here.

The funny part is that I tried that so many times thinking one time it might not crash, ha ha.


#12

You could try reinstalling the latest Shotcut from scratch to see if that will work.
I posted to this thread about how I solved my Shotcut problem.

Or message one of the developers. Brian is usually pretty good at helping to solve issues.


#13

Yes, I already did that. After deleting the original shotcut folder, I uninstalled shotcut from the other folder, then reinstalled and everything installed properly, I think.


#14

I’m assuming you have the latest version 18.01.02. and it’s the only one on your system.
The only thing I can think of is to run sfc /scannow from an administrator command prompt to see if there are any corrupt files that can be fixed.


#15

I would recommend that. There are some debugging steps we could try. It would be best for future readers to keep this thread clean.