Removing audio track removes video above it

What is your operating system? Windows 10

What is your Shotcut version (see Help > About Shotcut)? Is it 32-bit?
21.10.31 How do I tell how many bits

Can you repeat the problem? If so, what are the steps?

I import some video from a wedding in the first video track. Then add an audio track below it. After listening to the audio track I highlight it, split the track and ‘remove’ the first piece - the video above it gets removed as well. I tried removing the entire audio track and all the video got removed as well. I eventually had to slide my video a few minutes to the right to line up with where the audio starts, process the video, import it again then cut the beginning shorter as a workaround.

You have probably enabled ripple and forgotten. Make sure Ripple All Tracks is turned off.

Would that only remove the clip above the audio? Because it’s only the clip directly above the audio that deletes, nothing higher up.

“Ripple all tracks” would affect all tracks. Did you check that it is not enabled?

I do not recreate this in my simple test case:

  1. Start with empty project
  2. Add Video track V1
  3. Add Audio track A1
  4. Open video clip and add to V1 starting at 00:00:00
  5. Open audio clip and add to A1 starting at 00:00:00
  6. select audio clip
  7. Move curser to 00:00:05
  8. Click the split-at-playhead button (or press “s”)
  9. Select the first audio clip (from 00:00:00 to 00:00:05)
  10. Right click on the clip and select Remove (or press “x”)

I observe that the second half of the audio clip shifts to 00:00:00 and the video clip is unchanged

This topic was automatically closed after 89 days. New replies are no longer allowed.