Relative File Paths Not Working


#1

Closed Suggestion Thread

I have projects completely contained within individual folders as described in the above suggestion thread. All asset files are included in the folder. If the project folder is moved to a new location and the MLT file opened with shotcut the asset files are not found and the following error dialog is displayed.

Shotcut_Missing_Files_Error

I noticed in the MLT project file there is an absolute path to the project directory. It seems that this path is being used to open the asset files rather than the project files current location.

X Minus One 56-01-04 (032) The Roads Must Roll.mlt (11.3 KB)

Perhaps I am doing something wrong? Can you provide some clarity?

[edit]
If I lick OK in the above dialog the files are auto located. Also I am no longer able to reproduce the behavior, after struggling with it for many months. Making this form post must have fixed it. :wink:


#2

There is a bug report for this that is being worked on for the next release:


#3

OK. Thanks. Sorry I didn’t find the bug report before posting.