Program Crashes


#1

Hello,
Shotcut V.18.09.16 crashed several times.

  1. Tryed to drag and drop 6 small video clips (together) into the playlist, and program crashed. Draged 4 video clips to the playlist - OK.
  2. After editing some clip on the timeline, removed parts of the clip - OK, but when selected to remove the transition parts, program crashed. This happened once when selected the transition and right-clicked to remove, and again when used the ^ icon (arrow upward).
    What is / was wrong ?
    Answers will be appreciated.
    Thanks
    Motim

#2

I have not been able to reproduce these. Do you have Ripple All Tracks on in the Timeline menu and the Ripple button enabled? They are likely bugs, but I can only fix them if I reproduce them.


#3

Hello and thanks for answering.
I’m sorry, dont know what “Ripple” is.However, on the time line there was every time only one video to edit, and there was only one track.
In the playlist were several videos, imported two at a time.
And by the way, what is that “Ripple” you mentioned, and what for is it.
Answers will be appreciated.
Thanks
Motim


#4

This was fixed for next version 18.10:


#5

Have to admit that Shotcut crashes when I try to export.
Using v18.09.16 - Shotcut-180916.glibc2.14-x86_64.AppImage. Used simple cutting and audio, video fade-in and -out effects in the beginning and ending of cutted clips (removing advertising). That’s all. Video was ca 2h 37m long. Input files were .mkv with size ~2,6 GB 3,8 MB. Files are recorded using Simple Screen Recorder v0.3.11 - cannot put links here as your forum environment prevents that for new users (2 links per post allowed).
For OS I used 64-bit Linux Mint 19 and Lubuntu 18.04.1 LTS (with all updates). Noticed that multithreading worked well - all processor cores were used ca 80%, I had 8 cores (Intel i5 and i7 CPU’s), one machine had 16 GB RAM, another 64 GB. Using EXT4 filesystem, tried SATA3, SSD disks.
Tried to export: .mp4 (default settings) .mkv (Matroska) with default settings, also Ogg Vorbis for audio.
It will export 300…400 MB and then I discover that program is just closed.
In what there might be the issue? Is the AppImage version bad? Shall I use portable version? Tested that portable - same issue (did not help). Would say that packaging is probably not the issue.
I am pretty sad as the program promised to be good one… Especially when to look videotutorials from Shotcut homepage.


#6

We do not know how to reproduce the problem you are experiencing. You can try turning off Parallel Processing in Export to see if that helps.


#7

Added some information - you can use same Simple Screen Recorder v0.3.11 to create .mkv files using H.264 (superfast, constant rate factor: 23, allowed frame skipping) for video and Ogg Vorbis (128 kbps; not shown but comes with 48 kHz sampling rate) for audio as the program offers by default. Used 1174x662 for recorded area size, aspect ratio became 16:9
homepage http://www.maartenbaert.be/simplescreenrecorder/
GitHub repo https://github.com/MaartenBaert/ssr
One file was exactly 2825180088 bytes (~2,6 GiB; 3h 24m 54s and it should be ca 2h 37m if cut advertisings off) and another 3946353 bytes (~3,8 MiB; 22 seconds). The shorter one was inserted into larger one in random place (ca 10 minutes before large video end) and the big video was splitted from 7 different places, length between splits around 20 minutes (sometimes little more, sometimes less). Adding shorter file as new clip added 2 more splits - so 9 splits all together. Shorter file was in turn cut into ~5 second clip. Used audio and video fading off and on in the end and beginning of cutted clips.
Cutting, adding effects, etc worked like a charm but final rendering crashes… Noticed that .mkv rendering said to take ca 9…10 hours but .mp4 rendering ca 12 hours in my machines I described above. When taking parallel computing off then I guess it might take days to complete… Used default 60% quality and other settings for video that Shotcut offered.


#8

Here I provide also my project file (sensitive names are changed).
There is a main-video.mkv (~2,6 GiB; 3h 24m 54s) and small-video.mkv (~3,8 MiB; 22 seconds) that describe these files I used.

project.mlt (20.4 KB)


#9

I tested your project file today with my own media created with simpleScreenRecorder. I used same parameters as much as possible, but you did not indicate fps. I used 15. I did not reproduce the export crash. I used the export defaults, and it only took 1 hour 8 minutes to render on my 9 year old computer (very little screen activity).

Maybe there is a problem handing video files created by simpleScreenRecorder because I notice some strange things with frame rate reported by tools. In Shotcut, the file appears as 1000 fps. mediainfo shows:

Frame rate mode                          : Constant
Frame rate                               : 15.000 FPS

ffprobe, which is using the same libs as Shotcut, however, reports:

Stream #0:0: Video: h264 (High), yuv420p(tv, bt709, progressive), 1174x662 [SAR 1:1 DAR 587:331], 1k fps, 30 tbr, 1k tbn, 30 tbc (default)

I usually see 1000 fps with variable frame rate footage. Variable frame rate does not work good in Shotcut or any multitrack editor that I know of. Also, tbr, tbn, and tbc are also framerate-related fields; and they are showing some strange values. tbr typically matches fps, and frequently tbc is double fps.

There is very little in your project that can take advantage of parallel processing as there is no scaling, only a little fade filters, and that option does not affect encoding threading.
With Parallel processing turned off, my export test using defaults took 1 hour 23 minutes.


#10

Well, frame rate was 30 as offered by default in SSR. Using mpv and SHIFT+I shows also 1000 FPS (specified) but 31.714 as estimated. In SimpleScreenRecorder (SSR) I used 30 as default value. I even considered to use SSR again after cutting and preparing the video and then just play in Shotcut and record with SSR again the screen. I know this sounds silly but what to do… If Shotcut cannot handle SSR recorded videos. But certainly you know better what might be wrong and probably the SSR author knows what could be wrong. Have to admit that I am not a programmer nor video editing expert. Remembering that once I tried Lives http://lives-video.com while needed to convert security camera video from weird format (I guess .sff or something) and Lives was only one that could do that in Linux environment. Probably there are some tips&tricks to achieve that - as Lives is also FLOSS then perhaps it might be worth to look into it - just guessing.
P.S. could not share more links as the current forum did not allow this :frowning: