Problems with transitions and GPU processing on Shotcut 18.03.06

I noticed wrong transition rendering with GPU enabled (with Linux and Windows versions): I never use games, and my 7-years old GeForce GTX 570 was still sufficient for me. But I fear it lacks some features Shotcut now uses.

I tried to open the projects with GPU processing disabled, but this is not possible: Shotcut seems to use different scripts, (and in some cases GPU filters seem to provide better results indeed).

  • Is it a temporary Shotcut issue which can be fixed, or is my GTX 570 definitely outdated?

  • Is there a way to modify the existing .mlt XML files to use the GPU-free processes instead?

This thread will help you modify the MLT files to remove/replace GPU processing.

1 Like

GPU processing is an experimental feature for people who like to play with technology. Use it if you like to tinker with GPU features. DO NOT USE IT for an important project unless you are willing to restart the project if something goes wrong.

1 Like

Thank you very much, sauron!
I don’t know how my Shotcut was switched to GPU processing. Maybe I had a try once, then I forgot to uncheck it.
I already noticed the filters change: my color sampling and crop presets had “disappeared”, and I had to copy them to a new “movit.” folder.
I tried to fix the XML file of a small clip according to your advice, but all filter names are not “translated” in the post by “TheCorrector”, and I probably did something wrong: an FFV1 title clip with transparent background which is still transparent on a new GPU-free project obstinately keeps a black background, even if I remove the clip and put it back.
PS: I was able to fix this at last: I removed the clip and the track with the overlaid moving title, saved, re-opened and brought back the title.

I did it by mistake, but I learned something: I had 720p video clips taken in 2011 at an anniversary with a little photo camera, with an incredible yellow cast. Everything was yellow as if the room was lit by sodium lamps. With the GPU enabled, I got faint but balanced colors with only a color balance filter applied to the whole track.
Without GPU, I got more artefacts, especially pink haloes in the light of candles. I did a first GPU version without transitions, saved it in lossless FFV1 then added the transitions with GPU disabled.