Please test the BETA for version 21.10

Just Ctrl+Alt+M doesn’t work for me. No marker get’s deleted.

Doesn’t seem to have any way to change keyboard shortcuts in my version of GeForce Experience :confused:

If there are 2 markers, it deletes the wrong one.

And now it works one of them. Apparently the order of markers makes a difference.

In one program I use there is a shortcut for Alt+Z, and there is some weird shortcut for GeForce Experience. I have to manually shutdown Shadowplay in Task Manager every single time I reboot. It’s the only way I can use the the Alt+Z shortcut. I know it’s not Shotcut related, but just one more thing that’s GeForce’s bad Experience.

…at the same frame. The current behavior where you cannot control or know which will be deleted is by design. If you really must have two markers at the same start time you must have moved one to the start time. Likewise, you might need to move overlapping markers to delete or edit the one you want. Or, delete one and edit the other if needed. Whatever works for you.

Read the link I provided. It has instructions.

I saw that and I tried. But it didn’t work. I was on my old computer and it doesn’t have these options in the GeForce Experience settings.

I found out latter that on my other computer, Ctrl+Alt+M works.

There are some different pieces of GeForce Experience. This is the piece that provides screen recording that shows a screen overlay when you press a certain shortcut by default Alt+Z. Maybe yours is older and does not have that or the shortcut is different.

I changed the keyboard shortcut for delete marker to Ctrl+Shift+M for the release.

1 Like

Can @shotcut or @brian address in this release that certain characters like £ and ° can’t be written into a marker’s text? Once entered in the dialog, the bubble help shows a string of ?s.

I’m pretty sure this is insignificant for primarily English speakers, but pretty critical for a bunch of other people. I’m trying to input stuff like Korean, Chinese, and Arabic characters, but none of them show up in the bubble help.

OK. I understand what you are saying. When dragging the whole marker (without CTL), then you can grab the marker anywhere. But when you want to drag half of it to make a range (using CTL), you have to grab only the left half to drag left, or only the right half to drag right. So the clicking target is half the size. I have not had a problem with this myself. I’m not inclined to change it unless is is really a big problem for many people.

Done. I removed the label.

Probably. But snap to what?

I’m hoping that fixes all the funny things people were seeing.

Yes. This is fixed now. Thanks for the report.

Hey, Dan, Everyone!

I have been testing the Marker tool in particular. I’m working on my second or third video using this BETA TEST and frankly it’s a gift from the Gods. So thankyou very much.

Fit TImeline (0) to navigate to all Markers in a project is brilliant. May I suggest a hotkey or two to go to Previous (Shift+Up) and Next (Shift+Down) markers? It makes sense to me because I edit quickly with the hotkeys and this would make a wonderful addition.

I like to revisit the Markers on the timeline to remove them once I’m done with them and how easier is it than using hotkeys and furthermore without changing the width of the timeline?

Once again, Dan, team, thank you very much.

Best wishes

Stephen Esseenyne


Sure but it is still inconsistent with how wide the range is because when using Ctrl you can’t grab it too low or to high otherwise nothing happens whereas when just wanting to move it around all you have to make sure is that the tool tip for that marker is up and you can grab it wherever.

To the playhead. Markers mark a single frame on the exact point it’s placed on so where it’s moved to is extremely important. Wanting to place it on an exact frame is going to be the aim pretty much every time a single frame marker or a range marker is moved and in that case the user almost for sure has the playhead set exactly to where they want it to be so that the marker can snap to the playhead.

By the way, in regards to adding the duration counter of the marker range, you added it to the tool tip which is nice. Can it also be added to the Marker Edit menu? It’d be very useful when the user is changing the range from the Edit menu a duration counter is underneath that updates as the change is being done.

I’ve made more notes after more testing:

12 - A Cancel option should be added for the right click Marker menu underneath Edit and Delete.

13 - If you set an end that goes past the duration of the timeline this happens:

I don’t know if that’s the intention.

14 - If you have markers set on the timeline:

and delete all tracks the markers still remain:

I don’t know if that’s the intention or not either.

Copy and paste of multiple clips from audio tracks into video tracks crashes Shotcut.
Cut and paste also crashes Shotcut.

Sometimes these operations don’t crash Shotcut, but instead one video and one audio tracks are added on top of existing video tracks.

It appears that whether Shotcut crashes is dependent on how tracks are added or inserted.

For pattern 1, I added audio track 1 fist, audio track 2 second, video track 1 third, video track 2 fourth, and then drag-and-dropped noise and colors.

For pattern 2, I drag-dropped noise into the timeline, added video track 2, drag-dropped noise onto that video track, added two audio tracks, moved both noise, and drag-dropped two colors.

I have not had a problem either.

Thanks for the report. FYI, Copy/Cut is supposed to remember what kind of track the clips came from. Paste always operates top-down from the current track. But, of course, we do not interleave audio and video tracks. So, I need to decide a behavior here. I think it will be that when pasting from audio track to a video, the “current track” virtually moves to A1, and all audio clips are pasted relative to that.

If I understand it correctly, there is going to be invisible wall between video and audio tracks when using Cut/Copy and Paste/Overwrite/Append to move multiple clips across them.

That’s kind of how it works now when I do something like this:

This is not the behavior of moving multiple clips with drag-and-drop instead of Cut and Overwrite. They can just easily move across the video/audio track boundary. There is going to be some UI inconsistency there.

Then again, this might give users an option as to what they want to do crossing video/audio tracks.
I can’t add much to your decision making on this one.

Yes, I thought about this too. It seems you have the correct understanding of what I wrote. What I am thinking now is that when there is a target track available, it simply pastes into the existing track whatever track type it is. And when there are not enough tracks, it will use the track type from the clipboard to determine which track type to add to the bottom.

Seems like a reasonable request. But not important enough to risk adding a bug in this release. Let’s start a marker suggestion thread to be considered after the release.

I do not experience this in Windows or Linux. I do not hear other people report this. Maybe you can provide a screen capture?

Seems reasonable. Maybe we should start a suggestion thread to accumulate marker improvement ideas for the next release.



I fixed this in the edit dialog by adding range limits. It can still be done by dragging a marker too far right. I won’t be fixing that for this release due to regression risk.

I will have to think about how to handle that. But I do not want to try to fix it for this release due to regression risk.

I agree it is not a big deal, and it might even be a feature to some. For example, someone may shorten the timeline temporarily and then want to place something using this out-of-range marker via drag-n-drop.

This is fixed for the release by implementing this:

If you it to be a feature, do know then that it’s buggy. Here I set another instance of markers on a timeline:

and when all tracks are deleted:

notice that the markers shifted position.

Also, if you try to move any of those markers while they are set without any tracks they all snap to the left:

so if you try to put back clips on the timeline then all the markers are on the left making them useless:

With that in mind, maybe it should be that when all tracks are deleted while markers are in place then the interaction with the markers be limited to just being to delete them. That means almost entirely locking them with no way to move them or modifying a range until tracks are put back.

Snapping would have to be extended to the markers and make the snapping respond to the clips also in order for this to make sense. Otherwise the user won’t always be able to place the clip exactly where the markers are.

By the way, you added those help boxes in the filter parameters for Mask: Simple Shape, Mask: From File and Text: Rich. How about then taking the notes that you have pop up under the player for certain filters in those blue boxes like this:

and change them to be help boxes like the ones for Mask: Simple/From File and Text: Rich? That way no user can ever miss these very important instructions of use. The filters are Size, Position & Rotate, Text: Simple, Spot Remover, Crop: Rectangle and Timer.