Not responding and lagging

Constantly stops responding. I’d click one thing and it stops and says not responding.

Software bugs (unintentional coding errors/flaws) generally affect everyone equally. Clearly what you experience isn’t, therefore you must suspect something is amiss with your PC.
Scan your PC for Malware would be the first step. Also have your HDD and RAM checked.

I don’t have any malware. What do you mean by check HDD and RAM. I have 8 GB with 7.88 GB usable. Then for my HDD it says 317 GB free of 317 GB.

For errors.

As I say, it’s not normal for the application to stop responding. For example, it’s never happened during my use, and I use it a lot. So it’s not a bug with the program, it’s an issue with your PC, possibly hardware errors, malware or bad drivers.
One other thing to try is to disable GPU Processing if you previously enabled it and set Display method to OpenGL.

I already had GPU Processing disabled, I set the display method to OpenGL and it still stopped responding. Hows the best way to check HDD and RAM?

Assuming you are using Windows 8/8.1/10

Open an elevated command prompt and type: chkdsk /f You will need to restart for the check to take place on next boot.
When done, open an elevated command prompt and type: sfc /scannow

In the Run box (WinKey+R) type: mdsched

I checked the RAM and it was fine, I couldn’t get the HDD scan to work but I’m assuming it’s fine too. What else can I do? I tried it again and it was lagging then it stopped responding.

I fixed it by deleting it and downloading another video editer :slight_smile:

I am having the same issues.

Shotcut’s UI and video preview technology depends on a cross-platform technology called OpenGL, which does not work well on some systems. Sometimes, on Windows, using Settings > Display Method > DirectX (ANGLE) helps. ANGLE is an OpenGL to DirectX translation library developed for the Chrome browser to make WebGL to function on more Windows systems.

I’m having this same problem. How to I go about optimizing my Windows 7 system to fix the constant “Not Responding”

Please provide more, and exact, details so we can try to help you:

I’m having this same issue, and it’s really annoying me to see all of the “it’s your system” answers — as it clearly does not apply. I LITERALLY had Shotcut open and working fine. I finished a short video, closed the project file, and began another. Immediately, my entire system turned grayish and Shotcut said “not responding.” It never recovered, so I killed it, rebooted my computer, and tried again. It let me move files into my playlist, but the moment I tried to move one of them to the timeline, gray/not responding. Shotcut has never worked again. Simply clicking on the “File” menu would crash it. Opening the previous file would crash it. Sometimes just opening the program would crash it (each time I had to restart, sometimes even Ctrl/Alt/Del wouldn’t work and I’d have to hard boot).

I uninstalled Shotcut. I did every system check listed in the forums. I went back to the version listed as most stable. Same thing.

What could possibly have changed between finishing one file and starting another? I did nothing to my system in those few seconds.

I would take @GordC’s advice.

You should only have one instance of Shotcut running in Task Manager.

Version 18.08.14 is a major bug fix for Shotcut.

@Hudson555x I just thought the same… it could be that multiple instances of Shotcut are running.
I reported this here:
Shotcut is not closing process

Nope. I have tried it on another computer, and it goes into “not responding” mode, then shuts down. It has become unusable on all computers in the house — I have literally tried it on three different systems now.

@Hudson555x You must have missed the “rebooted” part.

Yes I did see where you crtl alt del and hard booted. I was interested on knowing if you ever opened up task manager to see how many Shotcut instances were running.

Perhaps there are other apps taking up CPU and memory. Task Manager shows this.

@StormKatt We do not know because we do not experience this problem especially using version 18.08.14 or the older 18.03.06. Please try to narrow down the source of the problem and share the info if you can. When you move between systems, what is the same? For example, the media files or project? Is it particular media format or project? Does deleting db.sqlite3 while Shotcut is not running help (use Settings > App Data Directory > Show… to get to the db)?