No sound when scrolling with arrow keys

Suddenly Shotcut does not play any sound when I move the playhead using the arrow keys. This is an issue that was never a problem before, so it’s strange that it would just appear out nowhere.

I’m running Windows 10 (64x) and have scanned/updated all drivers. I went so far as to do a clean install of Windows 10 but the problem persists. Any ideas?

Edit: Tracks are not muted, no filters, audio scopes show positive levels. Just no sound while editing at all.

Is Settings>Scrub audio enabled??

It is, but still no dice. If I hold the arrow key(s) down for ~2 seconds, it will play back the audio as it should. But no sound when moving the playhead just a step or two at a time

Which version?
Doesn’t help, but it’s working fine here.

Latest version. I thought it might be a bug from the most recent Windows 10 update, but still not sure.

I’ve the most recent W10 Pro update 1803 (April Creators) and it’s fine here, but I’m not using the most recent Shotcut version due to the many other bugs introduced with keyframes, so if you don’t need keyframes at the moment, downgrade to the previous version and see how that goes.

Silly question: where can I download an older version? All I can see on the Shotcut download page is the most recent.

FWIW, I did a complete OS reinstall hoping that would remedy the problem but it did not. Total bummer and waste of a day.

Here.

This was already discussed here:

It is a minor regression. If you enable one or more of the audio scopes (in View menu), then it will help to visually see instead of hearing.

Unfortunately, watching the audio scope and hearing it are two totally different things. Its actually shocking that would even be suggested as a solution lol

I downgraded shortcut and will just have to wait for a fix in a future version that not only works properly but also supports keyframes

1 Like

I fixed this for the next release v18.07 in July.

2 Likes

Is the fix in the current update? Didn’t see it listed in the notes, so I just wanted to clarify :slight_smile:

Yes.

But on the other hand it works for me in 18.03 and 18.06 as well.

Yes, but generally fixes are not mentioned much in the release blog posts. You need to see the git log of several projects to see all fixes.

If this was fixed way back in version 18, it appears to be broken again in the latest version of Shotcut. I have version 19.07.15 installed on my machine, and scrub audio enabled. However, scrub audio is not working using the arrow buttons or by dragging the play head slowly across a clip. I have exited and restarted Shotcut several times and rebooted the machine, both to no avail. Is there anything else I might try?

That is bizarre since I am currently working with an audio track and scrubbing works with the arrow keys. And I use version 19.07.15 as well.
Could you try the portable version? Perhaps your installed version has some issues.

Audio scrub is not reliable depending on the audio format and its encoding parameters. If you convert the clip using Properties > menu > Convert to Edit-friendly… then it is reliable.

This post was flagged by the community and is temporarily hidden.