No audio within shotcut at all

I’ve reinstalled the program several times to try and sort this issue but it hasn’t seemed to work. I have done everything I could have thought of and it still doesn’t output any audio. Is there any way to sort this out?

With no information provided…



Yeah, i’ve tried that, what else do i need to give you to try and work this out? Thanks for the help anyways, I appreciate it.

The audio is coming through the peak metre but there is no sound coming through any audio devices, I’ve got the audio enabled as you put as well.

Please read this. :slight_smile:

Thank you, ill get onto that

Here is the information, i hope that this can help.

Shotcut Version number: Shotcut version 19.01.27

Shotcut Settings:
Cant Find GPU Effects
Video Mode: Automatic
Display Method: OpenGL

Operating System:
Windows 10 Pro

Computer Specifications:
Processor: Ryzen 7 1700X
Installed Physical Memory: 8GB
Available Physical Memory: 1.37GB

ScreenShot of Shotcut :

Source File Specifications:
Codec: H.264/ AVC / MPEG-4 AVC/ MPEG/4 part 10
Resolution: 1024x576
Frame Rate: 30
Bit Rate: Could Not Find

Export File Specifications:
Export present selected: Default
Resolution: 1024x576
Frame Rate: 30
Codec: libx264
Rate Control: Quality-based VBR
Quality: 59%

Can you describe the problem in more detail? Is this your first time using Shotcut? When you say that it doesn’t “output any audio” are you talking about when editing in Shotcut and playing video files? I see the audio peak meter in Shotcut in your pictures is registering audio. Have you tried exporting a video clip out of Shotcut and see if that exported plays its audio fine on a video player?

Have you tried using the volume slider?

I’ve tried adjusting that and nothing has happened, its still silence

The audio ends up working when i export the video and the video that i am importing to edit has the audio working just fine on it. And i have used shotcut before, i used to use it a lot and the audio worked perfectly but then one day i loaded it up and there was no audio, i tried reinstalling it and there was still no sound.

I see that you have Audio Channels set to “6”. Try setting it to “2” and see if that helps. maybe your system doesn’t like to receive multi-channel audio.

I tried setting it to two audio channels and there is still no sound coming through. I have also tried setting it to one audio channel also and had the same result

If you choose “View->Application Log”, it will open a dialog with a bunch of messages. Look for a message about “SDL”.

Mine shows:

[Info   ] <MLT> [consumer sdl2_audio] Audio Opened: driver=directsound channels=2


The message is printed right after you start playing. So the easy way to get the message is:

  1. Open shotcut
  2. Open a file
  3. Click play (or maybe it auto-plays)
  4. Verify the level meters moved up and down a little
  5. Open the application log
  6. Scroll to the end

Feel free to post the whole log as an attachment and we can look for errors in it.

I’ve had a look at the Application Log and this is what the line that you were asking for says:
[Info ] <MLT> [consumer sdl2_audio] Audio Opened: driver=xaudio2 channels=1 frequency=48000

The whole of the Application Log is below:
ShotcutLog.txt (27.6 KB)

Thanks for sharing the log file. You correctly found the audio driver line. Unfortunately, there are no error messages in the log to give any clues about what might not be working for you. All the log messages suggest that everything should be working properly.

Do you have access to a different computer that you can try it on - just to check out sanity? Maybe there is something specific about the hardware in your computer that is incompatible with Shotcut.

Yeah, thank you. Im gonna try and test it on a virtual box later to see if it has the same issue there and if it does then im gonna have to assume that its down to the hardware, thanks anyway

Try changing Settings > Audio Channels to Stereo and restart Shotcut.

I just tried doing that and still no sound coming from shotcut, i tried it on several different audio devices this time and still no sound working, thanks anyway

I think i’ve found the issue but dont know how to solve it, i can play the audio of shotcut through another device that works of headphone jack but when i try it on my headphones, which work of USB 3.0, no sound comes through the headphones at all. Is there anything i could do to fix this?

That’s good progress!

So the audio device on your computer is a USB device? Do you have an onboard sound device that you can use? if your computer has multiple sound devices, maybe Shotcut is using one that you aren’t connected to.