New release worst than last - shotcut-win64-191216

Before I never had crackly audio. Very crackly now, and continues through entire video.

Reverted to old version shotcut-win64-190816 and all is ok again.

Also, splash page is weird, and has been last several releases. screen is split in 1/2.

windows 10 home 10.0.18362 build 18362

Is there away to attach files? have screen snapshots if needed.

I have the same problem. I’m on windows 8 though, so it isn’t just for people on windows 10. Audio is all crackly. Dunno about the last part though, I’m not smart enough to understand that stuff.

Both of you have not posted enough information to help.
I have Windows 10, and I don’t have any problems with audio.

If you would like to find a solution, perhaps try reading the pinned support message at the top of the screen to learn what information is needed.

Alright. So first, I’m running the most recent version of shotcut.

Version 191216.

The video mode is HD 1080p 60fps.
I’m using the DirectX (ANGLE) display method.

Using windows 8.1, version 6.3.9600 build 9600. 64 bit.

My processor is a Intel® Core™ i5-4590 CPU @ 3.30GHz 3.30GHz.
I have 8 GB of installed physical memory (RAM).

I feel like a screenshot wouldn’t help an audio problem so I won’t include it.

The extension type for my source clips I used was mp4. The codec for my video appears to be H.246 / AVC / MPEG-4 part 10
The resolution is 1650x1050.
Framerate was 60fps.
I don’t know how to check bitrate, but the audio codec was AAC.

I don’t think export presets matter, but I just used default. I didn’t go into the advanced changer, and I do have hardware encoder checked.

As for the steps, all I have to do is open my clip into shotcut and the audio crackling appears. I do want to fix this so ill try to respond quickly if and when you respond.

Thanks again for helping

Have you tried making a custom video mode for your source resolution? 1650x1050 is not proportion to 1920x1080.

I’m suspecting with 8gb of memory, you may be running out of memory for all of the processing required for playback. Shotcut’s minimum memory specifications:
firefox_2019-12-25_15-13-23
If you only have one hard drive, and if that one hard drive is a physical HDD, you’re going to get a slower performance than if you have a SSD. If you’re drawing your source file or editing off of a USB drive/thumb drive, you’re limiting yourself even further in speed.

If you’ve applied filters, done transitions, and getting audio issues during preview, that’s normal to some degree. You haven’t stated under which conditions you’re experiencing issues.

Have you tried using the 32 bit version?
You can install multiple versions of Shotcut, just name the Shotcut folder when you are installing it.
explorer_2019-12-25_15-26-58

I’m suspecting that you’re experiencing hardware limitations at this point, and I may not be able to recreate the issues you’re having. I have 32gb on my system and I run with 2 SSD’s One for the operating system and one for recording/editing.

One other thing to check for is make sure your source video audio is in stereo.
2019-12-25_15-33-39
And it matches up with your Settings - Audio Channels
shotcut_2019-12-25_15-34-02

What is Settings > Realtime?
I haven’t observed a regression.

So, first off, my monitor only supports 1650x1050 which is why I have my clips in that way. I am used to applying filters and having the audio be a little slower, but this is something new that came after I updated shotcut to the current version. I currently am using the 32 bit version, and I will try to install a previous version of shotcut to see if it also happens on there too. Everything is in stereo and such.

I went back to the previous version. There is no audio problems that I am not used to. I think it had something to do with the update.

As stated, installed latest version and audio was crackly. To recreate, drag a .MTS video in and play.

I uninstalled current version and went back to previous version and problem went away. Previous version = 19.08.16. QT = 5.9.7

DeskTop resolution 1280x1024
Refresh rate 60hz
NVIDIA GeForce GTX 1060 6GB
BIos Version 86.6.39.0.60
Total Avail Graphic Memory 14313MB
Dedicated Video Memory 6144MB
Shared Video Memory 0mb
Sharted system Memory 8169 MB

DEVICE
Inter i7-7700K CPU @ 4.20GHzx
Installed Ram 16GB
System type 64-bit x64 processor
Windows 10 Home
Version 1903 Installed on 8/29/2019
OS BUILD 18362.535

SHOTCUT (in use, which is a working version. I do NOT EVER CHANGE SETTINGS )

INPUT VIDEO FILE FORMAT MTS
Video Mode HD 720p 50fps
Scrub audio checked
Realtime (frame dropping) checked
Progressive checked.

Export defaults H.264/AAC MP4 file.

Video Properties
Track 1: 1920x1080 h264
Codec H.264/AVC/MPEG-4 AVC/MPEG-4 part 10
Resolution 1920x1080
Frame Rate 29.970030
Format yuv420p
Aspect ratio 16: 9
Scan mode interlaced top field first
Color range Broadcase limited (MPEG)

Audio properties
Speed 1.0000000x
Track 1: 2ch 48Khz ac3
Codec ATSC A/52A (AC-3)
channels 2 stereo
Sample rate 48000
format fltp
Sync 0ms

Does it affect export or only preview?

Both.

Are you testing the export in Shotcut? If so, do not do that. Because of this bug, you need to test in a known good player for you such as Windows player or VLC.
Both of you mentioned going back to version 19.08, but do you know if the problem appeared first in 19.09, 19.10, or 19.12 releases?

See this related post

In version 19.09 we upgraded the FFmpeg codec library, which would affect both preview and export. In version 19.12, we upgraded the SDL2 audio library, which would affect only preview.

I went from 19.08 to 19.12, so I don’t know about the other versions.

I’m not 100% sure I tested the exported file, but I believe I did.

The reason being that I was hoping the crackly noise was only internal to Shotcut. So I would have used the default Windows Movies and TV Player.