My solution for changing aspect ratio

Just wanted to share my solution for changing aspect ratio from 4:3 to 16:9, and more importantly, removing black bars from video when exported.

  1. “New project” is set to “Automatic

  2. Add video which has 16:9 ratio - add it to timeline

  3. Add video that you want to edit - add/append it to timeline

  4. Open “Properties” of the video you are editing (“Video” tab), and from there change aspect ratio from 4:3 to 16:9

    Shotcut - change aspect ratio

  5. Remove first video (if you are not editing it), the one that “forced” Shotcut to create 16:9 project, and keep editing that 4:3 video and finally, export it.

This solution for me removed black bars from final video, and playing it in a player doesn’t require additional adjustments.

It does remove the black bars, but unless I’m missing a step, it also stretches the 4:3 video.
Most of the times it is not desirable.

1 Like

Maybe it has something to do with broadcasting technology. My video was originally .wtv (MPEG-2), recorded TV, and the portion of the program that was recorded before my desired show was in 4:3, the rest was 16:9 and that first part is the culprit for 4:3 export and black bars.

Video you have posted looks to me like something older, like the show was originally made before digital broadcasting, and when TV’s were 4:3. In my experience, older TV shows even when digitalized remain with that “old school” touch.

Hmm… I don’t know, it seems to me that whatever the type of clip, the age of the video, or the technology used, if its original aspect ratio is 4:3, it will look stretched if you edit to fit exactly in a 16:9 container.

It’s like trying to fit this 1440x1080 (4:3) image in a 1920x1080 (16:9) frame.

You seem convinced of your method, so please tell me where I’m wrong :slight_smile:

Basically, that’s what I said… It makes perfect sense that something that was made in 4:3 format looks stretched when in 16:9. Same thing happens when you shift through different viewing formats on your TV - picture is stretching differently with every option, and some of those options cut off edges of picture.

I have offered my solution because I’m annoyed by black bars and also don’t mind picture a bit stretched (don’t even notice it or pay attention to it - my export looks good to me). :sunglasses:

Just wanted to help…

The easier solution is to use a 16:9 Video Mode, then Size, Position & Rotate filter if you don’t mind stretched video.
Set Size Mode to Distort.

This post may help you further:

And further down in the same post:

Thank you for your help, but I’ve already came across this “crop” solution while browsing through this forum. Unfortunatelly, it’s not easier or quicker for me (don’t have enough attention span for it or something :smile: ).
The thing is, as I wrote earlier:

So, my desired recorded TV show was broadcasted in 16:9, but portion of TV program that was on air when recording started was broadcasted in 4:3. Video players (VLC or any other) start playing original .wtv file in 4:3 window, but then automatically switch to 16:9 window, when that show that was broadcasted in 4:3 ended. Unfortunatelly, that switch doesn’t happen in Shotcut, so my solution works for me, and I don’t think the final result has stretched video.

This topic was automatically closed after 90 days. New replies are no longer allowed.