More performance issues, lagging/freezing. Not sure why

Hi all, I’ve been having a hell of a time getting shotcut to run as well on my new high end pc as it did on my old phenom 2.

Today after I opened up my project it was super laggy even trying to get menu options to open was taking a couple of seconds. I was desperately trying to get a clip to shrink and it just locked up. I tried to just close shotcut but ended up having to let windows kill it.

To be safe I do a full reboot and try again. It was laggy but I was able to somehow shorten my clip but then as soon as I started scrolling to make sure I didn’t break things further down it just straight up froze on me again. This time it happened when I was trying to zoom in to figure out what this tiny clip that was on my timeline I couldn’t explain. Maybe it has something to do with zooming in? I have two tracks but V2 is hidden, Audio is on to help align tracks preview scaling set to 540, CPU and RAM aren’t getting hit hard and it’s not just the timeline but the actually shotcut menu controls that are lagging as well. Not sure what is going on.

These sound like OS problems more than Shotcut problems, especially since Shotcut worked fine on a separate PC.

Is Windows Defender running? It will scan every QML file that Shotcut compiles and attempts to run, and generally destroy Shotcut performance. It may be necessary to make a scan exception for your Shotcut directory. Same for any other anti-virus software running.

Are your video drivers up to date? If there is a problem or incompatibility with OpenGL drivers, then performance can suffer.

Are you importing files that are hours in length? Shotcut builds waveforms of the audio track in the background, which can slow things down until it finishes. Perhaps that is what’s going on.

Added exception to windows defender but didn’t see a difference, in fact it took longer for my project to open.

I have two tracks of the same length of which was a little over an hour. I turn video off on one but do leave sound on to make sure I’m keeping them synced as I edit. All files are in the edit friend h.264 codec. I’m using DirectX as the display method, as it was what shotcut defaulted to, but I just set it to automatic and restarted with no difference. According application log it would appear it is using OpenGL now.

[Info ] Mlt::GLWidget::initializeGL OpenGL vendor “NVIDIA Corporation”
[Info ] Mlt::GLWidget::initializeGL OpenGL renderer “NVIDIA GeForce RTX 3080/PCIe/SSE2”
[Info ] Mlt::GLWidget::initializeGL OpenGL threaded? true
[Info ] Mlt::GLWidget::initializeGL OpenGL ES? false
[Info ] Mlt::GLWidget::initializeGL OpenGL maximum texture size = 32768
[Info ] Mlt::GLWidget::initializeGL OpenGL maximum viewport size = 32768 x 32768

Shotcut in general is just running slow and has been, even tabbing to it sometimes takes a second to come up, and the menus are even slow once a project is loaded. I can’t switch to proxy mid edit but when I get to the next part I will try that to see if it solves all the problems as I’m running out of ideas.

I also can’t get fades to work on V2 for some reason.

Are you running any other Anti-Virus programs?
What are the Video Mode settings? Click on Output, then Properties to see settings.
What are the properties of the converted videos? Click on one clip, then Properties.

This could be a key factor. Try starting a new project, bring in two brand-new clips, and let the computer sit for about five minutes. Then try to start editing and see if Shotcut is more responsive. If it is, then there is potential that the temporary slowdown is due to Shotcut building waveform peaks in the background and the system is just busy.


Shotcut should not be getting slower with a Defender exception. It should be radically faster. Maybe there is a storage-level problem. Try running Resource Monitor or Performance Monitor and watch the I/O queue depth of all disks. If it ever gets above 10, then it’s the storage layer causing latency.

I agree that it sounds like there is something on the computer that is interfering. Maybe Windows Defender or maybe something else. Some time ago there was a forum user who had installed a GUI automation tool that hooked itself into every application and was not being friendly with Shotcut. Antivirus programs (like Defender) are the most common cause because they intercept the calls to open files and scan the file first.

I always run MS Defender without exceptions and never have a performance problem. Also I have never used a third party antivirus for the past 10 years. The problem here is very similar to reports by some others especially in October and November of 2020 with the last Qt library upgrade, but no one ever figured out the cause. Since then, I have bought a very low end and a new, mid-range computer both running Windows in addition to 2 other Windows systems without experiencing the problem.

Defender is most noticeable during startup when QML gets compiled to .qmlc (lots of small file reads and many new writes), and whenever dynamic libraries are loaded for the first time. For me, there aren’t many performance problems related to Defender once Shotcut is actually up and running. On some systems, especially after a fresh install, it can take up to three minutes of splash screen before the main window appears. From that point onward, the Qt library does seem to be a more likely culprit.

Sorry guys I’ve been tied up so didn’t have time to get back to this until just now. Oddly enough it seems to be working quite well now. Even when playing both tracks with the size and crop filters. The only difference is the length of the timeline. It went from 90 minutes to 21. Would that alone be an explanation? I assumed that it wouldn’t matter if I cut out an hours worth of footage because it’s technically still saved and it seemed laggy when I was working on it the other night. But today it seems fine despite me not changing anything even the menu lag went away. As for my queue length It never got above .03.

thanks for all the help, just really want to dial in on getting the right settings and using the right techniques to maximize performance. If it starts happening again I’ll try to do a screen recording of all of my running processes, disk performance, shotcut settings, etc.

The shotcut running slower part could very easily be wrong as it was just an estimate. Today I fired it up and somehow it is running better today despite no changes. Defender didn’t seem to change anything but I did leave that folder as an exception.

The fade on V2 was super annoying, no matter what I did I couldn’t get it to work, audio or video, but after a restart of shotcut that one did go away( just thought I’d mention it in case this every comes up in a google search).

Like most other technology, if it’s not working try unplugging it and plugging it back in.

This topic was automatically closed after 90 days. New replies are no longer allowed.