Logo does not show up when exporting with other resolution


I’ve narrowed something that looks like a bug:

My logo does not appear on the exported video when choosing a resolution not equal to the source resolution.

Source video is 1920x1080 [from a GOPRO 4].
When outputing to 1920x1080 : ok exported video is fine.
When outputing to 1280x720 : video is fine but without logo :frowning:

I already did the logo overlay a few months back so I know how to do it with Shotcut : add a second video track then drag the image and use “size and position” filter.

Here is a screenshot of my current test showing the issue :

In Shotcut GUI, everything’s fine.
The only thing I change is the export preset (just the resolution differs) and in one case it works fine, not in the other.

I just upgraded today to 18.07.02…
I was in 17.x, maybe 16.x before and export to either 1080p or 720p was fine.

The image is not resized. I’m just putting it on the bottom right corner.
I also tried to put it somewhere inside 1280x720 (middle of the screen) but same result : logo just doesn’t appear in 1280x720 export :cry:

It took me a while to find out why it was not working and make a smaller test…
(at first i though it was a composition or track order issue…)

I can provide the .mlt, video & picture if needed.
I’m on windows 10. “GPU Effects” are disabled in shotcut.

It’s showing your filter for Size & Position being 1920x1080, not 1280x720.
Is "logo_115.png a transparent png sized at 1920x1080?

The transparent .png is 115x112

I tried various settings with the size and position filter but no result.
The preset “bottom right” change the size so that’s me trying other settings on the capture. But none works.

V1: 1920x1080 PNG (Source)
V2: 64x64 PNG (Source)
Exported at 1920x1080 (1080p)

V1: 1920x1080 PNG (Source)
V2: 64x64 PNG (Source)
Exported at 1280x720 (720p)

Shotcut 18.07.02
Windows 10 Home
Frame capture from VLC Media Player.

Edited for better clarification for @titi.

I’m not sure what your trying to say but it’s not working in my specific scenario. Did you read about the resolution. what’s your input and output resolution ?
(because yeah it’s working when the output resolution matches the input resolution).

Let me show you step by step:

Step #1: empty track for the logo

Step #2: drag .png logo from explorer to player then drag to track

Step #3: add “size and position” filter
logo is automatically moved to left (was at center) and still way bigger than its size (whatever)

Step #4: use preset “bottom right”
it shows up like that with correct logo size:

Step #5: manually type the expected size : 115x112
logo shows up in the middle of the screen

When exporting after either step #3, #4 or #5 :

  • export in 1920x1080 : ok logo shows up
  • export in 1280x720 : logo does not show up :sob:

Then, if i remove or just disable the “Size and Position” filter
=> export in 720p works great : big logo in the video :stuck_out_tongue: !

[dammit new user can only attach 1 image per post, that is so useless
i had to put the images elsewhere…]

Try setting the position in the Size and Position filter to x=320 and y=180 in step 4 and export it at 1280x720.


Do the math. You’re trying to export something that’s not in the export window that’s why it’s not working.

Video Mode: Automatic (Selects the mode based upon image size)
When saved the mlt, it shows video%20mode%201080
Exported to 1920x1080 (Frame capture by VLC Media Player)

Exported to 1280x720 (Frame capture by VLC Media Player)

Just changed the export settings for both images.
Settings I used:

New Project
Set Video Mode to 720p (This has to be done before you import anything)
Import images

  • V1: 1920x1080 png
  • V2: 64x64 png
  • V3: svg graphic file

Apply filter to V2:

Apply filter to V3:

Exported at 1280x720 (Frame capture from VLC Media Player)

Yes, that’s why I tried Step #5, it should have work.

And now when I do it again it’s working fine -_-
I probably made a mistake during my tests.

And I didn’t remember having to change “Size & Position” filter settings previously when exporting to either 1080p or 720p. But maybe I did, it was several month ago.
The video is automatically resized, but the logo position is not relative when using bottom right…

Thank you for you assistance @Hudson555x & @sauron

This used to work in older versions of Shotcut because size and position info was saved used percentages, which would scale when you changed the resolution at export time (but it never worked for HTML-based filters because HTML is not such a simple thing to go into programmatically and adjust everything). Since the introduction of keyframes, Shotcut needed to start using some different APIs that is now saving the information using pixel values. I am aware of this and am working on a fix to save using percentages again, but I do not yet know if that change will make it into the next release v18.08 due next week. In the meantime, the general rule is - with a timeline-based project do not adjust the export resolution and best to set Settings > Video Mode at the start of the project.


Awesome, thank you for the technical explanation :smiley: