Issues with video resizing/rotate/zoom/resolution. Am I missing something?

Good afternoon, I’ve been using Shotcut for about a week now and I’m really enjoying the program so far. There’s one thing I seem to be having an issue with, and I cannot seem to find a solution. Perhaps someone here can help me out?

I have a video with a size of 1920x1080 and I would like to flip the video so it’s in vertical mode - 1080x1920. Easy enough. I create a custom video mode with the correct settings, add the Size, Position, & Rotate filter, and add a rotation of 90 degrees. Here’s where the issue lies - for some reason, the video shrinks down as soon as rotate is applied, but still shows a zoom of 100%. If I want to fill the black space now created by the rotate, I have to zoom into the video by an extra 80%. This is causing my video to lose sharpness/detail. I tried this with other video modes/videos, and I’m experiencing the same issue.

What am I doing wrong here? Why would the video shrink in size with a zoom of 100% if all I’m doing is rotating? If there’s no way to avoid this, is there any way to mitigate the loss of detail when zooming back in?

Use Properties > Rotation to correct orientation.

1 Like

I see! I likely missed this because I was clicking on the track and not the video file in the timeline. Clicking the track displays nothing, whereas the video file brought up the related properties.

Thank you for the speedy reply. It is greatly appreciated.

A related question that I’m running into and sort of touches on the original issue - if I use the crop filter to crop the 1920x1080 video down to 1080x1080 and switch the video mode to reflect the new 1.1 square format, how would I prevent Shotcut from reverting back to the 1920x1080 sizing and shrinking the landscape format to fit inside the square? I’ve adjusted resolution in properties and various settings in the size/position/rotate filter, but the only way I’ve found so far is to zoom in to fit. I’m trying to avoid that.

Use the Crop: Source Video Filter

Edit

That did it. I was using Crop: Square. Beginners idiocy over here.

Thank you again for the assistance.