Issues with Size/Position/Rotation

What is your operating system?
Windows 11

What is your Shotcut version (see Help > About Shotcut)? Is it 32-bit?
21.10.31

Can you repeat the problem? If so, what are the steps?
(Please be specific and use the names as seen in Shotcut, preferably English. Include a screenshot or screen recording if you can. Also, you can attach logs from either View > Application Log or right-click a job and choose View Log.)

When I add Size/Position/Rotation to a vertical video (on the V1 layer) and export it, the V1 layer resizes back to the original size

Sorry but I do not understand how to reproduce it from the information you have provided. It is probably not a bug, and maybe you attached the filter to the wrong thing such that you see something (in Source player?) that is different than what you are exporting (e.g. timeline).

Perhaps this is a case of having the wrong Video Mode. If it is not, then please provide all steps to duplicate.

Everything with layers or tracks with Shotcut is defined by the Video Mode. The Video Mode is like the canvas to a painting. This has to be the first decision made when working with video.

Shotcut’s default setting is “Automatic”. If left in Automatic, if the first video you bring in is vertical, say 1080x1920 (resolution), the Video Mode is set to that resolution. Any filters, or any other video’s are bound to that resolution.

I can only guess you left it in Automatic, and you may have a 1080x1920 video.

First step, is set the video mode to a preset of 1080p.
shotcut_2021-11-17_14-47-39

Second step is to open your video in Shotcut.
This is what it will look like in the preview:
shotcut_2021-11-22_15-34-57

Third step is to then apply the Size, Position & Rotate filter.
Rotate the video.
Then change this setting to 1080 (the other settings box will auto calculate)

For my test, I used the HD 1080p25 16:9 video mode, opened a vertical video, added it to V1, added a Size Position & Rotate filter, zoomed in a bit to fill the frame more, and exported using defaults. Viewing the export result looks the same as what I see in the Shotcut player’s Project tab.

I did it. (I sent you the print), it changes itself, it doesn’t set to 1080x1920.

The screenshot you sent me shows you rotating a 1920x1080 to 1080x1920 with a video mode of 1920x1080.

You also have keyframes activated for some reason, with at least 1 keyframe set for the Size & Position. It’s not shown if you have any other keyframes set. Keyframes is not needed to rotate a video, unless you are after some visual effect during the video.

Since you sent me a screenshot in private, I have blurred the images and file name.

Would it be related to the original source content being in 1920x1080? I’ll take screenshots of the project when I can a bit later