Incorrect Audio Waveforms Loading (with workaround)

What is your operating system?: Windows 10 Pro, Version 1909 (64-bit) (Version 2004 not currently available for my system)

Shotcut Version: Version 20.11.28, 64-bit (.exe install)

Can you repeat the problem?: No, all testing I had tried has failed to replicate the issues (testing mentioned below).

Bug (See Screenshots Below):

  • When I open a project, occasionally, several waveforms either fail to load or display incorrectly for the clip they are on (I have had this bug on many different projects).
  • This bug occurs when opening a previously saved project and is more frequent, but not limited to projects that include clips where their speed is greater than 1x .
  • Using/not using proxies has no effect on this bug.
  • As the bug occurs when a project is first opened, I think it could be related to initial data that Shotcut loads to populate the timeline (Shotcut somehow loads the incorrect waveform data that is overlayed on the clips?)

My Workaround/Hotfix:

  • Using the Rebuild Audio Waveform on each affected clip solves the issue (this can get tedious when the timeline contains many clips).
  • The existing Rebuild Audio Waveform option in Shotcut 20.11.28 is less likely to work on clips when their speed is higher than 1x (the higher the multiplier, the less likely the rebuild will work).
  • *I have made a Suggestion post regarding a new feature that would make the rebuild process more efficient for editors: Add 'Rebuild All Audio Waveforms' Option?

Testing I’ve Done:

  • Saving/opening projects (15 mins or longer) that contain time-lapse footage - Issue persists
  • Saving/opening a new project with clips added as a control - unable to reproduce this bug
  • Add footage to the Timeline and increased its Speed - unable to reproduce this bug
  • Reinstalling Shotcut entirely (clearing cache, settings etc.) – Issue persists
  • Editing on a different computer – Issues persists (possible a project-specific bug?)
  • Proxy enabled/disabled – Issue persists
  • Relocating timeline footage, and redirecting Shotcut to new location – issue persists
  • Tried using the Reload option – issue persists (not sure what this feature does?)

From my testing, the issue appears to be project-specific (XML/*.mlt) as the affected project still have this issue on different machines, but I cannot find the trigger that causes an unaffected project to become affected.

My System Specs (if relevant?):

  • i7-6950x (10 Core, 20 thread)
  • 32GB DDR4 RAM
  • RTX 2060 (6GB GDDR6)
  • 500GB, Samsung 970 EVO (M.2 NVMe) (Boot Drive & Proxy Cache)
  • 1TB, HGST HDD (SATA) (Editing Storage)
  • 2TB, Seagate BarraCuda Compute (SATA) (Other Storage)
  • *All hardware clock speeds are at stock – I favour stability over performance

If there is any extra information you need, feel free to comment and I will get back to you with it!

Are you running more than one instance of Shotcut? You should check the Task Manager Details view sorted by name to look for other possibly hidden dead processes.

Thanks for the reply, not that I am aware of, Task Manager just shows the one instance of Shotcut open, and no other background processors are running that relate to Shotcut either.

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.