I cannot get additional video clips to open on the timeline

What is your operating system?
Windows 10

What is your Shotcut version (see Help > About Shotcut)? Is it 32-bit?

Can you repeat the problem? If so, what are the steps?
(Please be specific and use the names as seen in Shotcut, preferably English. Include a screenshot or screen recording if you can. Also, you can attach logs from either View > Application Log or right-click a job and choose View Log.)
I use Shotcut to edit my videos and I normally have several clips that have to be put together and photos to add at the end. I updated Shotcut to the new version this morning and now I cannot get the new clips to open on the timeline. I have tried drag and drop and I have tried copy and paste to get it to go on the timeline but every time I try to add it (no matter how I do it) it puts the last clip I was working on at the end…like it is copying that one. I have to exit the whole system and reopen it to be able to get the next clip to open on the timeline so I can work on it. Please help.

The bug you are reporting was already reported a few times and fixed. You are not running the newest version. The newest is 21.09.13; please upgrade to it.

Thank you, I’m sorry, I thought I had downloaded the latest version.