How to smooth jagged edges in the Export?

Hello there,

I have been working for several days now on a compilation video of photos and when I exported it the edges of text and photos are really jagged. I read that the anti aliasing should take care of this on export, but my exported video looks the same as the preview.

How can I fix this?

Here is a short clip from the full video: https://youtu.be/RSqSacZ820E

In order for someone to help you are going to have to give more information, such as:

  • What were the export parameters you used?
  • Did you use hardware encoding?
  • If so what hardware did you use?

It looks like SD upscaled to 1080p. What is the video mode used for the project? Did you change the resolution in Export > Advanced > Video?
Was the text and animated motion of the photo created in Shotcut?

I am sorry. I should have been more specific. This is my first post, and I have been trudging through that project for so long now I wasn’t thinking big picture when I asked the question. Under Settings>Project>Video It looks like it is set to Non-broadcasting 640 X 480 4:3 NTSC. I don’t recall choosing this.

I tried exporting it both ways using Hardware encoding and without out with similar results. h264_qsv and hevc_qsv are checked under the configure menu.

I tried exporting it multiple times. Originally I just used the default (I am sorry, don’t know what that was now). The latest one I used these parameters from a suggestion online about getting a high quality output).

So I guess I did change it from the original for the project. Is there a way to fix that?

The text and animated motion for the pictures were created in shotcut. They are high quality jpgs with fade in, fade out, and one of the presets for the Size, Position and Rotate filters applied.

Thank you guys for your fast response.

Probably because you had it at the default Automatic, which uses the first thing you added, which was a low resolution video (640x480). I do not know what Video Mode to recommend since I do not know if you want to stay with 4:3 aspect ratio or go with the more common today 16:9. In any case, composing at a low resolution and then up-scaling the result, which is what you did, is not going to look good and you need to change the Video Mode. However, it will require you to redo the size and position of things in your project.

I do want the more standard 16:9. :tired_face:

So would I just change it under the project settings, and rework everything? Or should I start over from scratch?

This is a compilation of a live stream feed (which isn’t super clear even though I had 1080p webcams :slightly_frowning_face: ), and high quality jpgs from a photographer. Any recommendations for video mode for that kind of project?

Personally I would create the project as 1080p with a framerate that matches your webcam footage.

Try a small project wit just a couple of clips, export it using the “default” preset and check the output before going any further.

I actually did end up doing just that last night, and it looked the way that I was going for. Thanks for you guys’ help!

I am not sure if I marked the proper comment as the solution for the thread. Should It be the the one that identified the source of the issue I experienced, or what I ended up doing in the end? I am just not sure of the etiquette, and I want to make sure the post can help others in the future.